At Wed, 27 Aug 2008 10:37:08 -0400,
rick pim wrote:

> 9.4.2b2, solaris 5.10 compiled with the vendor's gcc:
>
> 27-Aug-2008 02:24:36.126 general: critical: resolver.c:5494: REQUIRE((((query) != 0) && (((const isc__magic_t *)(query))->magic == ( (('Q') << 24 | ( '!') << 16 | ( '!') << 8 | ( '!')))))) failed
> 27-Aug-2008 02:24:36.126 general: critical: exiting (due to assertion failure)
>
> unfortunately, i have no core file. i see from the archives that this (or
> something like it) has been seen before but no resolution is known. is
> an approximate date for 9.4.3 known at this time and is this issue
> addressed there?


Try the patch at:
http://www.jinmei.org/patch/dispatch.c.diff

It will also appear in the next beta for 9.4.3, but the release is
being deferred to prioritize fixing troubles of the Windows version.

---
JINMEI, Tatuya
Internet Systems Consortium, Inc.