There was a post made about a year ago regarding this rndc reconfig issue
(shown below).
From my understanding it seems that if you compile named with
"--enable-threads" and if you start the name server with "-n #" (where the
number is larger than 1) then you should be able to do a "rndc reconfig"
without a good deal of downtime.
Is this correct or not?
From trying this on a good amount of zones there is still the same amount of
downtime as doing "rndc reload".
I have tried this on RHEL, FreeBSD 6.1, NetBSD, Gentoo, Debian, and
Mandrake. All function the exact same way.

Can this timeout be prevented in anyway?
I've seen this question asked numerous times without a definate answer, so I
thought I would just ask it one more time.

If anydone does have this working, what were the compile options and the
startup options that you used?




On 11/09/05, Paul Vixie wrote:

> Tavis Gustafson writes:
>
> > Hello all. We currently run bind9 on 3 auth dns servers, one primary,
> > two secondaries. With over 100k domains, any time we do rndc reconfig
> > on master or rndc reload on secondaries, we get lookup timeouts of up to

>
> > 30 seconds. Even with staggering the updates on primary and secondaries

>
> > it's getting to be a real problem.

>
> 9.3.1, built with threads on anything but freebsd<6.0, should make this
> better.
>
> 9.4.0, built with threads on anything but freebsd<6.0, *will* make this
> better.
>


Thanks for any help.
-jm