bind-9.3.2 / CPU issue. - DNS

This is a discussion on bind-9.3.2 / CPU issue. - DNS ; Hi list, I currently run bind version 9.3.2 on a machine : Mem: 3108468k total Swap: 2097136k total Cpu: dual Intel(R) Xeon(TM) CPU 2.80GHz I have four of these boxes running as caching nameservers for my customers. I get about ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: bind-9.3.2 / CPU issue.

  1. bind-9.3.2 / CPU issue.



    Hi list,

    I currently run bind version 9.3.2 on a machine :

    Mem: 3108468k total
    Swap: 2097136k total
    Cpu: dual Intel(R) Xeon(TM) CPU 2.80GHz

    I have four of these boxes running as caching nameservers for my customers. I get about 600 queries/second on each machine. After x amount of time my cpu usage peeks to 100%
    resulting in _real_ slow responses, the problem doesn't go away from itself, I need to restart named to get this fixed. All four machines have this issue. I tried several upgrades,
    tuning config options like max-cache-size, max-ncache-ttl ... still no result. I do use an ACL to restrict users based on ip, tried to disable that to for a while, but still with no result.

    Is there someone with the same issue ? Or some good tips ?

    Thanks,
    Wesley.

    --
    (o_ Wesley Hof
    //\ UNIX System Engineer
    V_/_ Scarlet Belgium



  2. Re: bind-9.3.2 / CPU issue.


    Wesley Hof wrote:
    > Hi list,
    >
    > I currently run bind version 9.3.2 on a machine :
    >
    > Mem: 3108468k total
    > Swap: 2097136k total
    > Cpu: dual Intel(R) Xeon(TM) CPU 2.80GHz
    >
    > I have four of these boxes running as caching nameservers for my customers. I get about 600 queries/second on each machine. After x amount of time my cpu usage peeks to 100%
    > resulting in _real_ slow responses, the problem doesn't go away from itself, I need to restart named to get this fixed. All four machines have this issue. I tried several upgrades,
    > tuning config options like max-cache-size, max-ncache-ttl ... still no result. I do use an ACL to restrict users based on ip, tried to disable that to for a while, but still with no result.
    >
    > Is there someone with the same issue ? Or some good tips ?
    >
    > Thanks,
    > Wesley.
    >
    > --
    > (o_ Wesley Hof
    > //\ UNIX System Engineer
    > V_/_ Scarlet Belgium


    What OS and what version do you use ? What NIC is used ?
    What does netstat -i and netstat -a shows ?



+ Reply to Thread