> On Jul 11, 2008, at 4:41 AM, Dan Holler wrote:
>
> > Dave -
> > I am running the same version, on AIX 5.3, had no problems with the
> > compile, with the following tools, perhaps this will help.
> >
> > # oslevel -s
> > 5300-08-01-0819
> >
> > # gcc -v
> > Using built-in specs.
> > Target: powerpc-ibm-aix5.3.0.0
> > Configured with: ../configure --with-as=/usr/bin/as
> > --with-ld=/usr/bin/ld --enable-languages=c,c++,java
> > --prefix=/opt/freeware --enable-threads
> > --enable-version-specific-runtime-libs --host=powerpc-ibm-aix5.3.0.0
> > --target=powerpc-ibm-aix5.3.0.0 --build=powerpc-ibm-aix5.3.0.0
> > --disable-libjava-multilib
> > Thread model: aix
> > gcc version 4.2.0
> >
> > # lslpp -w `which make`
> > File Fileset Type
> >
> > ---------------------------------------------------------------------------

> -
> > /usr/bin/make bos.adt.base
> > Symlink

>
>
>
> D'oh! There it is, here's what I had ...
>
>
> > $ oslevel -s
> > 5300-07-04-0818
> > $ gcc -v
> > Using built-in specs.
> > Target: powerpc-ibm-aix5.1.0.0
> > Configured with: ../configure --with-as=/usr/bin/as --with-ld=/usr/
> > bin/ld --disable-nls --enable-languages=c,c++ --prefix=/opt/freeware
> > --enable-threads --enable-version-specific-runtime-libs --
> > host=powerpc-ibm-aix5.1.0.0
> > Thread model: aix
> > gcc version 4.0.0
> > $

>
>
> That can't be good (gcc was built for 5.1 instead of 5.3 and was more
> dated). OK, upgrade gcc to a proper version ...
>
>
> > $ gcc -v
> > Using built-in specs.
> > Target: powerpc-ibm-aix5.3.0.0
> > Configured with: ../configure --with-as=/usr/bin/as --with-ld=/usr/
> > bin/ld --enable-languages=c,c++,java --prefix=/opt/freeware --enable-
> > threads --enable-version-specific-runtime-libs --host=powerpc-ibm-
> > aix5.3.0.0 --target=powerpc-ibm-aix5.3.0.0 --build=powerpc-ibm-
> > aix5.3.0.0 --disable-libjava-multilib
> > Thread model: aix
> > gcc version 4.2.0
> > $

>
>
> OK, trying again ... I ran "make distclean" (figuring it couldn't
> hurt) and "./configure" successfully and this time "make" ran for
> considerably longer ... until ...
>
>
> > gcc -I/home/dave/projects/bind/bind-9.4.2-P1 -I./include -
> > I./unix/include -I/home/dave/projects/bind/bind-9.4.2-P1/lib/lwres/
> > include -I../../lib/lwres/unix/include -I../../lib/lwres/include -
> > I/home/dave/projects/bind/bind-9.4.2-P1/lib/dns/include -I../../lib/
> > dns/include -I/home/dave/projects/bind/bind-9.4.2-P1/lib/bind9/
> > include -I../../lib/bind9/include -I/home/dave/projects/bind/
> > bind-9.4.2-P1/lib/isccfg/include -I../../lib/isccfg/include -I/home/
> > dave/projects/bind/bind-9.4.2-P1/lib/isccc/include -I../../lib/
> > isccc/include -I/home/dave/projects/bind/bind-9.4.2-P1/lib/isc/
> > include -I../../lib/isc -I../../lib/isc/include -I../../lib/isc/
> > unix/include -I../../lib/isc/pthreads/include -I../../lib/isc/
> > powerpc/include -D_REENTRANT -D_THREAD_SAFE -g -O2 -W -Wall -
> > Wmissing-prototypes -Wcast-qual -Wwrite-strings -Wformat -Wpointer-
> > arith -fno-strict-aliasing -c lwsearch.c
> > gcc -g -O2 -o named builtin.o client.o config.o
> > control.o controlconf.o interfacemgr.o listenlist.o log.o
> > logconf.o main.o notify.o query.o server.o sortlist.o tkeyconf.o
> > tsigconf.o update.o xfrout.o zoneconf.o lwaddr.o lwresd.o
> > lwdclient.o lwderror.o lwdgabn.o lwdgnba.o lwdgrbn.o lwdnoop.o
> > lwsearch.o unix/os.o ../../lib/lwres/liblwres.a ../../lib/dns/
> > libdns.a -lcrypto ../../lib/bind9/libbind9.a ../../lib/isccfg/
> > libisccfg.a ../../lib/isccc/libisccc.a ../../lib/isc/libisc.a -
> > lnsl -lpthread
> > ld: 0711-317 ERROR: Undefined symbol: .RSA_generate_key_ex
> > ld: 0711-317 ERROR: Undefined symbol: .DSA_generate_parameters_ex
> > ld: 0711-317 ERROR: Undefined symbol: .DH_generate_parameters_ex
> > ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more
> > information.
> > collect2: ld returned 8 exit status


You have new openssl header (0.9.8) files being found but the old crypto
library (0.9.7).

> > make: 1254-004 The error code from the last command is 1.
> >
> >
> > Stop.
> > make: 1254-004 The error code from the last command is 1.
> >
> >
> > Stop.
> > make: 1254-004 The error code from the last command is 1.
> >
> >
> > Stop.
> > $

>
>
> Shoot, this sounds like I'm still missing something. Openssl version
> (in case it matters) is ...
>
>
> > $ openssl version
> > OpenSSL 0.9.8f 11 Oct 2007
> > $

>
>
> Many thanks to all for suggestions both already given and yet to come.
>
>
>
> Dave Stewart
> Aqua~Flo Supply (Goleta CA)
> dstewart at aquaflo dot com
>
> A computer once beat me at chess,
> but it was no match for me at kickboxing!
>
>
>

--
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742 INTERNET: Mark_Andrews@isc.org