I'm pretty ignorant when it comes to dns and bind... but I did have
something working in the lab under Centos 4.3. After doing a "yum
update" to centos 4.6, the dns server is no longer responding to
outside requests. I noticed in the yum log that some bind packages
were updated, but I really have no idea what is going on.

the sympton:
[10:55:22am - asus-laptop - ~] dig @192.168.2.3 tails

; <<>> DiG 9.4.1-P1 <<>> @192.168.2.3 tails
; (1 server found)
;; global options: printcmd
;; connection timed out; no servers could be reached


the tests:
[root@mario ~]$ service named restart
Stopping named: [ OK ]
Starting named: [ OK ]

[root@mario ~]$ tail -20 /var/log/messages
Jul 8 11:06:36 mario named[6220]: stopping command channel on
127.0.0.1#953
Jul 8 11:06:36 mario named[6220]: no longer listening on 127.0.0.1#53
Jul 8 11:06:36 mario named[6220]: no longer listening on
192.168.2.3#53
Jul 8 11:06:36 mario named[6220]: exiting
Jul 8 11:06:37 mario named: succeeded
Jul 8 11:06:39 mario named[6263]: starting BIND 9.2.4 -u named -t /
var/named/chroot
Jul 8 11:06:39 mario named[6263]: using 1 CPU
Jul 8 11:06:39 mario named[6263]: loading configuration from '/etc/
named.conf'
Jul 8 11:06:39 mario named[6263]: listening on IPv4 interface lo,
127.0.0.1#53
Jul 8 11:06:39 mario named[6263]: listening on IPv4 interface eth0,
192.168.2.3#53
Jul 8 11:06:39 mario named[6263]: command channel listening on
127.0.0.1#953
Jul 8 11:06:39 mario named[6263]: zone 0.in-addr.arpa/IN: loaded
serial 42
Jul 8 11:06:39 mario named[6263]: zone 0.0.127.in-addr.arpa/IN:
loaded serial 1997022700
Jul 8 11:06:39 mario named[6263]: zone 255.in-addr.arpa/IN: loaded
serial 42
Jul 8 11:06:39 mario named[6263]: zone
0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0. 0.0.0.0.0.0.ip6.arpa/
IN: loaded serial 1997022700
Jul 8 11:06:39 mario named[6263]: zone localdomain/IN: loaded serial
42
Jul 8 11:06:39 mario named[6263]: zone localhost/IN: loaded serial 42
Jul 8 11:06:39 mario named[6263]: running
Jul 8 11:06:39 mario named: named startup succeeded
Jul 8 11:06:52 mario mountd[3352]: authenticated unmount request from
donkeykong:896 for /user0/webcams (/user0)

[root@mario ~]$ ps -Af | grep named
named 6263 1 0 11:06 ? 00:00:00 /usr/sbin/named -u
named -t /var/named/chroot
root 6276 6073 0 11:07 pts/0 00:00:00 grep named

[root@mario ~]$ named-checkconf /etc/named.conf
[root@mario ~]$

can anyone see anything obvious here without me posting my
named.conf? any ideas about something that may have changed in the
last couple of years that will require some changes/updates/additions
to my config file?


FG