Barry Margolin wrote:

>In article ,
> RYAN vAN GINNEKEN wrote:
>
>
>
>>Everything was going great until my client upgraded his cable modem and
>>got a new ip from his/our ISP this caused me to make changes to my dns
>>files. Now i am missing something i am sure it is very simple but have
>>spent weeks trying to make sense of it. I hate to bother the gurus of
>>this list with my problems but am at my wits end and do not know where
>>else to turn thank you in advance.
>>
>>here is my problem
>>all these sites used to work fine internally and externally alike
>>shoemasters.com hosted externally at
>>68.144.196.18 but use ns1.computerking.ca as there primary ns
>>graemehill.com hosted externally at
>>68.144.196.18 but use ns1.computerking.ca as there primary ns
>>classicautographics.com virtually hosted at my site
>>computerking.ca ip # 68.144.204.152
>>ybotstudios.com virtually hosted at my site
>>computerking.ca ip # 68.144.204.152
>>
>>When i do a external ns lookup i get this for shoemasters.com the first
>>
>>

>
>Haven't you been on this list long enough to learn that nslookup is
>*not* the right tool for debugging DNS. You must have read a zillion
>times that "dig" is better. Why do you persist in using that piece of
>crap when you know there's a better way?
>
>

Ok ok i swear i will never use nslookup again only dig and THANKS a
million for helping me anyway.

>
>
>>thing i notice is the Non-authoritative answer: that is bad right means
>>something is mis configured right. The next thing is the ip address
>>
>>

>
>No, it's normal to get a non-authoritative response from a caching
>server. You should only expect an authoritative response when you query
>one of the authoritative servers (master or slave). If you get a
>non-authoritative response from one them them *then* you know something
>is wrong.
>
>
>
>
>>68.144.231.38 that is the old ip i swear it is not in my records
>>anywhere. It should be and i believe all my records on
>>ns1.computerking.ca and the slave ns1.shoemasters.com point to
>>68.144.196.18. The lookups for classicautographics.com,
>>ybotstudios.com, and graemehill.com are all very similar to the one
>>below with the wrong ip.
>>
>>Non-authoritative answer:
>>shoemasters.com nameserver = ns1.computerking.ca.
>>shoemasters.com nameserver = ns1.shoemasters.com.
>>
>>

>
>Why don't you have ns1.shoemasters.com listed in the delegation of the
>domain on the GTLD servers?
>
>
>
>
>>
>>Authoritative answers can be found from:
>>shoemasters.com nameserver = ns1.shoemasters.com.
>>shoemasters.com nameserver = ns1.computerking.ca.
>>ns1.shoemasters.com internet address = 68.144.231.38
>>
>>
>>So i do a nslookup of computerking.ca not both of these are external
>>lookups using ns1.kloth.net. Again i get Non-authoritative answer: and
>>most puzzling mail1.shoemasters.com has the right address but
>>ns1.shoemasters.com does not. I check my records they are correct i
>>think have the same address 68.144.196.18 for both ns1.shoemasters.com
>>and mail1.shoemasters.com.
>>
>>

>
>It's coming from the glue record on the GTLD servers, due to the host
>registration of NS1.SHOEMASTERS.COM:
>
>$ whois -h whois.internic.net ns1.shoemasters.com
>
>Whois Server Version 1.3
>
>Domain names in the .com and .net domains can now be registered
>with many different competing registrars. Go to http://www.internic.net
>for detailed information.
>
> Server Name: NS1.SHOEMASTERS.COM
> IP Address: 68.144.231.38
> Registrar: TUCOWS INC.
> Whois Server: whois.opensrs.net
> Referral URL: http://domainhelp.tucows.com
>
>
>

My interface for nameservers seems to be at telushosting.com rather than
TUCOWS. That is what i have a username and password for also a dialog
to enter nameservers. However their interface is sucky and does not
allow you to enter ip's only names i have waited for 10 days and every
time i enter the name ns1.shoemasters.com it adds the old 68.144.231.38
address. So i have removed it and am running shoemasters.com on only
one nameserver ns1.computerking.ca seems that shoemasters.com has the
right address but ns1.shoemasters.com does not. I have emailed telus
hosting and they assure me that the ip will update and i should just
wait longer (more than 10 days???).

>>here are the internal lookups i get the same thing for all the above
>>mentioned domains. What did i do ????? how do fix??? thought about
>>adding internal views for those domains but they are not really internal
>>are they??????
>>
>>tokyo.computerking.ca > /usr/local/etc/namedb/pz #nslookup shoemasters.com
>>Server: computerking.ca
>>Address: 192.168.0.202
>>
>>*** computerking.ca can't find shoemasters.com: Non-existent host/domain
>>
>>Also i can see the web pages for all the listed domains but cannot get
>>nslookup to find them. Please help
>>
>>

>
>A client can only access the zones that are listed in the view that it
>matches. So if you want internal clients to be able to see the public
>zones, you need to include them in both views.
>
>
>

Knowing these are dumb questions please do not be to upset with me for
asking. How come the domains worked before internally without adding
them to the internal view? If shoemasters.com is hosted from a
different ip does it not make it external or is it still considered
internal should my local name server not query external names servers
like when i lookup google.ca, yahoo.com, or any other address on the
web that i look up?