Everything was going great until my client upgraded his cable modem and
got a new ip from his/our ISP this caused me to make changes to my dns
files. Now i am missing something i am sure it is very simple but have
spent weeks trying to make sense of it. I hate to bother the gurus of
this list with my problems but am at my wits end and do not know where
else to turn thank you in advance.

here is my problem
all these sites used to work fine internally and externally alike
shoemasters.com hosted externally at
68.144.196.18 but use ns1.computerking.ca as there primary ns
graemehill.com hosted externally at
68.144.196.18 but use ns1.computerking.ca as there primary ns
classicautographics.com virtually hosted at my site
computerking.ca ip # 68.144.204.152
ybotstudios.com virtually hosted at my site
computerking.ca ip # 68.144.204.152

When i do a external ns lookup i get this for shoemasters.com the first
thing i notice is the Non-authoritative answer: that is bad right means
something is mis configured right. The next thing is the ip address
68.144.231.38 that is the old ip i swear it is not in my records
anywhere. It should be and i believe all my records on
ns1.computerking.ca and the slave ns1.shoemasters.com point to
68.144.196.18. The lookups for classicautographics.com,
ybotstudios.com, and graemehill.com are all very similar to the one
below with the wrong ip.

Non-authoritative answer:
shoemasters.com nameserver = ns1.computerking.ca.
shoemasters.com nameserver = ns1.shoemasters.com.

Authoritative answers can be found from:
shoemasters.com nameserver = ns1.shoemasters.com.
shoemasters.com nameserver = ns1.computerking.ca.
ns1.shoemasters.com internet address = 68.144.231.38


So i do a nslookup of computerking.ca not both of these are external
lookups using ns1.kloth.net. Again i get Non-authoritative answer: and
most puzzling mail1.shoemasters.com has the right address but
ns1.shoemasters.com does not. I check my records they are correct i
think have the same address 68.144.196.18 for both ns1.shoemasters.com
and mail1.shoemasters.com.

DNS server handling your query: ns1.kloth.net
DNS server's address: 213.133.98.149#53

Non-authoritative answer:
Name: computerking.ca
Address: 68.146.204.152
computerking.ca mail exchanger = 20 mail1.shoemasters.com.
computerking.ca mail exchanger = 10 mail1.computerking.ca.
computerking.ca
origin = ns1.computerking.ca.
mail addr = root.computerking.ca.
serial = 2005010202
refresh = 1200
retry = 120
expire = 1209600
minimum = 3600
computerking.ca nameserver = ns1.shoemasters.com.
computerking.ca nameserver = ns1.computerking.ca.

Authoritative answers can be found from:
computerking.ca nameserver = ns1.shoemasters.com.
computerking.ca nameserver = ns1.computerking.ca.
mail1.computerking.ca internet address = 68.146.204.152
mail1.shoemasters.com internet address = 68.144.196.18
ns1.shoemasters.com internet address = 68.144.231.38


here are the internal lookups i get the same thing for all the above
mentioned domains. What did i do ????? how do fix??? thought about
adding internal views for those domains but they are not really internal
are they??????

tokyo.computerking.ca > /usr/local/etc/namedb/pz #nslookup shoemasters.com
Server: computerking.ca
Address: 192.168.0.202

*** computerking.ca can't find shoemasters.com: Non-existent host/domain

Also i can see the web pages for all the listed domains but cannot get
nslookup to find them. Please help