On Thu, Oct 07, 2004 at 07:29:58AM -0700, saravanan ganapathy wrote:
> Hai,
> Due to some reasons, still I am using RH6.2 where
> bind8.2 is running. Now I need to upgrade to bind 9.x
> and got the following error when I start named after
> upgradation
>
> # /etc/rc.d/init.d/named start
>
> Starting named: named: -u not supported on Linux
> kernels older than 2.3.99-pre3 or 2.2.18 when using
> threads
>
> [FAILED]
>
> If I haven't specified '-u named' option in named
> script, then it will try to start bind as root user.
>
> Is there any way I can run bind using 'named' user?


Rebuild BIND and add --disable-threads to the ./configure args

Steve

--
Stephen J Friedl | Security Consultant | UNIX Wizard | +1 714 544-6561
www.unixwiz.net | Tustin, Calif. USA | Microsoft MVP | steve@unixwiz.net