Bug#504760: s390 installer doesn't work on 3215 console running as a VM guest - Debian

This is a discussion on Bug#504760: s390 installer doesn't work on 3215 console running as a VM guest - Debian ; Package: debian-installer Version: 20081029 The latest version of the installation program for the s390 architecture (for lenny/sid) doesn't work when running on a 3215 virtual console as a guest of z/VM. In this installation method, the installer performs some initial ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Bug#504760: s390 installer doesn't work on 3215 console running as a VM guest

  1. Bug#504760: s390 installer doesn't work on 3215 console running as a VM guest

    Package: debian-installer
    Version: 20081029

    The latest version of the installation program for the s390 architecture
    (for lenny/sid)
    doesn't work when running on a 3215 virtual console as a guest of z/VM.
    In this installation method, the installer performs some initial steps,
    such as configuring the network device and configuring the network, while
    using the 3215 virtual console. Then the installation switches to a
    network console (ssh session) for the rest of the installation. The
    trouble is that the installer seems to be treating the 3215 virtual console
    as an ANSI terminal. I see a bunch of stuff which appears to be ANSI
    escape sequences. This used to work, but something broke it. The
    installer must use a line-mode interface while running on the 3215 virtual
    console. I cannot get past this.

    --




    --
    To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Bug#504760: s390 installer doesn't work on 3215 console running as a VM guest

    reassign 504760 rootskel 1.66
    severity 504760 serious
    thanks

    On Thursday 06 November 2008, zlinuxman@wowway.com wrote:
    > The latest version of the installation program for the s390
    > architecture (for lenny/sid)
    > doesn't work when running on a 3215 virtual console as a guest of z/VM.
    > In this installation method, the installer performs some initial steps,
    > such as configuring the network device and configuring the network,
    > while using the 3215 virtual console. Then the installation switches
    > to a network console (ssh session) for the rest of the installation.
    > The trouble is that the installer seems to be treating the 3215 virtual
    > console as an ANSI terminal. I see a bunch of stuff which appears to
    > be ANSI escape sequences. This used to work, but something broke it.
    > The installer must use a line-mode interface while running on the 3215
    > virtual console. I cannot get past this.


    I suspect this is another consequence of the switch to first rootskel's
    cttyhack and later the reopen-console script.

    Reassigning to rootskel and setting severity to RC. Hopefully someone will
    look into it with you. Thanks for reporting the issue.

    If you are able to debug and possibly even fix this yourself by booting
    with BOOT_DEBUG=3 and then debugging the init procedure manually
    with 'set -x' in the reopen-console script, that would be extremely
    helpful.

    Cheers,
    FJP



    --
    To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread