Fw: Re: wireless on an old Thinkpad 600 - Debian

This is a discussion on Fw: Re: wireless on an old Thinkpad 600 - Debian ; Bernard,First, you are working with a system (Sarge) that is out-of-date. I would recommend loading Etch with a lightweight desktop like XFCE due to the TP600's limited resources. If I am not wrong, the TP600 (I used to have a ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Fw: Re: wireless on an old Thinkpad 600

  1. Fw: Re: wireless on an old Thinkpad 600


    Bernard,First, you are working with a system (Sarge) that is out-of-date. I would recommend loading Etch with a lightweight desktop like XFCE due to the TP600's limited resources. If I am not wrong, the TP600 (I used to have a 600e) has a max of 256MB RAM. It would not hurt to upgrade it. The main reason that I suggest Etch over Sarge is updated hardware support.
    >From your post, it looks like you are inquiring about both wired and wireless cards. I was using a 3Com 3C589D wired Ethernet card on my 600e, and it worked well under Linux.For wireless, I've had my best luck under Linux with WiFi cards that use the Atheros chipset and Atheros Linux driver.Here are a few links to Linux hardware compatibility sites that might be of help.http://www.linux-drivers.org/http://...p/debian/hcl/I hope you find these useful. Currently, I am posting this from Ubuntu v.8.04 (Hardy Heron) on a Compaq Evo N600c using a generic "Ativa" 802.11g WiFi card that I picked up at my local Office Depot. I've previously used these cards (I have three) with success on my old IBM TP A21e under Etch, a Compaq Armada M700 running Etch, and on a Toshiba Satellite 2410 Series running both PCLOS "TinyMe" and Puppy Linux 4.1 Retro (2.6.21.7 Kernel).

    --- On Tue, 10/28/08, Bernard wrote:
    From: Bernard
    Subject: wireless on an old Thinkpad 600
    To: debian-laptop@lists.debian.org
    Date: Tuesday, October 28, 2008, 6:44 PM

    Hi to everyone !

    I would like to install wireless facilities on my old Thinkpad. It has a
    300 Mhz processor, 128 MB of RAM, and 4.1 GB of space on hard disk. It
    used to run on RedHat 7.2, which stayed there for about six years without
    any problem. Since I have been unable to get wireless working on it using
    pcmcia IBM 'EtherJet' card and a router in client mode
    'FON2200' (the so
    called Fonera), I installed Debian Sarge instead of RedHat 7.





  2. Re: Fw: Re: wireless on an old Thinkpad 600

    Le Wed, 29 Oct 2008 09:04:28 -0700, Robert Smith a écrit*:


    > Bernard,First, you are working with a system (Sarge) that is
    > out-of-date. I would recommend loading Etch with a lightweight desktop
    > like XFCE due to the TP600's limited resources. If I am not wrong, the
    > TP600 (I used to have a 600e) has a max of 256MB RAM. It would not hurt
    > to upgrade it. The main reason that I suggest Etch over Sarge is updated
    > hardware support.


    I kwnow that Debian Sarge is outdated. Upon upgrading from RedHat 7.2 -
    much older yet - I first installed 'etch'n a half', but I ran into
    troubles as far as Xwindow was concerned. Browsing docs on the Internet
    revealed that a number of users had numerous problems with 2.6 kernels on
    old laptops. I then attempted to run Debian Sarge on my laptop. Sarge is
    the system that runs my Desktop, with no problems. With Debian Sarge on my
    laptop, I also had problems with XWindow, but I still could work on it,
    while on Etch I could barely do anything : the fvwm screen did not even
    allow an 'Xterm'.

    Now that late trials and mishaps have made my Sarge out of practical use,
    I have been willing to reinstall... which process seems to be, if not
    impossible, at least more difficult ever since yesterday or so. Packages
    are no longer available for install, except, maybe, at a new address which
    I don't happen to know as of now. I have therefore re-re-installed Debian
    Etch, even though it is not quite the same version as before : it is no
    longer called 'etch and a half', but 'Etch40r5'. It happens to be the same
    mess as far as X11 is concerned. My present day questions will therefore
    concern X11 problems as a start.

    This laptop used to run perfectly under 'fvwm' under Xfree86. I have never
    liked or sought anything like 'Gnome' or 'Kde', which I found too slow,
    buggy, useless and too much resembling Microsoft Windows desktops. fvwm
    had my preference, and I found it wonderful for my purpose. I want no more
    than that. As previously said, this laptop ran fvwm perfectly under RedHat
    7.2. Same on RH7.3. On Debian Sarge, I had been able to run a very limited
    fvwm, still Xterms were generated on demand, and I could do useful work
    that way. On Debian Etch, on the basic fvwm Xorg screen, as previously
    said I can't even get an Xterm !

    What tests or other diagnosis would you advise me to run so as to be able
    to debug my Xwindows problems ?

    I have the xserver-xorg-neomagic installed and reckognized. Synaptics does
    not reckognized my built-in mouse, but another generic software does
    reckognize it... for anything else I simply don't know. My Xorg.0.log file
    does not say anything that I can easily understand, but I could forward it
    if necessary.

    Once I can get a workable environment under Etch, I will get back to my
    Ethernet/Wireless/Router installation problems.




    --
    To UNSUBSCRIBE, email to debian-laptop-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread