Kernel module version requirements - Debian

This is a discussion on Kernel module version requirements - Debian ; Hi folks Please describe the version requirements of the dependency vbox application and kernel module. There was reports that a 1.6.2 module does not work with a 1.6.6 application. Bastian -- Fascinating, a totally parochial attitude. -- Spock, "Metamorphosis", stardate ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: Kernel module version requirements

  1. Kernel module version requirements

    Hi folks

    Please describe the version requirements of the dependency vbox
    application and kernel module. There was reports that a 1.6.2 module
    does not work with a 1.6.6 application.

    Bastian

    --
    Fascinating, a totally parochial attitude.
    -- Spock, "Metamorphosis", stardate 3219.8


    --
    To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: [Pkg-virtualbox-devel] Kernel module version requirements

    On Tue, Oct 28, 2008 at 11:00:44PM +0100, Bastian Blank wrote:
    > Please describe the version requirements of the dependency vbox
    > application and kernel module. There was reports that a 1.6.2 module
    > does not work with a 1.6.6 application.


    The version has to be the same afaik. It appears that there is neither a
    backward nor a forward compatibility. I was under the impression that a 1.6.6
    module works with a 1.6.2 application but a test showed that it doesn't.

    Therefore I wonder whether we should add a conflict into the module's control
    file. Comments anyone?

    Michael
    --
    Michael Meskes
    Michael at Fam-Meskes dot De, Michael at Meskes dot (De|Com|Net|Org)
    Michael at BorussiaFan dot De, Meskes at (Debian|Postgresql) dot Org
    ICQ: 179140304, AIM/Yahoo: michaelmeskes, Jabber: meskes@jabber.org
    Go VfL Borussia! Go SF 49ers! Use Debian GNU/Linux! Use PostgreSQL!


    --
    To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Re: [Pkg-virtualbox-devel] Kernel module version requirements

    On Wed, Oct 29, 2008 at 12:17:50PM +0100, Michael Meskes wrote:
    > On Tue, Oct 28, 2008 at 11:00:44PM +0100, Bastian Blank wrote:
    > > Please describe the version requirements of the dependency vbox
    > > application and kernel module. There was reports that a 1.6.2 module
    > > does not work with a 1.6.6 application.

    > The version has to be the same afaik. It appears that there is neither a
    > backward nor a forward compatibility. I was under the impression that a 1.6.6
    > module works with a 1.6.2 application but a test showed that it doesn't.


    Well.

    > Therefore I wonder whether we should add a conflict into the module's control
    > file. Comments anyone?


    No. virtualbox have to make this a dependency. I have no problem in
    producing a virtual package name which describes some sort of ABI.

    Bastian

    --
    Spock: The odds of surviving another attack are 13562190123 to 1, Captain.


    --
    To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  4. Re: [Pkg-virtualbox-devel] Kernel module version requirements

    On Wed, Oct 29, 2008 at 01:52:20PM +0100, Bastian Blank wrote:
    > > Therefore I wonder whether we should add a conflict into the module's control
    > > file. Comments anyone?

    >
    > No. virtualbox have to make this a dependency. I have no problem in
    > producing a virtual package name which describes some sort of ABI.


    But it's just a recommendation then. There is no dependency on the module
    package in the vbox package.

    Michael
    --
    Michael Meskes
    Michael at Fam-Meskes dot De, Michael at Meskes dot (De|Com|Net|Org)
    Michael at BorussiaFan dot De, Meskes at (Debian|Postgresql) dot Org
    ICQ: 179140304, AIM/Yahoo: michaelmeskes, Jabber: meskes@jabber.org
    Go VfL Borussia! Go SF 49ers! Use Debian GNU/Linux! Use PostgreSQL!


    --
    To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  5. Re: [Pkg-virtualbox-devel] Kernel module version requirements

    Please read http://www.debian.org/MailingLists/.

    On Wed, Oct 29, 2008 at 02:35:56PM +0100, Michael Meskes wrote:
    > On Wed, Oct 29, 2008 at 01:52:20PM +0100, Bastian Blank wrote:
    > > > Therefore I wonder whether we should add a conflict into the module's control
    > > > file. Comments anyone?

    > > No. virtualbox have to make this a dependency. I have no problem in
    > > producing a virtual package name which describes some sort of ABI.

    > But it's just a recommendation then. There is no dependency on the module
    > package in the vbox package.


    It is a hard dependency, or does virtualbox work without the module?

    Bastian

    --
    "Life and death are seldom logical."
    "But attaining a desired goal always is."
    -- McCoy and Spock, "The Galileo Seven", stardate 2821.7


    --
    To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  6. Re: [Pkg-virtualbox-devel] Kernel module version requirements

    On Wed, Oct 29, 2008 at 04:28:55PM +0100, Bastian Blank wrote:
    > Please read http://www.debian.org/MailingLists/.


    ???

    > It is a hard dependency, or does virtualbox work without the module?


    It does work without a module, but you cannot start a VM. Now this reduces the
    functionality significantly but still there is functionality (like working with
    disk images) that works without it. Besides, people might install the module
    from source I think.

    Michael

    --
    Michael Meskes
    Michael at Fam-Meskes dot De, Michael at Meskes dot (De|Com|Net|Org)
    Michael at BorussiaFan dot De, Meskes at (Debian|Postgresql) dot Org
    ICQ: 179140304, AIM/Yahoo: michaelmeskes, Jabber: meskes@jabber.org
    Go VfL Borussia! Go SF 49ers! Use Debian GNU/Linux! Use PostgreSQL!


    --
    To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread