Hello Debian Kernel list,

I'm experiencing a lot of soft lockups with the 2.6.24-etchnhalf kernel
and JFS on a Etch installation:


BUG: soft lockup - CPU#0 stuck for 11s! [jfsCommit:2122]

Pid: 2122, comm: jfsCommit Not tainted (2.6.24-etchnhalf.1-686-bigmem #1)
EIP: 0060:[] EFLAGS: 00000202 CPU: 0
EIP is at put_page+0x1a/0x9b
EAX: 4000087c EBX: c12a8320 ECX: 00000000 EDX: c12a8320
ESI: 000399d0 EDI: 00002000 EBP: c7d07768 ESP: dff6fec0
DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
CR0: 8005003b CR2: b6f59000 CR3: 234b9000 CR4: 000006f0
DR0: 00000000 DR1: 00000000 DR2: 00000000 DR3: 00000000
DR6: ffff0ff0 DR7: 00000400
[] dbUpdatePMap+0x163/0x429 [jfs]
[] __get_metapage+0x338/0x34d [jfs]
[] txAllocPMap+0x109/0x119 [jfs]
[] txUpdateMap+0x88/0x1ce [jfs]
[] __wake_up+0x32/0x42
[] txEnd+0x123/0x12a [jfs]
[] jfs_lazycommit+0x82/0x1ff [jfs]
[] default_wake_function+0x0/0x8
[] jfs_lazycommit+0x0/0x1ff [jfs]
[] kthread+0x38/0x60
[] kthread+0x0/0x60
[] kernel_thread_helper+0x7/0x10
=======================



This is my 3ware RAID controller:

02:01.0 RAID bus controller: 3ware Inc 9xxx-series SATA-RAID
Subsystem: 3ware Inc 9xxx-series SATA-RAID
Flags: bus master, 66MHz, medium devsel, latency 72, IRQ 21
I/O ports at 7000 [size=256]
Memory at fb200000 (64-bit, non-prefetchable) [size=256]
Memory at fd800000 (64-bit, prefetchable) [size=8M]
[virtual] Expansion ROM at fb210000 [disabled] [size=64K]
Capabilities: [48] Power Management version 2



This is my mountpoint with a JFS filesystem:

/dev/sda1 on /backup type jfs (rw,noatime,nodiratime)


/dev/sda1 9.1T 4.7T 4.5T 51% /backup


jfs_tune -l /dev/sda1
jfs_tune version 1.1.11, 05-Jun-2006

JFS filesystem superblock:

JFS magic number: 'JFS1'
JFS version: 1
JFS state: mounted
JFS flags: JFS_LINUX JFS_COMMIT JFS_GROUPCOMMIT JFS_INLINELOG
Aggregate block size: 4096 bytes
Aggregate size: 19530376664 blocks
Physical block size: 512 bytes
Allocation group size: 33554432 aggregate blocks
Log device number: 0x801
Filesystem creation: Tue Mar 11 13:45:04 2008
Volume label: ''



Could be JFS version 1 the problem?


All packages are updated.

Please CC me as I'm not in this mailing list.


Kind regards,
Andreas


--
Andreas Schröder | IT Administration

ART+COM Technologies GmbH
Kleiststr. 23-26 | 10787 Berlin | Germany
p: +49.30.21001-463 | f: +49.30.21001-556
w: http://tech.artcom.de/

Trade Register 107973B | County Court Charlottenburg
CEO: Pavel Mayer
VAT-IdNr.: DE254751981



--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org