Re: [KDE 4.1 backports] [BUG] Dependency problem with 4.1.1 to 4.1.2 upgrade
On Sat, Oct 11, 2008 at 01:34:41PM +0200, Richard Scherping wrote:[color=blue]
> Hello list,
> hello Ana!
> Recently KDE4 packages in kde4.debian.net seem to have been updated from 4.1.1 to 4.1.2. Unfortunately they now depend on Qt4 >= 4.4.3, which is available in Sid, but NOT in Lenny. As these backports are made explicitely for Lenny, this is odd.
> If the new Qt4 version (4.4.3 compared to 4.4.0, which is in Lenny) is really needed for KDE 4.1.2, this release should not have been backported.
> If Qt4 4.4.0 is still OK (I do not have the time to test that unfortunately), please change the depencies.
I was surprised when reading this email because I have not remember making the
backports against qt 4.4.3, but given i made then too much in hurry i was not
surprised i have mistankenly built against 4.4.3. And I was planning backport
qt 4.4.3 anyway.
Today when finally i was able to look at finishing this, I have realize that
i386 backports are built against 4.4.0 but amd64 are built against lenny with qt
4.4.3, so there it is Richard's problem.
I am going to rebuild amd64's backports so they depend on qt 4.4.0 and i am
going to upload a backport for qt 4.4.3.
By default, this new qt 4.4.3 will be installed, i think it is ok for most of
the users, since qt 4.4.3 solves some nasty problems for people using kde 4,
and it has full compatibility back to stuff built against 4.4.0. Lenny won't
be released with 4.4.3 just for bad timing.
I will add all this info later today or tomorrow when updating kde4.d.n for
announcing the backports.
To UNSUBSCRIBE, email to [email]debian-kde-REQUEST@lists.debian.org[/email]
with a subject of "unsubscribe". Trouble? Contact [email]email@example.com[/email]