Bug#501383: domU with 2.6.26 does not see more than 4G of RAM - Debian

This is a discussion on Bug#501383: domU with 2.6.26 does not see more than 4G of RAM - Debian ; Package: linux-image-2.6.26-1-xen-686 Version: 2.6.26-5 Severity: normal I've just tried to start kernel from linux-image-2.6.26-1-xen-686 instead of etch xen kernel in a domU. Since that domU runs an application server with >50 KDE session nortmally active, it required much RAM. Current ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Bug#501383: domU with 2.6.26 does not see more than 4G of RAM

  1. Bug#501383: domU with 2.6.26 does not see more than 4G of RAM

    Package: linux-image-2.6.26-1-xen-686
    Version: 2.6.26-5
    Severity: normal

    I've just tried to start kernel from linux-image-2.6.26-1-xen-686
    instead of etch xen kernel in a domU.

    Since that domU runs an application server with >50 KDE session
    nortmally active, it required much RAM. Current setup is 15G.
    That works with etch 2.6.18-6-xen kernel.

    However, kernel from linux-image-2.6.26-1-xen-686 recognized only 4G.

    Hypervisor version is 3.2.0-3~bpo4+2 (from backports.org).
    xen-utils-3.2-1 in dom0 is 3.2.0-3~bpo4+2.
    Both hypervisor and domU are 32bit.


    -- System Information:
    Debian Release: 4.0
    APT prefers stable
    APT policy: (640, 'stable'), (620, 'testing'), (600, 'unstable'), (580, 'experimental')
    Architecture: i386 (i686)
    Shell: /bin/sh linked to /bin/bash
    Kernel: Linux 2.6.18-6-xen-686
    Locale: LANG=ru_RU.KOI8-R, LC_CTYPE=ru_RU.KOI8-R (charmap=KOI8-R)



    --
    To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Bug#501383: domU with 2.6.26 does not see more than 4G of RAM

    tags 501383 moreinfo
    thanks

    On Tue, Oct 07, 2008 at 07:22:01AM +0400, Nikita V. Youshchenko wrote:
    > I've just tried to start kernel from linux-image-2.6.26-1-xen-686
    > instead of etch xen kernel in a domU.


    This bugreport lacks any information, like kernel and hypervisor logs,
    which may be usefull to find a problem.

    > Hypervisor version is 3.2.0-3~bpo4+2 (from backports.org).
    > xen-utils-3.2-1 in dom0 is 3.2.0-3~bpo4+2.


    This version is not supported. At least upgrade the hypervisor to 3.2.1
    from Lenny.

    > Both hypervisor and domU are 32bit.


    You want to use a 64bit hypervisor if possible. It would reduce the
    overhead of the running systems. However, this would not longer allow to
    use the Etch kernel in the dom0.

    Bastian

    --
    Beam me up, Scotty!



    --
    To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Bug#501383: domU with 2.6.26 does not see more than 4G of RAM

    > > Hypervisor version is 3.2.0-3~bpo4+2 (from backports.org).
    > > xen-utils-3.2-1 in dom0 is 3.2.0-3~bpo4+2.

    >
    > This version is not supported. At least upgrade the hypervisor to 3.2.1
    > from Lenny.


    Thanks for your reply.

    I can't upgrade now, since system in question is running several domUs that
    are used in production.

    I will search for an upgrade window. Cristmas holidays is the most likely
    possibility.

    Nikita

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.9 (GNU/Linux)

    iEYEABECAAYFAkkUOaAACgkQv3x5OskTLdv23wCdGvPB8wo9dE BW6cXDNZtPxh37
    jKEAoLlcqbSG3U+4SGlrvs7lMlvNo7mF
    =ejKP
    -----END PGP SIGNATURE-----


+ Reply to Thread