Re: Why KDE4 ktorrent in Lenny? - Debian

This is a discussion on Re: Why KDE4 ktorrent in Lenny? - Debian ; El Martes, 23 de Septiembre de 2008, Mike Bird escribi├│: > See below for my Lenny KDE packages. ┬*What differences do you see > between this and the systems where you tested ktorrent 3 with Lenny's > KDE 3? ┬*Is ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: Re: Why KDE4 ktorrent in Lenny?

  1. Re: Why KDE4 ktorrent in Lenny?

    El Martes, 23 de Septiembre de 2008, Mike Bird escribi├│:
    > See below for my Lenny KDE packages. ┬*What differences do you see
    > between this and the systems where you tested ktorrent 3 with Lenny's
    > KDE 3? ┬*Is it possible that ktorrent 3 does not work with KDE 3?


    It _does_ work, and as said in the thread, should work perfectly.

    Try installing debsums and run it against the KDE 4 packages. Just in case,
    make sure you don't have any package without dependencies solved.

    You must have a ~/.kde4, because KTorrent stores there important information
    about the torrents in progress. If you don't have one, try reinstalling as
    Modestas said.

    --
    Alex (a.k.a. suy) | GPG ID 0x0B8B0BC2
    http://barnacity.net/ | http://disperso.net


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: Why KDE4 ktorrent in Lenny?

    On Wed September 24 2008 04:48:36 Alejandro Exojo wrote:
    > El Martes, 23 de Septiembre de 2008, Mike Bird escribi├│:
    > > See below for my Lenny KDE packages. ┬*What differences do you see
    > > between this and the systems where you tested ktorrent 3 with Lenny's
    > > KDE 3? ┬*Is it possible that ktorrent 3 does not work with KDE 3?

    >
    > It _does_ work, and as said in the thread, should work perfectly.


    Please post your "dpkg -l | grep kde" from a working Lenny KDE 3.
    I've already posted mine[1].

    Thus far people asserting that it works have actually been running KDE 4
    and/or Sid. The question is whether Lenny's default ktorrent 3 works
    with Lenny's default KDE 3.5.9 using only the parts of Lenny's KDE 4
    brought in by ktorrent 3's dependencies.

    > Try installing debsums and run it against the KDE 4 packages.


    I already have debsums installs. No problems related to KDE or anything
    remotely close to KDE. I've appended the output to this message.

    As noted in the thread, I have removed/purged ktorrent 3 and its
    KDE 4 dependencies using dpkg, run ktorrent2.2 successfully for some
    days, and reinstalled ktorrent 3. No change.

    FWIW, my ktorrent2.2 is currently removed ("deinstall ok config-files")
    not purged, so I can return to a working configuration.

    > Just in case, make sure you don't have any package without
    > dependencies solved.


    No missing dependencies (apt-get --dry-run -f install).

    > You must have a ~/.kde4, because KTorrent stores there important
    > information about the torrents in progress. If you don't have one, try
    > reinstalling as Modestas said.


    Modestas indicated that "kbuildsycoca4" perhaps with "--noincremental"
    should create "~/.kde4". It does not. What should create "~/.kde4"?
    Why is it not included in ktorrent 3 dependencies?

    If I "mkdir ~/.kde4" and then run "kbuildsycoca4 --noincremental"
    nothing is placed in "~/.kde4". I have previously posted my
    kbuildsycoca4 output[2]. What more is needed to diagnose why
    kbuildsycoca4 is not putting anything in "~/.kde4". FWIW, running
    ktorrent itself does not put anything in "~/.kde4" either.

    Nothing is scanning "/usr/lib/kde4" for the plugins. What should be
    scanning "/usr/lib/kde4"? Why is it not included in ktorrent 3
    dependencies?

    ktorrent 3 is unable to start service 'khelpcenter'. Does ktorrent 3
    work with khelpcenter 4:4.0.0.really.3.5.9.dfsg.1-5 or does it need
    khelpcenter4, and if so why is it not a dependency?

    ktorrent 3 under KDE 3.5.9 is really ugly, and the fonts are not
    anti-aliased. Is there any way to fix this without installing KDE 4?

    Thanks,

    --Mike Bird

    [1] http://lists.debian.org/debian-kde/2.../msg00085.html
    [2] http://lists.debian.org/debian-kde/2.../msg00081.html


    # debsums -ca
    debsums: can't open acpi-support file /etc/modprobe.d/thinkpad_acpi.modprobe
    (No such file or directory)
    debsums: no md5sums for at
    /etc/bind/named.conf.options
    /etc/bind/named.conf.local
    debsums: no md5sums for binutils
    debsums: no md5sums for bzip2
    /etc/console-tools/config
    debsums: no md5sums for debian-archive-keyring
    debsums: no md5sums for debian-multimedia-keyring
    /etc/dhcp3/dhclient.conf
    debsums: no md5sums for doc-debian
    debsums: no md5sums for ed
    debsums: no md5sums for emacsen-common
    debsums: no md5sums for g++
    debsums: no md5sums for initscripts
    debsums: no md5sums for java-gcj-compat
    debsums: no md5sums for klogd
    debsums: no md5sums for libaudio2
    debsums: no md5sums for libbz2-1.0
    debsums: no md5sums for libbz2-dev
    debsums: no md5sums for libdb4.2
    debsums: no md5sums for libdb4.5
    debsums: no md5sums for liblockfile1
    debsums: no md5sums for libncurses5
    debsums: no md5sums for libncursesw5
    /etc/security/limits.conf
    debsums: no md5sums for libxine1
    debsums: no md5sums for lockfile-progs
    debsums: no md5sums for mawk
    debsums: no md5sums for ncurses-base
    debsums: no md5sums for ncurses-bin
    debsums: no md5sums for ncurses-term
    /etc/nessus/nessusd.conf
    debsums: no md5sums for netbase
    /etc/quagga/daemons
    debsums: no md5sums for slib
    debsums: no md5sums for sysklogd
    debsums: no md5sums for sysv-rc
    debsums: no md5sums for sysvinit
    debsums: no md5sums for sysvinit-utils
    debsums: no md5sums for update-inetd
    #


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Re: Why KDE4 ktorrent in Lenny?

    Mike Bird wrote:
    > On Wed September 24 2008 04:48:36 Alejandro Exojo wrote:
    >> El Martes, 23 de Septiembre de 2008, Mike Bird escribi├│:
    >>> See below for my Lenny KDE packages. What differences do you see
    >>> between this and the systems where you tested ktorrent 3 with Lenny's
    >>> KDE 3? Is it possible that ktorrent 3 does not work with KDE 3?

    >> It _does_ work, and as said in the thread, should work perfectly.

    >
    > Please post your "dpkg -l | grep kde" from a working Lenny KDE 3.
    > I've already posted mine[1].
    >
    > Thus far people asserting that it works have actually been running KDE 4
    > and/or Sid. The question is whether Lenny's default ktorrent 3 works
    > with Lenny's default KDE 3.5.9 using only the parts of Lenny's KDE 4
    > brought in by ktorrent 3's dependencies.
    >


    Hi Mike,

    I've been running a pure KDE3 up until now and got curious. Pretty
    standard, nothing special

    This is what I got when installing ktorrent:

    The following NEW packages will be installed:
    kde-icons-oxygen{a} kdebase-runtime{a} kdebase-runtime-bin-kde4{a}
    kdebase-runtime-data{a} kdelibs-bin{a} kdelibs5{a}
    kdelibs5-data{a} ktorrent libphonon4{a} libqca2{a} libsoprano4{a}
    libstreamanalyzer0{a} libstreams0{a} libstrigiqtdbusclient0{a}
    phonon{a} phonon-backend-xine{a}
    The following packages will be REMOVED:
    kdebase-bin-kde3{a}


    Running ktorrent after that worked perfectly fine.

    I can only suggest what others have already said, that you'll probably
    have a misconfigured system.

    Cheers,
    Michael

    --
    Why is it that all of the instruments seeking intelligent life in the
    universe are pointed away from Earth?


    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iEYEARECAAYFAkjadl4ACgkQh7PER70FhVRLUwCdHLP4pwCNSc QkhkiKhaXP7BRE
    utcAn1HujV/3VpmFBb27+qSb80LnEwM8
    =Yy6X
    -----END PGP SIGNATURE-----


  4. Re: Why KDE4 ktorrent in Lenny?

    On Wed September 24 2008 10:18:21 Michael Biebl wrote:
    > I can only suggest what others have already said, that you'll probably
    > have a misconfigured system.


    Please post your "dpkg -l | grep kde".

    Thanks,

    --Mike Bird


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  5. Re: Why KDE4 ktorrent in Lenny?

    Mike Bird wrote:
    > On Wed September 24 2008 10:18:21 Michael Biebl wrote:
    >> I can only suggest what others have already said, that you'll probably
    >> have a misconfigured system.

    >
    > Please post your "dpkg -l | grep kde".
    >


    Nothing fancy. This is *after* installing ktorrent

    pluto:~# dpkg -l | grep kde
    ii kde-core 5:48 the K Desktop Environment core modules
    ii kde-i18n-de 4:3.5.10-1 German (de) internationalized (i18n) files for KDE
    ii kde-icons-nuovext 1.6.dfsg.1-3 nuoveXT icon theme for KDE
    ii kde-icons-nuvola 1.0.0-3 Nuvola icon theme for KDE3
    ii kde-icons-oxygen 4:4.1.0-2 Oxygen icon theme for KDE 4
    ii kde-style-polyester 1.0.3-1 Polyester widget style and kwin decoration for KDE3
    ii kdeaddons-kfile-plugins 4:3.5.9-2 KDE file dialog plugins for text files and folders
    ii kdeartwork-emoticons 4:3.5.9-3 emoticon collections for KDE chat clients
    ii kdeartwork-misc 4:3.5.9-3 various multimedia goodies released with KDE
    ii kdeartwork-style 4:3.5.9-3 widget styles released with KDE
    ii kdebase 4:3.5.9.dfsg.1-5 base components from the official KDE release
    ii kdebase-bin 4:3.5.9.dfsg.1-5 core binaries for the KDE base module
    ii kdebase-data 4:3.5.9.dfsg.1-5 shared data files for the KDE base module
    ii kdebase-kio-plugins 4:3.5.9.dfsg.1-5 core I/O slaves for KDE
    ii kdebase-runtime 4:4.1.0-2 runtime components from the official KDE 4 release
    ii kdebase-runtime-bin-kde4 4:4.1.0-2 core binaries for the KDE 4 base runtime module
    ii kdebase-runtime-data 4:4.1.0-2 shared data files for the KDE 4 base runtime module
    ii kdebluetooth 1.0~beta8-5 KDE Bluetooth Framework
    ii kdeeject 4:3.5.9.dfsg.1-5 script used by KDE to eject removable media
    ii kdegraphics-kfile-plugins 4:3.5.9-3 KDE metainfo plugins for graphic files
    ii kdelibs 4:3.5.9.dfsg.1-6 core libraries from the official KDE release
    ii kdelibs-bin 4:4.1.0-3 executables for all KDE 4 core applications
    ii kdelibs-data 4:3.5.9.dfsg.1-6 core shared data for all KDE applications
    ii kdelibs4-dev 4:3.5.9.dfsg.1-6 development files for the KDE core libraries
    ii kdelibs4c2a 4:3.5.9.dfsg.1-6 core libraries and binaries for all KDE applications
    ii kdelibs5 4:4.1.0-3 core libraries for all KDE 4 applications
    ii kdelibs5-data 4:4.1.0-3 core shared data for all KDE 4 applications
    ii kdemultimedia-kfile-plugins 4:3.5.9-3 au/avi/m3u/mp3/ogg/wav plugins for kfile
    ii kdemultimedia-kio-plugins 4:3.5.9-3 enables the browsing of audio CDs under Konqueror
    ii kdepasswd 4:3.5.9.dfsg.1-5 password changer for KDE
    ii kdepim-kfile-plugins 4:3.5.9-5 KDE File dialog plugins for palm and vcf files
    ii kdepim-kio-plugins 4:3.5.9-5 KDE pim I/O Slaves
    ii kdepim-kresources 4:3.5.9-5 KDE pim resource plugins
    ii kdeprint 4:3.5.9.dfsg.1-5 print system for KDE
    ii kdesdk-kfile-plugins 4:3.5.9-2 KDE file dialog plugins for software development files
    ii kdesdk-scripts 4:3.5.9-2 a set of useful development scripts for KDE
    ii kdesktop 4:3.5.9.dfsg.1-5 miscellaneous binaries and files for the KDE desktop
    ii kdesvn 1.0.2-1 subversion client with tight KDE integration
    ii kdesvn-kio-plugins 1.0.2-1 subversion I/O slaves for KDE
    ii kdevelop 4:3.5.2-1 An IDE for Unix/X11
    ii kdevelop-data 4:3.5.2-1 An IDE for Unix/X11 - data
    ii kdevelop-doc 4:3.5.2-1 An IDE for Unix/X11 - documentation
    ii kdewallpapers 4:3.5.9-3 wallpapers released with KDE
    ii libkdepim1a 4:3.5.9-5 KDE PIM library
    ii liblockdev1 1.0.3-1.2+b1 Run-time shared library for locking devices
    ii liblockdev1-dev 1.0.3-1.2+b1 Development library for locking devices
    ii network-manager-kde 1:0.7~svn859085-1 KDE systray applet for controlling NetworkManager
    ii openoffice.org-kde 1:2.4.1-9 KDE Integration for OpenOffice.org (Widgets, Dialogs, Addressboo


    --
    Why is it that all of the instruments seeking intelligent life in the
    universe are pointed away from Earth?


    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iEYEARECAAYFAkjaeDsACgkQh7PER70FhVRxKACgnikPkJfWla O6rpKHb+MLwZ+a
    PFYAnRUkhmsEaEH/gqWZDwyfFkypOfgD
    =10z2
    -----END PGP SIGNATURE-----


  6. Re: Why KDE4 ktorrent in Lenny? SOLVED

    Found and removed some old KDE4-related garbage in /usr/local.
    My fault, not Debian.

    Many thanks to everyone who answered my dumb questions.

    --Mike Bird


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread