Bug#497238: issues with detecting kvm hard disk - Debian

This is a discussion on Bug#497238: issues with detecting kvm hard disk - Debian ; Package: installation-reports Boot method: from virtual cdrom Image version: http://cdimage.debian.org/cdimage/da...sinesscard.iso This build finished at Sat Aug 30 21:35:59 UTC 2008. Date: 31. August 2008 Machine: kvm, running on an amd64 lenny based system (base system: 2.6.26-1-amd64, kvm is 71+dfsg-1) Processor: ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Bug#497238: issues with detecting kvm hard disk

  1. Bug#497238: issues with detecting kvm hard disk

    Package: installation-reports

    Boot method: from virtual cdrom
    Image version: http://cdimage.debian.org/cdimage/da...sinesscard.iso
    This build finished at Sat Aug 30 21:35:59 UTC 2008.
    Date: 31. August 2008

    Machine: kvm, running on an amd64 lenny based system (base system:
    2.6.26-1-amd64, kvm is 71+dfsg-1)
    Processor: qemu virtual CPU (host: AMD Athlon(tm) 64 X2 Dual Core)
    Memory: 256m
    Command line:
    kvm -boot d -drive file=/dev/data/Test2,if=virtio -cdrom debian-testing-amd64-netinst.iso-Aug-30-21-35-59-UTC-2008 -m 256
    Partitions: raw disk at the beginning, at the end:

    Output of lspci -knn (or lspci -nn):
    00:00.0 Host bridge [0600]: Intel Corporation 440FX - 82441FX PMC [Natoma] [8086:1237] (rev 02)
    00:01.0 ISA bridge [0601]: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II] [8086:7000]
    00:01.1 IDE interface [0101]: Intel Corporation 82371SB PIIX3 IDE [Natoma/Triton II] [8086:7010]
    Kernel driver in use: PIIX_IDE
    Kernel modules: piix
    00:01.3 Bridge [0680]: Intel Corporation 82371AB/EB/MB PIIX4 ACPI [8086:7113] (rev 03)
    Kernel driver in use: piix4_smbus
    Kernel modules: i2c-piix4
    00:02.0 VGA compatible controller [0300]: Cirrus Logic GD 5446 [1013:00b8]
    Kernel modules: cirrusfb
    00:03.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec:8139] (rev 20)
    Kernel driver in use: 8139too
    Kernel modules: 8139too, 8139cp
    00:04.0 Mass storage controller [0180]: Qumranet, Inc. Device [1af4:1001]


    Base System Installation Checklist:
    [O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

    Initial boot: [O]
    Detect network card: [O]
    Configure network: [O]
    Detect CD: [O]
    Load installer modules: [O]
    Detect hard drives: [E]
    Partition hard drives: [O]
    Install base system: [O]
    Clock/timezone setup: [O]
    User/password setup: [O]
    Install tasks: [O]
    Install boot loader: [O]
    Overall install: [O]

    Comments/Problems:

    With virtio, the hard disk wasn't detected. After udpkg -i .../virtio-modules-2.6.26-1-amd64-di*,
    the rest went fine (including automatic detection).
    With scsi or ide, everything went fine.

    Another problem (with scsi and virtio) was that kvm didn't like to boot from
    that kind of media, but that's kvm bug #497214.


    (And a final bit, it would be great if there would be an installation medium
    that would work with the curses-only interface of kvm, i.e. uses only linux
    text mode.)


    Cheers,
    Andi
    --
    http://home.arcor.de/andreas-barth/



    --
    To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Bug#497238: issues with detecting kvm hard disk

    reassign 497238 hw-detect
    thanks

    On Sun, Aug 31, 2008 at 10:01:32AM +0200, Andreas Barth wrote:
    > With virtio, the hard disk wasn't detected. After udpkg -i
    > .../virtio-modules-2.6.26-1-amd64-di*,
    > the rest went fine (including automatic detection).


    This has been discussed on the mailling-list already, see:
    http://lists.debian.org/debian-boot/.../msg00753.html

    I am still waiting for feedback from other members of the team about the
    proposed patch.

    Cheers,
    --
    Jérémy Bobbio .''`.
    lunar@debian.org : :Ⓐ : # apt-get install anarchism
    `. `'`
    `-

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.6 (GNU/Linux)

    iD8DBQFIu+HI2PUjs9fQ72URAtA5AJ40JK/+Rjqq1R6RU3Y76QsfBhrBZwCeNZ9Q
    mVxyfJggIzAUDJde0mXuWBg=
    =zS2b
    -----END PGP SIGNATURE-----


  3. Bug#497238: issues with detecting kvm hard disk

    Jérémy Bobbio writes:

    > reassign 497238 hw-detect
    > thanks
    >
    > On Sun, Aug 31, 2008 at 10:01:32AM +0200, Andreas Barth wrote:
    >> With virtio, the hard disk wasn't detected. After udpkg -i
    >> .../virtio-modules-2.6.26-1-amd64-di*,
    >> the rest went fine (including automatic detection).

    >
    > This has been discussed on the mailling-list already, see:
    > http://lists.debian.org/debian-boot/.../msg00753.html
    >
    > I am still waiting for feedback from other members of the team about the
    > proposed patch.


    I fully agree with it.

    --
    O T A V I O S A L V A D O R
    ---------------------------------------------
    E-mail: otavio@debian.org UIN: 5906116
    GNU/Linux User: 239058 GPG ID: 49A5F855
    Home Page: http://otavio.ossystems.com.br
    ---------------------------------------------
    "Microsoft sells you Windows ... Linux gives
    you the whole house."



    --
    To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  4. Bug#497238: marked as done (issues with detecting kvm hard disk)


    Your message dated Thu, 04 Sep 2008 13:02:11 +0000
    with message-id
    and subject line Bug#497238: fixed in hw-detect 1.67
    has caused the Debian Bug report #497238,
    regarding issues with detecting kvm hard disk
    to be marked as done.

    This means that you claim that the problem has been dealt with.
    If this is not the case it is now your responsibility to reopen the
    Bug report if necessary, and/or fix the problem forthwith.

    (NB: If you are a system administrator and have no idea what this
    message is talking about, this may indicate a serious mail system
    misconfiguration somewhere. Please contact owner@bugs.debian.org
    immediately.)


    --
    497238: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=497238
    Debian Bug Tracking System
    Contact owner@bugs.debian.org with problems


+ Reply to Thread