Qtopia - Debian

This is a discussion on Qtopia - Debian ; I apologize that this question doesn't fit squarely with this group's topic, but haven't found a better place to ask. I'd like to dabble in programming for the Qtopia platform, however, as far as I can tell, there are no ...

+ Reply to Thread
Results 1 to 7 of 7

Thread: Qtopia

  1. Qtopia


    I apologize that this question doesn't fit squarely with this group's
    topic, but haven't found a better place to ask.

    I'd like to dabble in programming for the Qtopia platform, however, as
    far as I can tell, there are no packages for the current 4.x edition
    development tools, although there is an older qt3-dev-tools-embedded
    package.

    Can anyone give me a hint how to install the necessary dev tools without
    damaging my existing Qt installation?

    Michael

    --
    Michael Schuerig
    mailto:michael@schuerig.de
    http://www.schuerig.de/michael/


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: Qtopia

    On Sunday 10 August 2008 15:35:46 Michael Schuerig wrote:
    > I apologize that this question doesn't fit squarely with this group's
    > topic, but haven't found a better place to ask.
    >
    > I'd like to dabble in programming for the Qtopia platform, however, as
    > far as I can tell, there are no packages for the current 4.x edition
    > development tools, although there is an older qt3-dev-tools-embedded
    > package.
    >
    > Can anyone give me a hint how to install the necessary dev tools without
    > damaging my existing Qt installation?
    >
    > Michael


    No, there is no Qtopia in Debian (at least yet, I may give it a try, as it
    would be useful to the QDE project).

    You should (if I remember well enough) use the --prefix to install qt for
    embedded systems in another place, anyway I think the default is /usr/local,
    in which you are on the safe side.

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.9 (GNU/Linux)

    iEYEABECAAYFAkifSwcACgkQXGiQYciCD6faKQCeI25uF3c9yl BjjqERgUS5VIot
    vywAoNjLPWLkWq9ogIy3pvUn3G/v+CXc
    =3Zt8
    -----END PGP SIGNATURE-----


  3. Re: Qtopia

    On 2008-08-10, Michael Schuerig wrote:
    > I'd like to dabble in programming for the Qtopia platform, however, as
    > far as I can tell, there are no packages for the current 4.x edition
    > development tools, although there is an older qt3-dev-tools-embedded
    > package.


    Are you wanting just Qt/embedded or the full Qtopia stack?

    > Can anyone give me a hint how to install the necessary dev tools without
    > damaging my existing Qt installation?


    There is somewhere in pkg-kde svn a packaging startup that can easily be
    extended. But just for Qt/Embdedded.

    /Sune


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  4. Qtopia

    Qutopia holds a tremendous possibility for eliminating much of the
    unnecessary complexity of the whole program stack.

    Note http://www.osnews.com/story/20160/Qt..._and_Firefox_3

    Henry

    Sune Vuorela wrote:
    > On 2008-08-10, Michael Schuerig wrote:
    >
    >> I'd like to dabble in programming for the Qtopia platform, however, as
    >> far as I can tell, there are no packages for the current 4.x edition
    >> development tools, although there is an older qt3-dev-tools-embedded
    >> package.
    >>

    >
    > Are you wanting just Qt/embedded or the full Qtopia stack?
    >
    >
    >> Can anyone give me a hint how to install the necessary dev tools without
    >> damaging my existing Qt installation?
    >>

    >
    > There is somewhere in pkg-kde svn a packaging startup that can easily be
    > extended. But just for Qt/Embdedded.
    >
    > /Sune
    >
    >
    >



    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  5. Re: Qtopia

    On 2008-08-10, Henry keultjes wrote:
    > Qutopia holds a tremendous possibility for eliminating much of the
    > unnecessary complexity of the whole program stack.


    Well.. I don't think the world is ready yet to kill X11.

    /Sune


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  6. Re: Qtopia

    On Sunday 10 August 2008, Lisandro Damián Nicanor Pérez Meyer wrote:
    > On Sunday 10 August 2008 15:35:46 Michael Schuerig wrote:


    > > Can anyone give me a hint how to install the necessary dev tools
    > > without damaging my existing Qt installation?
    > >
    > > Michael

    >
    > No, there is no Qtopia in Debian (at least yet, I may give it a try,
    > as it would be useful to the QDE project).
    >
    > You should (if I remember well enough) use the --prefix to install qt
    > for embedded systems in another place, anyway I think the default is
    > /usr/local, in which you are on the safe side.


    As far as I've figured it out, it works like this

    - Download a snapshot from ftp://ftp.trolltech.com/qtopia/snapshots/.
    I've got qtopia-opensource-src-4.3.2-snapshot-20080810.tar.gz.
    - Unpack it somewhere.
    - Create an empty installationa directory, in my
    case /usr/local/opt/qtopia, and cd there.
    - Run /qtopia-opensource-src-4.3.2-snapshot-20080810/configure.
    - Run make
    - Run make install

    At least it ought to work like that. I'm stumped because configure/qmake
    insists to use the default gcc/g++, 4.3.1 in my case, which does not
    compile some of the code. Some of the problems are minor, I finally
    stumbled for good over a dynamic_cast. gcc/g++ 4.2 will presumably
    work, however, I haven't found the switch, env variable or whatever
    else it takes, to tell configure/qmake to use /usr/bin/g++-4.2.

    Michael

    --
    Michael Schuerig
    mailto:michael@schuerig.de
    http://www.schuerig.de/michael/


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  7. Re: Qtopia

    On Sunday 10 August 2008 17:33:58 Sune Vuorela wrote:
    > On 2008-08-10, Michael Schuerig wrote:
    > > I'd like to dabble in programming for the Qtopia platform, however, as
    > > far as I can tell, there are no packages for the current 4.x edition
    > > development tools, although there is an older qt3-dev-tools-embedded
    > > package.

    >
    > Are you wanting just Qt/embedded or the full Qtopia stack?
    >
    > > Can anyone give me a hint how to install the necessary dev tools without
    > > damaging my existing Qt installation?

    >
    > There is somewhere in pkg-kde svn a packaging startup that can easily be
    > extended. But just for Qt/Embdedded.


    Do you happen to know where it is? It can save me some time (I am currently
    digging the svn without success)

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.9 (GNU/Linux)

    iEYEABECAAYFAkiga6kACgkQXGiQYciCD6e2gwCguvxRRE5xOF F1NS/NJ6K1+5Be
    PuoAn1Y7rDqnsQXOA9qjFkdOq2mTbRPJ
    =oEfO
    -----END PGP SIGNATURE-----


+ Reply to Thread