Allow debian-edu-install to propagate to testing - Debian

This is a discussion on Allow debian-edu-install to propagate to testing - Debian ; Hi. The current debian-edu-install package in unstable (0.672) got udebs, and are thus blocked from propagating into testing automatically. It has had its required resting time, and it would be great if it was allowed to propagate into testing. It ...

+ Reply to Thread
Results 1 to 7 of 7

Thread: Allow debian-edu-install to propagate to testing

  1. Allow debian-edu-install to propagate to testing

    Hi. The current debian-edu-install package in unstable (0.672) got
    udebs, and are thus blocked from propagating into testing
    automatically. It has had its required resting time, and it would be
    great if it was allowed to propagate into testing. It was uploaded
    before the freeze.

    Cc til debian-boot, to allow them to comment on the udeb issue.

    Since the upload we have discovered and fixed some bugs in the
    package, which are currently being tested in the Debian Edu
    repository. We will need at least another update before Lenny is
    released, and hope it can be accepted too. We will get back to you
    about this.

    Happy hacking,
    --
    Petter Reinholdtsen


    --
    To UNSUBSCRIBE, email to debian-release-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: Allow debian-edu-install to propagate to testing

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Petter Reinholdtsen writes:

    > Hi. The current debian-edu-install package in unstable (0.672) got
    > udebs, and are thus blocked from propagating into testing
    > automatically. It has had its required resting time, and it would be
    > great if it was allowed to propagate into testing. It was uploaded
    > before the freeze.
    >
    > Cc til debian-boot, to allow them to comment on the udeb issue.
    >
    > Since the upload we have discovered and fixed some bugs in the
    > package, which are currently being tested in the Debian Edu
    > repository. We will need at least another update before Lenny is
    > released, and hope it can be accepted too. We will get back to you
    > about this.


    No objection

    - --
    O T A V I O S A L V A D O R
    - ---------------------------------------------
    E-mail: otavio@debian.org UIN: 5906116
    GNU/Linux User: 239058 GPG ID: 49A5F855
    Home Page: http://otavio.ossystems.com.br
    - ---------------------------------------------
    "Microsoft sells you Windows ... Linux gives
    you the whole house."
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.9 (GNU/Linux)
    Comment: Processed by Mailcrypt 3.5.8+

    iEYEARECAAYFAkiS/9YACgkQLqiZQEml+FUVRwCfRayXMQprn6j8YQwt53vqcvmP
    UEMAoLv555qMbLM8rwOdx40Hka+4YY9t
    =V87N
    -----END PGP SIGNATURE-----


    --
    To UNSUBSCRIBE, email to debian-release-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Re: Allow debian-edu-install to propagate to testing

    On Fri, Aug 01, 2008 at 12:21:54PM +0000, Otavio Salvador wrote:
    > Petter Reinholdtsen writes:
    >
    > > Hi. The current debian-edu-install package in unstable (0.672) got

    >
    > No objection


    unblocked

    --
    ·O· Pierre Habouzit
    ··O madcoder@debian.org
    OOO http://www.madism.org

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.9 (GNU/Linux)

    iEYEABECAAYFAkiTDxMACgkQvGr7W6HudhyozwCgqTB/tWro53kYaeyWYn6FHIPO
    EEYAn1ejriEAS/c+aOpH9dke9Ngupifu
    =Ti0K
    -----END PGP SIGNATURE-----


  4. Re: Allow debian-edu-install to propagate to testing

    [Pierre Habouzit]
    > unblocked


    Great. I am not sure it was enough. The message now reads:

    5 days old (needed 5 days)
    Not touching package, as requested by freeze (contact debian-release
    if update is needed)
    Not considered

    Happy hacking,
    --
    Petter Reinholdtsen


    --
    To UNSUBSCRIBE, email to debian-release-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  5. Re: Allow debian-edu-install to propagate to testing


    [Petter Reinholdtsen]
    > Since the upload we have discovered and fixed some bugs in the
    > package, which are currently being tested in the Debian Edu
    > repository. We will need at least another update before Lenny is
    > released, and hope it can be accepted too. We will get back to you
    > about this.


    I guess now is a good time to get back to you about this. The version
    in unstable is the one we have been testing in Debian Edu the last few
    days, and it seem to work fine. It contain a code move to put it at
    the correct location in the installer, and a rename of the d-i hooks
    to make sure the makes reflect their position in the d-i sequence to
    make sure I do not put code in the wrong location again, and finally
    fix one leftover code part failing to use a HTTP proxy. I also added
    some cosmetic changes to speed up the installation and get more fine
    grained information from etcinsvk, but those are not very important.
    This is the changelog:

    debian-edu-install (0.673) unstable; urgency=low

    * Move upgrade calls from debian-edu-add_local_apt to pre-pkgsel.d,
    to make sure sources.list is updated before trying to upgrade.
    * Rename d-i hook scripts to use the name of their .d directory
    as file name to make it easier to predict when a script will execute,
    and avoid mistakes like the above in the future.
    * Make sure to activate etcinsvk as soon as possible, imediately after
    the base system is installed, to be able to track where changes
    come from.
    * Drop redundant 'aptitude update' from post-base-installer. It is
    also executed in pre-pkginst.
    * Make sure http_proxy is set when calling aptitude and cfengine, to
    make sure both use a proxy when it is required.

    -- Petter Reinholdtsen Mon, 4 Aug 2008 20:54:53 +0200

    The changes can be seen in
    http://svn.debian.org/wsvn/debian-ed...ll/?rev=0&sc=0 >.

    The release in Lenny is revision 44697, and the one in unstable is
    revision 45670.

    Happy hacking,
    --
    Petter Reinholdtsen


    --
    To UNSUBSCRIBE, email to debian-release-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  6. Re: Allow debian-edu-install to propagate to testing

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Petter Reinholdtsen writes:

    > [Petter Reinholdtsen]
    >> Since the upload we have discovered and fixed some bugs in the
    >> package, which are currently being tested in the Debian Edu
    >> repository. We will need at least another update before Lenny is
    >> released, and hope it can be accepted too. We will get back to you
    >> about this.

    >
    > I guess now is a good time to get back to you about this. The version
    > in unstable is the one we have been testing in Debian Edu the last few
    > days, and it seem to work fine. It contain a code move to put it at
    > the correct location in the installer, and a rename of the d-i hooks
    > to make sure the makes reflect their position in the d-i sequence to
    > make sure I do not put code in the wrong location again, and finally
    > fix one leftover code part failing to use a HTTP proxy. I also added
    > some cosmetic changes to speed up the installation and get more fine
    > grained information from etcinsvk, but those are not very important.
    > This is the changelog:


    No objection

    - --
    O T A V I O S A L V A D O R
    - ---------------------------------------------
    E-mail: otavio@debian.org UIN: 5906116
    GNU/Linux User: 239058 GPG ID: 49A5F855
    Home Page: http://otavio.ossystems.com.br
    - ---------------------------------------------
    "Microsoft sells you Windows ... Linux gives
    you the whole house."
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.9 (GNU/Linux)
    Comment: Processed by Mailcrypt 3.5.8+

    iEYEARECAAYFAkih0NsACgkQLqiZQEml+FUjigCgifgfHRzYsn qC2cCSmHy2jr09
    gCEAn2kTb9MSeoVvNhqHhSkD6uL1TNZ7
    =gNSb
    -----END PGP SIGNATURE-----


    --
    To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  7. Re: Allow debian-edu-install to propagate to testing

    Petter Reinholdtsen wrote:
    > [Petter Reinholdtsen]
    >> Since the upload we have discovered and fixed some bugs in the
    >> package, which are currently being tested in the Debian Edu
    >> repository. We will need at least another update before Lenny is
    >> released, and hope it can be accepted too. We will get back to you
    >> about this.

    >
    > I guess now is a good time to get back to you about this. The version
    > in unstable is the one we have been testing in Debian Edu the last few
    > days, and it seem to work fine. It contain a code move to put it at
    > the correct location in the installer, and a rename of the d-i hooks
    > to make sure the makes reflect their position in the d-i sequence to
    > make sure I do not put code in the wrong location again, and finally
    > fix one leftover code part failing to use a HTTP proxy. I also added
    > some cosmetic changes to speed up the installation and get more fine
    > grained information from etcinsvk, but those are not very important.


    unblocked

    Cheers

    Luk


    --
    To UNSUBSCRIBE, email to debian-release-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread