Bug#482305: kernel 2.6.25-2-686 has xen support - Debian

This is a discussion on Bug#482305: kernel 2.6.25-2-686 has xen support - Debian ; Package: linux-image-2.6.25-2-686 Version: 2.6.25-3 Hi, I updated sid/unstable a few minutes ago and when I try to re-compile nvidia propietary module, this message appears: Detected compiler version : 4.1.2 Using compiler gcc-4.1 version 4.1.2 touch /usr/src/modules/nvidia-kernel/nv/gcc-check touch /usr/src/modules/nvidia-kernel/nv/cc-sanity-check ## Main ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Bug#482305: kernel 2.6.25-2-686 has xen support

  1. Bug#482305: kernel 2.6.25-2-686 has xen support

    Package: linux-image-2.6.25-2-686
    Version: 2.6.25-3

    Hi,

    I updated sid/unstable a few minutes ago and when I try to
    re-compile nvidia propietary module, this message appears:

    Detected compiler version : 4.1.2

    Using compiler gcc-4.1 version 4.1.2

    touch /usr/src/modules/nvidia-kernel/nv/gcc-check

    touch /usr/src/modules/nvidia-kernel/nv/cc-sanity-check

    ## Main Make ##

    IGNORE_CC_MISMATCH=1 CC="gcc-4.1" /usr/bin/make -C
    /usr/src/modules/nvidia
    make[2]: Entering directory `/usr/src/modules/nvidia-kernel/nv'

    The kernel you are installing for is a Xen kernel!



    The NVIDIA driver does not currently work on Xen kernels. If

    you are using a stock distribution kernel, please install

    a variant of this kernel without Xen support; if this is a

    custom kernel, please install a standard Linux kernel. Then

    try installing the NVIDIA kernel module again.


    ...then, I think about what kernel is running and this is the
    "standard" (I mean, no xen support)


    root@cube:~# uname -a
    Linux cube.dns-local.net 2.6.25-2-686 #1 SMP Wed May 14 16:42:03 UTC 2008
    i686 GNU/Linux
    root@cube:~#

    apt-cache reveals the following kernels availables

    linux-image-2.6.25-2-486 - Linux 2.6.25 image on x86
    linux-image-2.6.25-2-686 - Linux 2.6.25 image on PPro/Celeron/PII/PIII/P4
    linux-image-2.6.25-2-686-bigmem - Linux 2.6.25 image on
    PPro/Celeron/PII/PIII/P4linux-image-2.6.25-2-amd64 - Linux 2.6.25 image on
    AMD64
    linux-image-2.6.25-2-xen-686 - Linux 2.6.25 image on i686

    but I have installed (none with xen) only these packages:

    ii linux-image-2.6-686 2.6.25+14 Linux
    2.6 image on PPro/Celeron/PII/PIII/P4
    ii linux-image-2.6-k7 2.6.25+14 Linux
    2.6 image on AMD K7 - transition packa
    ii linux-image-2.6.25-2-686 2.6.25-3 Linux
    2.6.25 image on PPro/Celeron/PII/PIII/

    So I don't know if there was a bug while generating -686 version
    and includes xen support (as the package linux-image-2.6.25-2-xen-686) or
    if I have another problem (maybe related to nvidia propietary module)



    --
    To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Bug#482305: marked as done (kernel 2.6.25-2-686 has xen support)


    Your message dated Wed, 21 May 2008 20:12:01 +0200
    with message-id <20080521181200.GR27599@baikonur.stro.at>
    and subject line Re: Bug#482305: kernel 2.6.25-2-686 has xen support
    has caused the Debian Bug report #482305,
    regarding kernel 2.6.25-2-686 has xen support
    to be marked as done.

    This means that you claim that the problem has been dealt with.
    If this is not the case it is now your responsibility to reopen the
    Bug report if necessary, and/or fix the problem forthwith.

    (NB: If you are a system administrator and have no idea what this
    message is talking about, this may indicate a serious mail system
    misconfiguration somewhere. Please contact owner@bugs.debian.org
    immediately.)


    --
    482305: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=482305
    Debian Bug Tracking System
    Contact owner@bugs.debian.org with problems


+ Reply to Thread