Base system installation errors in testing due to libldap - Debian

This is a discussion on Base system installation errors in testing due to libldap - Debian ; Hi, For amd64 at least I'm currently getting installation errors due to the fact that both libldap2 and libldap-2.4-2 are in testing and getting installed, which results in: libldap-2.4-2: Conflicts: libldap2 but 2.1.30.dfsg-13.5 is to be installed Could someone please ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: Base system installation errors in testing due to libldap

  1. Base system installation errors in testing due to libldap

    Hi,

    For amd64 at least I'm currently getting installation errors due to the fact
    that both libldap2 and libldap-2.4-2 are in testing and getting installed,
    which results in:

    libldap-2.4-2: Conflicts: libldap2 but 2.1.30.dfsg-13.5 is to be installed

    Could someone please look into this?

    My local mirror is up to date with ftp-master per 08:00 UTC today.

    Cheers,
    FJP

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.6 (GNU/Linux)

    iD8DBQBIMD3Lgm/Kwh6ICoQRApQAAKCEtG5BGOwazGLNPf2+XZdN/qQg+ACgr7tR
    o3OtJaUqgz1uwr4URVRjzws=
    =TmqT
    -----END PGP SIGNATURE-----


  2. Re: Base system installation errors in testing due to libldap

    * Russ Allbery [Sun, 18 May 2008 07:53:36 -0700]:

    > Frans Pop writes:


    > > For amd64 at least I'm currently getting installation errors due to the
    > > fact that both libldap2 and libldap-2.4-2 are in testing and getting
    > > installed, which results in:


    > > libldap-2.4-2: Conflicts: libldap2 but 2.1.30.dfsg-13.5 is to be installed


    > > Could someone please look into this?


    > That would imply that something in the base system is still built against
    > the OpenLDAP 2.1 libraries and probably needs to be binNMU'd. (And the
    > current OpenLDAP packages desperately need another maintainer with time to
    > work on them, but that's a different problem.)


    I don't see such package. Maybe it has to do with the fact that that
    libldap2 is still Prio: important? Frans, are Prio: important packages
    pulled by the default base system install?

    Cheers,

    --
    Adeodato Simó dato at net.com.org.es
    Debian Developer adeodato at debian.org

    Listening to: Albert Pl√* - Virgo vamp


    --
    To UNSUBSCRIBE, email to debian-release-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Re: Base system installation errors in testing due to libldap

    * Adeodato Simů (dato@net.com.org.es) [080518 16:57]:
    > * Russ Allbery [Sun, 18 May 2008 07:53:36 -0700]:
    >
    > > Frans Pop writes:

    >
    > > > For amd64 at least I'm currently getting installation errors due to the
    > > > fact that both libldap2 and libldap-2.4-2 are in testing and getting
    > > > installed, which results in:

    >
    > > > libldap-2.4-2: Conflicts: libldap2 but 2.1.30.dfsg-13.5 is to be installed

    >
    > > > Could someone please look into this?

    >
    > > That would imply that something in the base system is still built against
    > > the OpenLDAP 2.1 libraries and probably needs to be binNMU'd. (And the
    > > current OpenLDAP packages desperately need another maintainer with time to
    > > work on them, but that's a different problem.)

    >
    > I don't see such package. Maybe it has to do with the fact that that
    > libldap2 is still Prio: important? Frans, are Prio: important packages
    > pulled by the default base system install?


    That, together with the fact that two packages depend on it:
    ** libhugs-ldap has an unsatisfied dependency on alpha: libldap2 (>= 2.1.17-1)
    ** libaws2.2 has an unsatisfied dependency on alpha: libldap2 (>= 2.1.17-1)


    Cheers,
    Andi
    --
    http://home.arcor.de/andreas-barth/


    --
    To UNSUBSCRIBE, email to debian-release-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  4. Re: Base system installation errors in testing due to libldap

    On Sunday 18 May 2008, Adeodato Simó wrote:
    > > That would imply that something in the base system is still built
    > > against the OpenLDAP 2.1 libraries and probably needs to be binNMU'd.
    > > (And the current OpenLDAP packages desperately need another maintainer
    > > with time to work on them, but that's a different problem.)

    >
    > I don't see such package. Maybe it has to do with the fact that that
    > libldap2 is still Prio: important? Frans, are Prio: important packages
    > pulled by the default base system install?


    Yes. debootstrap always installs packages with prio important or higher.
    That is what defines the "base system".

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.6 (GNU/Linux)

    iD8DBQBIME45gm/Kwh6ICoQRAlLeAKDPnZl5sKM+fTMsqHQCmQjMkaf+HwCfQKxe
    5m8ir0sz3poHzGa2e279K3A=
    =9MYY
    -----END PGP SIGNATURE-----


  5. Re: Base system installation errors in testing due to libldap

    On Sunday 18 May 2008, Frans Pop wrote:
    > On Sunday 18 May 2008, Adeodato Simó wrote:
    > > I don't see such package. Maybe it has to do with the fact that that
    > > libldap2 is still Prio: important? Frans, are Prio: important packages
    > > pulled by the default base system install?

    >
    > Yes. debootstrap always installs packages with prio important or higher.
    > That is what defines the "base system".


    The priority for the package has been adjusted, so this should be fixed
    after next mirror push.

    Cheers,
    FJP

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.6 (GNU/Linux)

    iD8DBQBIMF1Wgm/Kwh6ICoQRAh0JAKCa2D/qpDjGni7eouQDcQiB9PTl9ACdEEwF
    yibL6FovarqKvTJy85x25Ic=
    =B/cl
    -----END PGP SIGNATURE-----


+ Reply to Thread