Bug#479652: linux-image-2.6.24-1-686: xorg problem with 2.6.24/25 - Debian

This is a discussion on Bug#479652: linux-image-2.6.24-1-686: xorg problem with 2.6.24/25 - Debian ; Package: linux-image-2.6.24-1-686 Version: 2.6.24-6 Severity: important Hi I have Athlon XP on Gigabyte GA-7ZX MB and Matrox MGA450. I have no problems running linux-image-2.6.22-3-k7 With newest 2.6.2{4,5}-1-686 can't start xserver in proper frequency range. I've tested with: - fresh xorg.conf ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: Bug#479652: linux-image-2.6.24-1-686: xorg problem with 2.6.24/25

  1. Bug#479652: linux-image-2.6.24-1-686: xorg problem with 2.6.24/25

    Package: linux-image-2.6.24-1-686
    Version: 2.6.24-6
    Severity: important

    Hi

    I have Athlon XP on Gigabyte GA-7ZX MB and Matrox MGA450.

    I have no problems running linux-image-2.6.22-3-k7

    With newest 2.6.2{4,5}-1-686 can't start xserver in proper
    frequency range.

    I've tested with:
    - fresh xorg.conf -> CRT monitor switches off
    - my old xorg.conf -> 48 Hz vertical (where 2.6.22 gives 75 Hz)

    diff of Xorg.0.logs 2.6.22 v 2.6.24 gives only (with my conf):

    313c313
    < (II) MGA(0): I2C Monitor info: 0x8214a78
    ---
    > (II) MGA(0): I2C Monitor info: 0x8214a70

    690,691c690,691
    < (II) MGA(0): [drm] added 8192 byte SAREA at 0xfac4a000
    < (II) MGA(0): [drm] mapped SAREA 0xfac4a000 to 0xb7cc4000
    ---
    > (II) MGA(0): [drm] added 8192 byte SAREA at 0xf8bef000
    > (II) MGA(0): [drm] mapped SAREA 0xf8bef000 to 0xb7bee000



    Mirek


    -- Package-specific info:

    -- System Information:
    Debian Release: lenny/sid
    APT prefers testing
    APT policy: (991, 'testing'), (50, 'unstable')
    Architecture: i386 (i686)

    Kernel: Linux 2.6.25-1-686 (SMP w/1 CPU core)
    Locale: LANG=pl_PL, LC_CTYPE=pl_PL (charmap=ISO-8859-2) (ignored: LC_ALL set to pl_PL)
    Shell: /bin/sh linked to /bin/bash

    Versions of packages linux-image-2.6.24-1-686 depends on:
    ii debconf [debconf-2.0] 1.5.21 Debian configuration management sy
    ii initramfs-tools [linux-initra 0.92a tools for generating an initramfs
    ii module-init-tools 3.4-1 tools for managing Linux kernel mo

    Versions of packages linux-image-2.6.24-1-686 recommends:
    ii libc6-i686 2.7-10 GNU C Library: Shared libraries [i

    -- debconf information:
    linux-image-2.6.24-1-686/preinst/overwriting-modules-2.6.24-1-686: true
    linux-image-2.6.24-1-686/postinst/bootloader-error-2.6.24-1-686:
    linux-image-2.6.24-1-686/postinst/create-kimage-link-2.6.24-1-686: true
    linux-image-2.6.24-1-686/prerm/would-invalidate-boot-loader-2.6.24-1-686: true
    linux-image-2.6.24-1-686/preinst/initrd-2.6.24-1-686:
    linux-image-2.6.24-1-686/preinst/lilo-has-ramdisk:
    linux-image-2.6.24-1-686/preinst/abort-install-2.6.24-1-686:
    linux-image-2.6.24-1-686/prerm/removing-running-kernel-2.6.24-1-686: true
    linux-image-2.6.24-1-686/preinst/abort-overwrite-2.6.24-1-686:
    linux-image-2.6.24-1-686/postinst/bootloader-test-error-2.6.24-1-686:
    linux-image-2.6.24-1-686/preinst/lilo-initrd-2.6.24-1-686: true
    shared/kernel-image/really-run-bootloader: true
    linux-image-2.6.24-1-686/postinst/old-system-map-link-2.6.24-1-686: true
    linux-image-2.6.24-1-686/preinst/failed-to-move-modules-2.6.24-1-686:
    linux-image-2.6.24-1-686/postinst/depmod-error-initrd-2.6.24-1-686: false
    linux-image-2.6.24-1-686/preinst/bootloader-initrd-2.6.24-1-686: true
    linux-image-2.6.24-1-686/postinst/old-initrd-link-2.6.24-1-686: true
    linux-image-2.6.24-1-686/postinst/old-dir-initrd-link-2.6.24-1-686: true
    linux-image-2.6.24-1-686/postinst/depmod-error-2.6.24-1-686: false
    linux-image-2.6.24-1-686/preinst/elilo-initrd-2.6.24-1-686: true
    linux-image-2.6.24-1-686/postinst/kimage-is-a-directory:



    --
    To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Bug#479652: linux-image-2.6.24-1-686: xorg problem with 2.6.24/25

    On Tue, 06 May 2008, Miroslaw Kwasniak wrote:
    >
    > I have Athlon XP on Gigabyte GA-7ZX MB and Matrox MGA450.
    >
    > I have no problems running linux-image-2.6.22-3-k7
    >
    > With newest 2.6.2{4,5}-1-686 can't start xserver in proper
    > frequency range.
    >
    > I've tested with:
    > - fresh xorg.conf -> CRT monitor switches off
    > - my old xorg.conf -> 48 Hz vertical (where 2.6.22 gives 75 Hz)
    >
    > diff of Xorg.0.logs 2.6.22 v 2.6.24 gives only (with my conf):
    >
    > 313c313
    > < (II) MGA(0): I2C Monitor info: 0x8214a78
    > ---
    > > (II) MGA(0): I2C Monitor info: 0x8214a70

    > 690,691c690,691
    > < (II) MGA(0): [drm] added 8192 byte SAREA at 0xfac4a000
    > < (II) MGA(0): [drm] mapped SAREA 0xfac4a000 to 0xb7cc4000
    > ---
    > > (II) MGA(0): [drm] added 8192 byte SAREA at 0xf8bef000
    > > (II) MGA(0): [drm] mapped SAREA 0xf8bef000 to 0xb7bee000


    what mga and xorg version are you running?

    did the xorg upgrade lately help?

    --
    maks



    --
    To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Bug#479652: linux-image-2.6.24-1-686: xorg problem with 2.6.24/25

    On Sat, May 10, 2008 at 12:16:58AM +0200, maximilian attems wrote:
    >
    > what mga and xorg version are you running?


    xserver-xorg-video-mga 1:1.4.8.dfsg.1-1
    xserver-xorg 1:7.3+10

    > did the xorg upgrade lately help?


    No.

    Even worse - my investigations caused temporary monitor failure
    Cooling about 10 minutes turned it to an operational state.

    I see that my problem is probably in the framebuffer code.

    Facts that I found:

    1) I managed to start X with kernel 2.6.25 adding vga=9 parameter.

    2) With FB & default (almost empty) config X switches off my monitor
    (probably a symptom of to high frequency)

    - ctr-alt-bakspace properly terminates X
    - ctr-alt-{+,-} give no visible effects
    - ctr-alt-Fn isn't able to switch to VT
    I'm sure: a sequence ctr-alt-F1 ctr-alt-bakspace terminates X

    - the monitor failure was provoked with this procedure
    - on tty1 I wrote: sleep 10; DISPLAY=:0 xvidtune -show
    - on tty2: X

    Then monitor had switch off (power-on LED green->yellow) as expected
    and after some delay I saw (LED was still yellow) a violet color on
    screen.

    System was locked. After reset monitor had a temporary failure.

    3) With FB and my config (I've appended it at the end) all modes that I've
    tried have a wrong (to low) frequency, for expample
    - declared 75 Hz, xvidtune displays 75
    - ctrl-panel on monitor (and an visual apperance) gives 49 Hz
    - switching VT's works

    4) At boot time FB causes >30 seconds delay at ide1 probe:

    FB
    [ 2.795029] hdb: WDC WD800JB-00FMA0, ATA DISK drive
    [ 2.850591] hdb: host max PIO5 wanted PIO255(auto-tune) selected PIO4
    [ 2.850591] hdb: UDMA/100 mode selected
    [ 2.850591] Probing IDE interface ide1...
    [ 37.668144] ide1: Wait for ready failed before probe !
    [ 38.803765] hdd: CD-W524E, ATAPI CD/DVD-ROM drive
    [ 38.859411] hdd: host max PIO5 wanted PIO255(auto-tune) selected PIO4
    [ 38.859411] hdd: UDMA/33 mode selected
    [ 38.859411] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    [ 38.859411] ide1 at 0x170-0x177,0x376 on irq 15

    VGA
    [ 3.315290] hdb: WDC WD800JB-00FMA0, ATA DISK drive
    [ 3.373643] hdb: host max PIO5 wanted PIO255(auto-tune) selected PIO4
    [ 3.373643] hdb: UDMA/100 mode selected
    [ 3.373742] Probing IDE interface ide1...
    [ 4.525918] hdd: CD-W524E, ATAPI CD/DVD-ROM drive
    [ 4.584121] hdd: host max PIO5 wanted PIO255(auto-tune) selected PIO4
    [ 4.584292] hdd: UDMA/33 mode selected
    [ 4.586661] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    [ 4.590511] ide1 at 0x170-0x177,0x376 on irq 15


    It's risky to investigate more on my hardware

    Mirek

    ===========
    My ugly very old config:
    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Files"

    # FontPath "/usr/share/fonts/X11/misc"
    # FontPath "/usr/share/fonts/X11/cyrillic"
    # FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
    # FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
    # FontPath "/usr/share/fonts/X11/Type1"
    # FontPath "/usr/share/fonts/X11/100dpi"
    # FontPath "/usr/share/fonts/X11/75dpi"

    # FontPath "/usr/X11R6/lib/X11/fonts/misc"
    # FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
    # FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    # FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    # FontPath "/usr/X11R6/lib/X11/fonts/Type1"
    # FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
    # FontPath "/usr/X11R6/lib/X11/fonts/75dpi"

    # path to defoma fonts
    # FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

    EndSection

    Section "Module"
    ## Load "GLcore"
    Load "bitmap"
    Load "dbe"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "record"
    ## Load "speedo"
    ## Load "type1"
    Load "vbe"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "pl"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/gpmdata"
    # Option "Protocol" "IntelliMouse"
    Option "Protocol" "ImPS/2"
    EndSection

    Section "Device"
    Identifier "Matrox Graphics, Inc. MGA G400/G450"
    Driver "mga"
    #Option UseEDID "False"
    Option "IgnoreEDID" "1"
    Option "NoDDC" "True"

    # BusID "PCI:1:0:0"
    EndSection

    Section "Monitor"
    Identifier "Generic Monitor"
    Option "DPMS"
    HorizSync 31.4-65
    VertRefresh 50-100

    # HorizSync 28-51
    # VertRefresh 43-60
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "Matrox Graphics, Inc. MGA G400/G450"
    Monitor "Generic Monitor"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x960" "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    ####################################
    Section "Device"
    Identifier "matrox 450"
    Option "AGPMode" "4"
    Driver "mga"
    # ChipSet "mgag400"
    # Option "UseFBDev" "false"
    # Option "NoHal" "true"
    BusID "PCI:1:0:0"
    Screen 0
    Option "DRI"
    BoardName "G450"
    EndSection

    Section "Device"
    Identifier "matrox 450-2"
    Option "AGPMode" "4"
    Driver "mga"
    # ChipSet "mgag400"
    # Option "UseFBDev" "false"
    # Option "NoHal" "true"
    BusID "PCI:1:0:0"
    Screen 1
    Option "DRI"
    BoardName "G450"
    EndSection

    Section "Monitor"

    Identifier "LE1024"
    # HorizSync 31.4-31.6,35.1-35.2,35.5-35.6
    #
    # HorizSync 31.4-35.6
    # VertRefresh 50-87
    HorizSync 31.4-85
    VertRefresh 50-100

    Modeline "800x600LE0" 33.30 800 816 856 936 600 600 601 621 -vsync -hsync
    Modeline "800x600LE1" 33.30 800 816 856 936 600 600 601 621 -vsync +hsync +csync
    Modeline "800x600LE2" 29.52 800 816 856 936 600 600 601 742 Interlace
    Modeline "800x600LE3" 33.30 800 816 856 936 600 600 601 621 +VSync +HSync
    EndSection

    Section "Monitor"

    Identifier "LE1024-2"
    # HorizSync 31.4-31.6,35.1-35.2,35.5-35.6
    #
    HorizSync 31.4-85
    VertRefresh 50-120
    Modeline "800x600LE0" 33.30 800 816 856 936 600 600 601 621 -vsync -hsync
    Modeline "800x600LE1" 33.30 800 816 856 936 600 600 601 621 -vsync +hsync +csync
    Modeline "800x600LE2" 29.52 800 816 856 936 600 600 601 742 Interlace
    Modeline "800x600LE3" 33.30 800 816 856 936 600 600 601 621 +VSync +HSync
    EndSection

    Section "Screen"
    Identifier "SLE1024"
    Device "matrox 450"
    Monitor "LE1024"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "1024x768" "640x480" "800x600LE" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1024x768" "640x480" "800x600LE" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1024x768" "640x480" "800x600LE" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1024x768" "640x480" "800x600LE" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1024x768" "640x480" "800x600LE" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1024x768" "640x480" "800x600LE0" "800x600LE1" "800x600LE2" "800x600LE3"
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "SLE1024-2"
    Device "matrox 450-2"
    Monitor "LE1024-2"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "1024x768" "640x480" "800x600LE" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1024x768" "640x480" "800x600LE" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1024x768" "640x480" "800x600LE" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1024x768" "640x480" "800x600LE" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1024x768" "640x480" "800x600LE" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1024x768" "640x480" "800x600LE0" "800x600LE1" "800x600LE2" "800x600LE3"
    EndSubSection
    EndSection


    Section "ServerLayout"
    Identifier "LE"
    Screen "SLE1024" 0 0
    # Screen "SLE1024-2" 0 0
    # Screen "SLE1024-2" Rightof "SLE1024"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    EndSection





    --
    To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  4. Bug#479652: linux-image-2.6.24-1-686: xorg problem with 2.6.24/25

    On Sat, May 10, 2008 at 12:16:58AM +0200, maximilian attems wrote:
    > what mga and xorg version are you running?

    ^^^
    If you meant a hardware then here lspci:

    01:00.0 0300: 102b:0525 (rev 85) (prog-if 00 [VGA controller])
    01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400/G450 (rev 85)
    (prog-if 00 [VGA controller])
    Subsystem: Matrox Graphics, Inc. Millennium G450 32Mb SDRAM Dual
    Head
    Flags: bus master, medium devsel, latency 64, IRQ 16
    Memory at dc000000 (32-bit, prefetchable) [size=32M]
    Memory at dfafc000 (32-bit, non-prefetchable) [size=16K]
    Memory at df000000 (32-bit, non-prefetchable) [size=8M]
    Expansion ROM at dfac0000 [disabled] [size=128K]
    Capabilities: [dc] Power Management version 2
    Capabilities: [f0] AGP version 2.0
    Kernel driver in use: matroxfb
    Kernel modules: matroxfb_base, matrox_w1





    --
    To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  5. Bug#479652: linux-image-2.6.24-1-686: xorg problem with 2.6.24/25

    On Sun, May 11, 2008 at 01:43:52PM +0200, Miroslaw Kwasniak wrote:
    > I see that my problem is probably in the framebuffer code.


    Recent news:

    linux-image-2.6.24-1-686_2.6.24-7_i386.deb is OK (2.6.24-6 was bad)
    linux-image-2.6.25-2-686_2.6.25-3_i386.deb still buggy



    --
    To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread