[should've replied to debian-devel in addition to bug 476573]

2008/4/17 Rene Engelhard :

> Unfortunately I didn't think about/notice this either, but a etch->sid
> dist-upgrade with openoffice.org-voikko involved now fails with the
> scriplets using -env.


Yes, that's unfortunately true.

> Option 2
> --------
> Policy 7.2 says you need a Pre-Depends for such cases...


I tried around with this last night for various rounds, and settled
now for this:
http://mentors.debian.net/debian/poo...ikko_2.2-3.dsc
debdiff attached.

I'm not sure if both -common (unopkg) and -core (unopkg.bin)
pre-dependencies are really needed, but I added them while trying to
find out the problems I had.

The problem I was having was that since the old voikko is removed
before the new one is installed, the new preinst is called with
install instead of upgrade. So I decided to remove the old voikko
extensions also when preinst is called with install, since postinst
anyway installs the new voikko again. One possible problematic
situation with more than one old voikko extensions was also resolved.

There is a remaining concern that since the old openoffice.org-core is
removed before the old openoffice.org-voikko, the old extension is not
removed by the old OOo. However, the new unopkg seems to do a fine job
removing the old extension, too, unlike maybe some time ago when OOo
was a bit more shaky about these things. So, currently with this
version I'm successfully having etch -> lenny upgrades (or, lenny + my
local ooo-voikko repo with this version). The new unopkg is usable at
the time ooo-voikko's preins tis called, old voikko version is removed
and new one is installed. The extension works, as does extensions
dialog in OOo (the dialog didn't start when the old voikko wasn't
removed properly).

Pre-Depends should be used sparingly, but it would seem like a good fit here.

-Timo


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org