Package: linux-image-2.6.24-1-xen-686
Version: 2.6.24-6
Severity: important
Tags: upstream

The kernel image does not have CONFIG_XEN_PRIVILEGED_GUEST=y set and
/var/lib/linux-image-2.6.24-1-xen-686/xen-versions is empty. This is
a regression from previous versions and causes update-grub not to
add a stanza for the hypervisor. As a result, 2.6.24 cannot be used
on a xen host.

I am told this is an upstream problem. I am filing it with debbugs
for posterity.

Apparently 2.6.25, which is about to hit sid, will support x86_32
again, and *_64 has to wait for 2.6.24.

This also means that lenny will likely not support xen dom0 on
amd64.

-- System Information:
Debian Release: lenny/sid
APT prefers unstable
APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.24-1-686 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages linux-image-2.6.24-1-xen-686 depends on:
ii initramfs-tools 0.92 tools for generating an initramfs
ii linux-modules-2.6.24-1-xen-68 2.6.24-6 Linux 2.6.24 modules on i686

Versions of packages linux-image-2.6.24-1-xen-686 recommends:
ii libc6-xen 2.7-10 GNU C Library: Shared libraries [X

-- no debconf information

--
.''`. martin f. krafft
: :' : proud Debian developer, author, administrator, and user
`. `'` http://people.debian.org/~madduck - http://debiansystem.info
`- Debian - when you have better things to do than fixing systems

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFIDvuLIgvIgzMMSnURAulNAJ95u5wvNj+p8qLWwCzdm8 RCIryzTgCdE75A
GptlUa30B7pEDeZk3/uLjEQ=
=Jw8r
-----END PGP SIGNATURE-----