kernel 2.6.24 & speakup - Debian

This is a discussion on kernel 2.6.24 & speakup - Debian ; maximilian attems, le Tue 25 Mar 2008 23:27:14 +0100, a écrit : > On Tue, Mar 25, 2008 at 07:43:47PM +0000, Samuel Thibault wrote: > > maximilian attems, le Tue 25 Mar 2008 20:13:30 +0100, a écrit : > > ...

+ Reply to Thread
Page 3 of 3 FirstFirst 1 2 3
Results 41 to 53 of 53

Thread: kernel 2.6.24 & speakup

  1. Re: kernel 2.6.24 & speakup

    maximilian attems, le Tue 25 Mar 2008 23:27:14 +0100, a écrit :
    > On Tue, Mar 25, 2008 at 07:43:47PM +0000, Samuel Thibault wrote:
    > > maximilian attems, le Tue 25 Mar 2008 20:13:30 +0100, a écrit :
    > > >
    > > > once it is in next

    > >
    > > "in next"?

    >
    > next is the linux tree of things that are ready for the next
    > merge window aka 2.6.26 now.


    Ok.

    > > > 2.6.24 window is closed anyway.

    > >
    > > You mean the upstream or the Debian?

    >
    > debian


    Ah, so since Lenny's d-i is supposed to use 2.6.24, speakup won't make
    it into it :/

    Thanks for the info anyway,
    Samuel


    --
    To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: kernel 2.6.24 & speakup

    maximilian attems, le Tue 25 Mar 2008 23:27:14 +0100, a écrit :
    > On Tue, Mar 25, 2008 at 07:43:47PM +0000, Samuel Thibault wrote:
    > > maximilian attems, le Tue 25 Mar 2008 20:13:30 +0100, a écrit :
    > > >
    > > > once it is in next

    > >
    > > "in next"?

    >
    > next is the linux tree of things that are ready for the next
    > merge window aka 2.6.26 now.


    Ok.

    > > > 2.6.24 window is closed anyway.

    > >
    > > You mean the upstream or the Debian?

    >
    > debian


    Ah, so since Lenny's d-i is supposed to use 2.6.24, speakup won't make
    it into it :/

    Thanks for the info anyway,
    Samuel


    --
    To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Re: kernel 2.6.24 & speakup

    Samuel Thibault writes:

    >> > > 2.6.24 window is closed anyway.
    >> >
    >> > You mean the upstream or the Debian?

    >>
    >> debian

    >
    > Ah, so since Lenny's d-i is supposed to use 2.6.24, speakup won't make
    > it into it :/


    Beta2 is probably going to be released with 2.6.24 but I guess lenny
    will still be updated for 2.6.25/2.6.26 (up to kernel team to decide
    about it).

    --
    O T A V I O S A L V A D O R
    ---------------------------------------------
    E-mail: otavio@debian.org UIN: 5906116
    GNU/Linux User: 239058 GPG ID: 49A5F855
    Home Page: http://otavio.ossystems.com.br
    ---------------------------------------------
    "Microsoft sells you Windows ... Linux gives
    you the whole house."


    --
    To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  4. Re: kernel 2.6.24 & speakup

    Samuel Thibault writes:

    >> > > 2.6.24 window is closed anyway.
    >> >
    >> > You mean the upstream or the Debian?

    >>
    >> debian

    >
    > Ah, so since Lenny's d-i is supposed to use 2.6.24, speakup won't make
    > it into it :/


    Beta2 is probably going to be released with 2.6.24 but I guess lenny
    will still be updated for 2.6.25/2.6.26 (up to kernel team to decide
    about it).

    --
    O T A V I O S A L V A D O R
    ---------------------------------------------
    E-mail: otavio@debian.org UIN: 5906116
    GNU/Linux User: 239058 GPG ID: 49A5F855
    Home Page: http://otavio.ossystems.com.br
    ---------------------------------------------
    "Microsoft sells you Windows ... Linux gives
    you the whole house."


    --
    To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  5. Re: kernel 2.6.24 & speakup

    On Tue, 25 Mar 2008, Samuel Thibault wrote:

    > Ah, so since Lenny's d-i is supposed to use 2.6.24, speakup won't make
    > it into it :/


    as otavio said we gonna release with > 2.6.24
    for debian 2.6.24 stuff would have to go through the stable releases.

    7 out of 9 hunks FAILED -- saving rejects to file
    drivers/char/keyboard.c.rej
    12 out of 16 hunks FAILED -- saving rejects to file drivers/char/vt.c.rej
    1 out of 2 hunks FAILED -- saving rejects to file
    include/linux/keyboard.h.rej
    1 out of 1 hunk FAILED -- saving rejects to file
    include/linux/notifier.h.rej
    1 out of 1 hunk FAILED -- saving rejects to file include/linux/vt.h.rej
    (+) FAIL notifier-integration.patch

    notifier-integration.patch taken from HEAD
    465da369435f5dc853656bb01731c59759d0a5e2
    it'be nice if your git repo would feature a gitweb and a git server.
    anyway the -mm patch
    ftp://ftp.kernel.org/pub/linux/kerne...notifier.patch
    seems to apply fine for 2.6.25, but has none of the wanted exports.



    --
    To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  6. Re: kernel 2.6.24 & speakup

    On Tue, 25 Mar 2008, Samuel Thibault wrote:

    > Ah, so since Lenny's d-i is supposed to use 2.6.24, speakup won't make
    > it into it :/


    as otavio said we gonna release with > 2.6.24
    for debian 2.6.24 stuff would have to go through the stable releases.

    7 out of 9 hunks FAILED -- saving rejects to file
    drivers/char/keyboard.c.rej
    12 out of 16 hunks FAILED -- saving rejects to file drivers/char/vt.c.rej
    1 out of 2 hunks FAILED -- saving rejects to file
    include/linux/keyboard.h.rej
    1 out of 1 hunk FAILED -- saving rejects to file
    include/linux/notifier.h.rej
    1 out of 1 hunk FAILED -- saving rejects to file include/linux/vt.h.rej
    (+) FAIL notifier-integration.patch

    notifier-integration.patch taken from HEAD
    465da369435f5dc853656bb01731c59759d0a5e2
    it'be nice if your git repo would feature a gitweb and a git server.
    anyway the -mm patch
    ftp://ftp.kernel.org/pub/linux/kerne...notifier.patch
    seems to apply fine for 2.6.25, but has none of the wanted exports.



    --
    To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  7. Re: kernel 2.6.24 & speakup

    Hello,

    maximilian attems, le Wed 26 Mar 2008 14:58:57 +0100, a écrit :
    > On Tue, 25 Mar 2008, Samuel Thibault wrote:
    >
    > > Ah, so since Lenny's d-i is supposed to use 2.6.24, speakup won't make
    > > it into it :/

    >
    > as otavio said we gonna release with > 2.6.24
    > for debian 2.6.24 stuff would have to go through the stable releases.
    >
    > 7 out of 9 hunks FAILED -- saving rejects to file
    > drivers/char/keyboard.c.rej
    > 12 out of 16 hunks FAILED -- saving rejects to file drivers/char/vt.c.rej
    > 1 out of 2 hunks FAILED -- saving rejects to file
    > include/linux/keyboard.h.rej
    > 1 out of 1 hunk FAILED -- saving rejects to file
    > include/linux/notifier.h.rej
    > 1 out of 1 hunk FAILED -- saving rejects to file include/linux/vt.h.rej
    > (+) FAIL notifier-integration.patch
    >
    > notifier-integration.patch taken from HEAD
    > 465da369435f5dc853656bb01731c59759d0a5e2


    Little wonder you get so many failures: you don't need to apply that
    patch: keyboard/vt notifiers are _already_ in 2.6.24 kernels.

    Again, the only patch you need to apply to 2.6.24 is
    speakup/patches/kernel-integration-2.6.24-source.patch
    and then you can compile speakup as an independant module from the src/
    directory. No need to fetch other patches like the one below

    > it'be nice if your git repo would feature a gitweb and a git server.
    > anyway the -mm patch
    > ftp://ftp.kernel.org/pub/linux/kerne...notifier.patch
    > seems to apply fine for 2.6.25, but has none of the wanted exports.


    It indeed isn't needed at all for speaup.

    Samuel


    --
    To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  8. Re: kernel 2.6.24 & speakup

    Hello,

    maximilian attems, le Wed 26 Mar 2008 14:58:57 +0100, a écrit :
    > On Tue, 25 Mar 2008, Samuel Thibault wrote:
    >
    > > Ah, so since Lenny's d-i is supposed to use 2.6.24, speakup won't make
    > > it into it :/

    >
    > as otavio said we gonna release with > 2.6.24
    > for debian 2.6.24 stuff would have to go through the stable releases.
    >
    > 7 out of 9 hunks FAILED -- saving rejects to file
    > drivers/char/keyboard.c.rej
    > 12 out of 16 hunks FAILED -- saving rejects to file drivers/char/vt.c.rej
    > 1 out of 2 hunks FAILED -- saving rejects to file
    > include/linux/keyboard.h.rej
    > 1 out of 1 hunk FAILED -- saving rejects to file
    > include/linux/notifier.h.rej
    > 1 out of 1 hunk FAILED -- saving rejects to file include/linux/vt.h.rej
    > (+) FAIL notifier-integration.patch
    >
    > notifier-integration.patch taken from HEAD
    > 465da369435f5dc853656bb01731c59759d0a5e2


    Little wonder you get so many failures: you don't need to apply that
    patch: keyboard/vt notifiers are _already_ in 2.6.24 kernels.

    Again, the only patch you need to apply to 2.6.24 is
    speakup/patches/kernel-integration-2.6.24-source.patch
    and then you can compile speakup as an independant module from the src/
    directory. No need to fetch other patches like the one below

    > it'be nice if your git repo would feature a gitweb and a git server.
    > anyway the -mm patch
    > ftp://ftp.kernel.org/pub/linux/kerne...notifier.patch
    > seems to apply fine for 2.6.25, but has none of the wanted exports.


    It indeed isn't needed at all for speaup.

    Samuel


    --
    To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  9. Re: kernel 2.6.24 & speakup

    maximilian attems, le Wed 26 Mar 2008 14:58:57 +0100, a écrit :
    > anyway the -mm patch
    > ftp://ftp.kernel.org/pub/linux/kerne...notifier.patch
    > seems to apply fine for 2.6.25, but has none of the wanted exports.


    BTW, the patch that adds the export is
    basic-braille-screen-reader-support.patch

    Samuel


    --
    To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  10. Re: kernel 2.6.24 & speakup

    On Thu, Mar 27, 2008 at 03:39:42PM +0100, Samuel Thibault wrote:
    > maximilian attems, le Wed 26 Mar 2008 14:58:57 +0100, a écrit :
    > > anyway the -mm patch
    > > ftp://ftp.kernel.org/pub/linux/kerne...notifier.patch
    > > seems to apply fine for 2.6.25, but has none of the wanted exports.

    >
    > BTW, the patch that adds the export is
    > basic-braille-screen-reader-support.patch


    i have head ache today, so i'll keep it short.
    it would be great if this messy thread comes to some result.

    the braille module itself unless merged would be in
    linux-modules-extra. does it still need a specific patch in linux-2.6
    itself for 2.6.25 and if yes please point to the mm one instead
    of letting people fish in the dark, thanks


    --
    To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  11. Re: kernel 2.6.24 & speakup

    maximilian attems, le Thu 27 Mar 2008 17:13:58 +0100, a écrit :
    > On Thu, Mar 27, 2008 at 03:39:42PM +0100, Samuel Thibault wrote:
    > > maximilian attems, le Wed 26 Mar 2008 14:58:57 +0100, a écrit :
    > > > anyway the -mm patch
    > > > ftp://ftp.kernel.org/pub/linux/kerne...notifier.patch
    > > > seems to apply fine for 2.6.25, but has none of the wanted exports.

    > >
    > > BTW, the patch that adds the export is
    > > basic-braille-screen-reader-support.patch

    >
    > i have head ache today, so i'll keep it short.
    > it would be great if this messy thread comes to some result.
    >
    > the braille module itself unless merged would be in
    > linux-modules-extra. does it still need a specific patch in linux-2.6
    > itself for 2.6.25 and if yes please point to the mm one instead
    > of letting people fish in the dark, thanks


    Erf, it looks like I've brought even more confusion with that braille
    patch. I'll try to be clearly sum up:

    - Vanilla 2.6.24 has keyboard/VT notifier support
    - both braille module and speakup need additional 4 exports to work
    - to get braille module in -mm, I had to stuff the 4 exports in its
    patch

    Now, I was not talking about importing the whole braille module patch
    into the debian kernel, but just the 4 exports, so that speakup can be
    compiled as modules. So

    - either (as I originally said in the thread) apply Speakup's
    speakup/patches/kernel-integration-2.6.24-source.patch ,
    - or use the equivalent exerpt of the -mm braille patch, attached to
    this mail.

    and then speakup can be compiled as separate modules in
    linux-modules-extra.

    Samuel


  12. Re: kernel 2.6.24 & speakup

    On Thu, 27 Mar 2008, Samuel Thibault wrote:

    > Erf, it looks like I've brought even more confusion with that braille
    > patch. I'll try to be clearly sum up:
    >
    > - Vanilla 2.6.24 has keyboard/VT notifier support
    > - both braille module and speakup need additional 4 exports to work


    ok understood, thanks

    > Now, I was not talking about importing the whole braille module patch
    > into the debian kernel, but just the 4 exports, so that speakup can be
    > compiled as modules. So
    >
    > - either (as I originally said in the thread) apply Speakup's
    > speakup/patches/kernel-integration-2.6.24-source.patch ,
    > - or use the equivalent exerpt of the -mm braille patch, attached to
    > this mail.


    cool applies fine to 2.6.25-rc7, add to current linux-2.6 trunk.
    will be in the next 2.6.25 upload, that can be expected soon.

    bonne soirée
    max


    --
    To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  13. Re: kernel 2.6.24 & speakup

    maximilian attems, le Thu 27 Mar 2008 21:13:49 +0100, a écrit :
    > On Thu, 27 Mar 2008, Samuel Thibault wrote:
    >
    > > Erf, it looks like I've brought even more confusion with that braille
    > > patch. I'll try to be clearly sum up:
    > >
    > > - Vanilla 2.6.24 has keyboard/VT notifier support
    > > - both braille module and speakup need additional 4 exports to work

    >
    > ok understood, thanks
    >
    > > Now, I was not talking about importing the whole braille module patch
    > > into the debian kernel, but just the 4 exports, so that speakup can be
    > > compiled as modules. So
    > >
    > > - either (as I originally said in the thread) apply Speakup's
    > > speakup/patches/kernel-integration-2.6.24-source.patch ,
    > > - or use the equivalent exerpt of the -mm braille patch, attached to
    > > this mail.

    >
    > cool applies fine to 2.6.25-rc7, add to current linux-2.6 trunk.
    > will be in the next 2.6.25 upload, that can be expected soon.


    Cool, thanks!

    Samuel


    --
    To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread
Page 3 of 3 FirstFirst 1 2 3