Re: preparing sid/lenny to build with GCC-4.3 - Debian

This is a discussion on Re: preparing sid/lenny to build with GCC-4.3 - Debian ; On Sun, Jan 27, 2008 at 10:53:59PM +0100, Matthias Klose wrote: > (...) so that we have > the chance to drop gcc-4.2 for the next release (together with > gcc-3.4/g++-3.4/gcc-4.0). Except if you want to remove qemu and kvm ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: Re: preparing sid/lenny to build with GCC-4.3

  1. Re: preparing sid/lenny to build with GCC-4.3

    On Sun, Jan 27, 2008 at 10:53:59PM +0100, Matthias Klose wrote:
    > (...) so that we have
    > the chance to drop gcc-4.2 for the next release (together with
    > gcc-3.4/g++-3.4/gcc-4.0).


    Except if you want to remove qemu and kvm from the archive, there are
    currently no chances of removing gcc-3.4.

    Mike


    --
    To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: preparing sid/lenny to build with GCC-4.3

    On Jan 28, 2008 4:53 AM, Mike Hommey wrote:
    > On Sun, Jan 27, 2008 at 10:53:59PM +0100, Matthias Klose wrote:
    > > (...) so that we have
    > > the chance to drop gcc-4.2 for the next release (together with
    > > gcc-3.4/g++-3.4/gcc-4.0).

    >
    > Except if you want to remove qemu and kvm from the archive, there are
    > currently no chances of removing gcc-3.4.


    Is there no way at all of fixing those so that they can be built with 4.3 ?

    --
    Besos,
    Marga


    --
    To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Re: preparing sid/lenny to build with GCC-4.3

    On Mon, Jan 28, 2008 at 12:17:48PM -0200, Margarita Manterola wrote:
    > On Jan 28, 2008 4:53 AM, Mike Hommey wrote:
    > > On Sun, Jan 27, 2008 at 10:53:59PM +0100, Matthias Klose wrote:
    > > > (...) so that we have
    > > > the chance to drop gcc-4.2 for the next release (together with
    > > > gcc-3.4/g++-3.4/gcc-4.0).

    > >
    > > Except if you want to remove qemu and kvm from the archive, there are
    > > currently no chances of removing gcc-3.4.

    >
    > Is there no way at all of fixing those so that they can be built with 4.3 ?


    There are finally some patches [1], but it is still being discussed.

    Mike

    1. http://lists.gnu.org/archive/html/qe.../msg00380.html


    --
    To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  4. Re: preparing sid/lenny to build with GCC-4.3

    > Is there no way at all of fixing those so that they can be built with 4.3?


    And about applications or packages not in Debian ?
    In particular, gcc/g++-3.4 is often used in the embedded world.


  5. Re: preparing sid/lenny to build with GCC-4.3

    Mike Hommey a écrit :
    > On Mon, Jan 28, 2008 at 12:17:48PM -0200, Margarita Manterola wrote:
    >> On Jan 28, 2008 4:53 AM, Mike Hommey wrote:
    >>> On Sun, Jan 27, 2008 at 10:53:59PM +0100, Matthias Klose wrote:
    >>>> (...) so that we have
    >>>> the chance to drop gcc-4.2 for the next release (together with
    >>>> gcc-3.4/g++-3.4/gcc-4.0).
    >>> Except if you want to remove qemu and kvm from the archive, there are
    >>> currently no chances of removing gcc-3.4.

    >> Is there no way at all of fixing those so that they can be built with 4.3 ?

    >
    > There are finally some patches [1], but it is still being discussed.
    >


    Those patches have been rejected^Wignored by Fabrice Bellard, and anyway
    don't really works with gcc-4.3. He is currently working on a new code
    generator to replace dyngen, however I am not sure it will be finished
    for Lenny.

    Note however that qemu doesn't need g++, and I think it is the same for
    the remaining programs using gcc-3.4, so this language could probably
    dropped.

    --
    .''`. Aurelien Jarno | GPG: 1024D/F1BCDB73
    : :' : Debian developer | Electrical Engineer
    `. `' aurel32@debian.org | aurelien@aurel32.net
    `- people.debian.org/~aurel32 | www.aurel32.net


    --
    To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  6. Re: preparing sid/lenny to build with GCC-4.3

    On Mon, Jan 28, 2008 at 07:53:19AM +0100, Mike Hommey wrote:
    > On Sun, Jan 27, 2008 at 10:53:59PM +0100, Matthias Klose wrote:
    > > (...) so that we have
    > > the chance to drop gcc-4.2 for the next release (together with
    > > gcc-3.4/g++-3.4/gcc-4.0).

    > Except if you want to remove qemu and kvm from the archive, there are
    > currently no chances of removing gcc-3.4.


    This is incorrect. The s390 port needs at least 3.4 to do something and
    4.0 to work correctly.

    Bastian

    --
    Warp 7 -- It's a law we can live with.


    --
    To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread