Gtk 2.8.20 - Debian

This is a discussion on Gtk 2.8.20 - Debian ; Hi I wish to make Gtk 2.8.20, but request me beatwen all Cairo i Atk, and no stands a problems Cairo makes me following mistake (error) /tmp/ccI1Jeqi.s: Assembler messages: /tmp/ccI1Jeqi.s:8651: Error: symbol `_cairo_pixman_composite' is already defined make[3]: *** [fbpict.lo] Greška ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Gtk 2.8.20

  1. Gtk 2.8.20

    Hi
    I wish to make Gtk 2.8.20, but request me beatwen all Cairo i Atk, and
    no stands a problems
    Cairo makes me following mistake (error)

    /tmp/ccI1Jeqi.s: Assembler messages:
    /tmp/ccI1Jeqi.s:8651: Error: symbol `_cairo_pixman_composite' is already
    defined
    make[3]: *** [fbpict.lo] Greška 1 (<=Stands for error 1 )
    make[3]: Izlazim iz direktorija `/home/darko/GtkT/cairo-1.0.2/pixman/src'
    make[2]: *** [all-recursive] Greška 1 (<=Stands for error 1 )
    make[2]: Izlazim iz direktorija `/home/darko/GtkT/cairo-1.0.2/pixman'
    make[1]: *** [all-recursive] Greška 1 (<=Stands for error 1 )
    make[1]: Izlazim iz direktorija `/home/darko/GtkT/cairo-1.0.2'
    make: *** [all] Greška 2 (<=Stands for error 2 )
    localhost:/home/darko/GtkT/cairo-1.0.2#airo
    /tmp/ccI1Jeqi.s: Assembler messages:
    /tmp/ccI1Jeqi.s:8651: Error: symbol `_cairo_pixman_composite' is already
    defined
    make[3]: *** [fbpict.lo] Greška 1 (<=Stands for error 1 )
    make[3]: Izlazim iz direktorija `/home/darko/GtkT/cairo-1.0.2/pixman/src'
    make[2]: *** [all-recursive] Greška 1 (<=Stands for error 1 )
    make[2]: Izlazim iz direktorija `/home/darko/GtkT/cairo-1.0.2/pixman'
    make[1]: *** [all-recursive] Greška 1 (<=Stands for error 1 )
    make[1]: Izlazim iz direktorija `/home/darko/GtkT/cairo-1.0.2'
    make: *** [all] Greška 2 (<=Stands for error 2)
    localhost:/home/darko/GtkT/cairo-1.0.2#


    ant atk list me this

    checking for GLIB - version >= 2.5.7...
    *** 'pkg-config --modversion glib-2.0' returned 2.8.6, but GLIB (2.12.4)
    *** was found! If pkg-config was correct, then it is best
    *** to remove the old version of GLib. You may also be able to fix the
    error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    *** to point to the correct configuration files
    no
    checking for pkg-config... (cached) /usr/local/bin/pkg-config
    checking for GLIB - version >= 2.0.0...
    *** 'pkg-config --modversion glib-2.0' returned 2.8.6, but GLIB (2.12.4)
    *** was found! If pkg-config was correct, then it is best
    *** to remove the old version of GLib. You may also be able to fix the
    error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    *** to point to the correct configuration files
    no
    configure: error:
    *** GLIB 2.0.0 or better is required. The latest version of
    *** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
    *** but not in the same location as pkg-config add the location of the file
    *** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

    I instaled glib 2.8.6 from source tar.gz not knowing that maybe with
    debian come glib2.12.4




    How to bulid gtk?

    --


    Darko.
    Linux debian-etch 2.6.18-5-686 # i686 GNU/Linux

    "I'm not a vegetarian because I love animals, I'm a vegetarian because I hate vegetables!"
    unknown


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: Gtk 2.8.20

    A Dimarts 15 Gener 2008, Darko va escriure:
    > Hi
    > I wish to make Gtk 2.8.20, but request me beatwen all Cairo i Atk, and
    > no stands a problems
    > Cairo makes me following mistake (error)
    >
    > /tmp/ccI1Jeqi.s: Assembler messages:
    > /tmp/ccI1Jeqi.s:8651: Error: symbol `_cairo_pixman_composite' is already
    > defined
    > make[3]: *** [fbpict.lo] Greška 1 (<=Stands for error 1 )
    > make[3]: Izlazim iz direktorija `/home/darko/GtkT/cairo-1.0.2/pixman/src'
    > make[2]: *** [all-recursive] Greška 1 (<=Stands for error 1 )
    > make[2]: Izlazim iz direktorija `/home/darko/GtkT/cairo-1.0.2/pixman'
    > make[1]: *** [all-recursive] Greška 1 (<=Stands for error 1 )
    > make[1]: Izlazim iz direktorija `/home/darko/GtkT/cairo-1.0.2'
    > make: *** [all] Greška 2 (<=Stands for error 2 )
    > localhost:/home/darko/GtkT/cairo-1.0.2#airo
    > /tmp/ccI1Jeqi.s: Assembler messages:
    > /tmp/ccI1Jeqi.s:8651: Error: symbol `_cairo_pixman_composite' is already
    > defined
    > make[3]: *** [fbpict.lo] Greška 1 (<=Stands for error 1 )
    > make[3]: Izlazim iz direktorija `/home/darko/GtkT/cairo-1.0.2/pixman/src'
    > make[2]: *** [all-recursive] Greška 1 (<=Stands for error 1 )
    > make[2]: Izlazim iz direktorija `/home/darko/GtkT/cairo-1.0.2/pixman'
    > make[1]: *** [all-recursive] Greška 1 (<=Stands for error 1 )
    > make[1]: Izlazim iz direktorija `/home/darko/GtkT/cairo-1.0.2'
    > make: *** [all] Greška 2 (<=Stands for error 2)
    > localhost:/home/darko/GtkT/cairo-1.0.2#
    >
    >
    > ant atk list me this
    >
    > checking for GLIB - version >= 2.5.7...
    > *** 'pkg-config --modversion glib-2.0' returned 2.8.6, but GLIB (2.12.4)
    > *** was found! If pkg-config was correct, then it is best
    > *** to remove the old version of GLib. You may also be able to fix the
    > error
    > *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    > *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    > *** required on your system.
    > *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    > *** to point to the correct configuration files
    > no
    > checking for pkg-config... (cached) /usr/local/bin/pkg-config
    > checking for GLIB - version >= 2.0.0...
    > *** 'pkg-config --modversion glib-2.0' returned 2.8.6, but GLIB (2.12.4)
    > *** was found! If pkg-config was correct, then it is best
    > *** to remove the old version of GLib. You may also be able to fix the
    > error
    > *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    > *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    > *** required on your system.
    > *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    > *** to point to the correct configuration files
    > no
    > configure: error:
    > *** GLIB 2.0.0 or better is required. The latest version of
    > *** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
    > *** but not in the same location as pkg-config add the location of the file
    > *** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.
    >
    > I instaled glib 2.8.6 from source tar.gz not knowing that maybe with
    > debian come glib2.12.4
    >
    >
    >
    >
    > How to bulid gtk?
    >


    Maybe the debian-gtk-gnome@lists.debian.org people could answer your
    question.

    regards,

    Leo

+ Reply to Thread