the most basic: what's wrong w/ my exim ACL? - Debian

This is a discussion on the most basic: what's wrong w/ my exim ACL? - Debian ; running etch (exim4) Trying to diagnose why my ACL isn't working, and I find I cannot even properly execute a simple condition correctly. Here's my ACL: accept message = condition is false condition = ${if eq{23}{123}{1}{0}} when I telnet in, ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: the most basic: what's wrong w/ my exim ACL?

  1. the most basic: what's wrong w/ my exim ACL?

    running etch (exim4)

    Trying to diagnose why my ACL isn't working, and I find I cannot even
    properly execute a simple condition correctly.

    Here's my ACL:

    accept message = condition is false
    condition = ${if eq{23}{123}{1}{0}}

    when I telnet in, and get to the rcpt to: command,
    exim does not respond with "condition is false" as I would expect. it
    says "unexpected failure".

    why isn't my message what I expect it should be?
    (I've tried appending "endpass" with no better results).

    tia - Bob

  2. Re: the most basic: what's wrong w/ my exim ACL?

    On Dec 11, 7:08 pm, bobg.h...@gmail.com wrote:
    > running etch (exim4)
    >
    > Trying to diagnose why my ACL isn't working, and I find I cannot even
    > properly execute a simple condition correctly.
    >
    > Here's my ACL:
    >
    > accept message = condition is false
    > condition = ${if eq{23}{123}{1}{0}}
    >
    > when I telnet in, and get to the rcpt to: command,
    > exim does not respond with "condition is false" as I would expect. it
    > says "unexpected failure".
    >
    > why isn't my message what I expect it should be?
    > (I've tried appending "endpass" with no better results).
    >
    > tia - Bob


    nevermind.
    I finally figured it out.

  3. Re: the most basic: what's wrong w/ my exim ACL?

    On Wed, 12 Dec 2007 17:02:53 -0800 (PST),
    bobg.hahc@gmail.com wrote:

    > On Dec 11, 7:08 pm, bobg.h...@gmail.com wrote:
    > > running etch (exim4)
    > > Trying to diagnose why my ACL isn't working, and I find I cannot
    > > even properly execute a simple condition correctly.
    > > Here's my ACL:
    > > accept message = condition is false
    > > condition = ${if eq{23}{123}{1}{0}}
    > > when I telnet in, and get to the rcpt to: command,
    > > exim does not respond with "condition is false" as I would expect.
    > > it says "unexpected failure".
    > > why isn't my message what I expect it should be?
    > > (I've tried appending "endpass" with no better results).

    > nevermind. I finally figured it out.


    Out of curiosity, what was the resolution to your problem, if you don't
    mind...?


    Fredderic

+ Reply to Thread