Package: wnpp
Severity: wishlist

* Package name : python-ssl
Version : 1.12
Upstream Author : See URL
* URL or Web page : http://pypi.python.org/pypi/ssl/
* License : Python (MIT-like)
Description : SSL wrapper for socket objects

Hello,

The old socket.ssl() support for TLS over sockets is being superseded
in Python 2.6 by a new 'ssl' module. This package brings that module
to older Python releases, 2.3.5 and up (it may also work on older
versions of 2.3, but it is untested).

This Python module can be found on http://pypi.python.org/pypi/ssl/

It's quite similar to the 2.6 ssl module, which is documented on
http://docs.python.org/dev/library/ssl.html

Adding it to Debian would :
- make pre-2.6 Python installations compatible with programs that
make use of the new ssl module ;
- bring new SSL-related features into the current Python packages,
such as certificate validation against trusted authorities.

I plan to use it to add SSL certificate validation support to
OfflineIMAP, in a way that is backward-compatible with older
Python versions.

Thanks,
bye,
--
intrigeri



--
To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org