installation failure: No kernel modules were found - Debian

This is a discussion on installation failure: No kernel modules were found - Debian ; Just after the installer identified an ISO image, I get this error: -------------------------------------------------------------- Load installer components from an installer ISO No kernem modules were found. This probably is due to a mismatch between the kernel used by this version of ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: installation failure: No kernel modules were found

  1. installation failure: No kernel modules were found

    Just after the installer identified an ISO image, I get this error:
    --------------------------------------------------------------
    Load installer components from an installer ISO

    No kernem modules were found. This probably is due to a mismatch
    between the kernel used by this version of the installer and the kernell
    version availale in the archive.
    ------------------------------------------------------------

    I did not get this error a few weeks ago. In the earlier attempt the
    daily build images were stuck at an earlier date because Debian
    ftpmaster (or something similar) was down. I'm using the daily builds.

    Steps, around 2007-11-22 06:00 UTC
    Get via jigdo-lite
    http://cdimage.debian.org/cdimage/da...-netinst.jigdo
    (I also got the business card). Timestamp on 21-Nov-2007 22:09. I'm at
    UTC -08:00; I'm not sure what timezone are reported by my browser for
    remote files.

    Get
    http://people.debian.org/~joeyh/d-i/...ia/boot.img.gz
    It has timestamp 21-Nov-2007 13:16

    Use those to put an installer on a USB stick.
    Boot the stick, select expertGUI, walk through options until I got to
    the error.

    My earlier attempt did not use jigdo and used the business card image.

    Is this the kind of thing I should file a bug about? I figure it might
    be something transitory, or my mistake.

    Ross


    --
    To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: installation failure: No kernel modules were found

    I get the same problem with the business card iso. Here is part of the
    syslog:
    Nov 22 09:06:50 localechooser: info: Set debian-installer/locale =
    'en_US.UTF-8'
    Nov 22 09:07:13 main-menu[1383]: DEBUG: resolver (libc6): package
    doesn't exist (ignored)
    Nov 22 09:07:15 main-menu[1383]: INFO: Menu item 'kbd-chooser' selected
    Nov 22 09:07:15 main-menu[1383]: INFO: Falling back to the package
    description for console-keymaps-at
    Nov 22 09:07:15 main-menu[1383]: INFO: Falling back to the package
    description for console-keymaps-at
    Nov 22 09:07:15 kbd-chooser[1648]: DEBUG: Mounting usbdevfs to look for
    kbd
    Nov 22 09:07:15 kbd-chooser[1648]: DEBUG:
    Parsing /proc/bus/usb/devices
    Nov 22 09:07:15 kbd-chooser[1648]: DEBUG: Adding generic entry for AT
    keymaps
    Nov 22 09:07:15 kbd-chooser[1648]: INFO: keyboard type at: present:
    true:
    Nov 22 09:07:15 kbd-chooser[1648]: INFO: keyboard type at: present:
    unknown
    Nov 22 09:07:15 kbd-chooser[1648]: INFO: Setting
    debian-installer/serial-console to false
    Nov 22 09:07:15 kbd-chooser[1648]: INFO: Setting
    debian-installer/uml-console to false
    Nov 22 09:07:16 kbd-chooser[1648]: INFO: kbd-chooser: arch at selected
    Nov 22 09:07:17 kbd-chooser[1648]: INFO: choose_keymap: keymap = us
    Nov 22 09:07:17 kbd-chooser[1648]: INFO: kbd_chooser: setting keymap us
    Nov 22 09:07:17 main-menu[1383]: DEBUG: resolver (libc6): package
    doesn't exist (ignored)
    Nov 22 09:07:18 main-menu[1383]: INFO: Menu item 'iso-scan' selected
    Nov 22 09:07:18 main-menu[1383]: INFO: Falling back to the package
    description for loop-modules-2.6.22-3-486-di
    Nov 22 09:07:18 main-menu[1383]: INFO: Falling back to the package
    description for loop-modules-2.6.22-3-486-di
    Nov 22 09:07:19 net/hw-detect.hotplug: Detected hotpluggable network
    interface lo
    Nov 22 09:07:19 hw-detect: Detected PCMCIA, installing pcmciautils.
    Nov 22 09:07:19 apt-install: Queueing package pcmciautils for later
    installation
    Nov 22 09:07:19 apt-install: Queueing package udev for later
    installation
    Nov 22 09:07:19 apt-install: Queueing package usbutils for later
    installation
    Nov 22 09:07:19 apt-install: Queueing package acpi for later
    installation
    Nov 22 09:07:19 apt-install: Queueing package acpid for later
    installation
    Nov 22 09:07:19 apt-install: Queueing package acpi-support-base for
    later installation
    Nov 22 09:07:19 apt-install: Queueing package eject for later
    installation
    Nov 22 09:07:19 apt-install: Queueing package libc6-i686 for later
    installation
    Nov 22 09:07:19 net/hw-detect.hotplug: Detected hotpluggable network
    interface lo
    Nov 22 09:07:20 kernel: loop: module loaded
    Nov 22 09:07:20 iso-scan: First pass: Look for ISOs near top-level of
    each filesystem.
    Nov 22 09:07:20 iso-scan: Waiting for /dev/sda to possibly get ready..
    Nov 22 09:07:23 iso-scan: Mounted /dev/sdb for first pass
    Nov 22 09:07:23 iso-scan: Found
    ISO ./debian-testing-i386-businesscard.iso on /dev/sdb
    Nov 22 09:07:23 kernel: ISO 9660 Extensions: Microsoft Joliet Level 3
    Nov 22 09:07:23 kernel: ISO 9660 Extensions: RRIP_1991A
    Nov 22 09:07:23 iso-scan: Detected ISO with 'testing' (lenny)
    distribution
    Nov 22 09:07:31 anna-install: Queueing udeb apt-mirror-setup for later
    installation
    Nov 22 09:07:31 iso-scan: Base system not installable from CD image,
    requesting choose-mirror
    Nov 22 09:07:31 anna-install: Queueing udeb choose-mirror for later
    installation
    Nov 22 09:07:31 main-menu[1383]: DEBUG: resolver (libc6): package
    doesn't exist (ignored)
    Nov 22 09:07:44 main-menu[1383]: INFO: Menu item 'load-iso' selected
    Nov 22 09:07:44 cdrom-retriever: warning: Unable to find
    contrib/debian-installer/binary-i386/Packages
    in /cdrom/dists/lenny/Release.
    Nov 22 09:07:44 cdrom-retriever: warning: Unable to find
    contrib/debian-installer/binary-i386/Packages.gz
    in /cdrom/dists/lenny/Release.
    Nov 22 09:07:44 anna[4499]: WARNING **: no packages for kernel in
    archive
    Nov 22 09:07:52 main-menu[1383]: INFO: Menu item 'load-iso' succeeded
    but requested to be left unconfigured.
    Nov 22 09:07:52 main-menu[1383]: DEBUG: resolver (libc6): package
    doesn't exist (ignored)
    Nov 22 09:08:18 init: Starting pid 1303, console /dev/tty2: '/bin/sh'
    Nov 22 09:10:21 main-menu[1383]: INFO: Falling back to the package
    description for auto-install
    Nov 22 09:10:21 main-menu[1383]: INFO: Falling back to the package
    description for ai-choosers
    Nov 22 09:10:21 main-menu[1383]: INFO: Menu item 'save-logs' selected
    Nov 22 09:10:24 debconf: cdebconf_gtk (process:1374): WARNING: removing
    progress_box


    --
    To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Re: installation failure: No kernel modules were found

    Hi
    > Nov 22 09:07:44 anna[4499]: WARNING **: no packages for kernel in
    > archive



    I had this issue also but I think it was during the weekend. When I took
    the next build it worked. The error was due to a mismatch in the
    versions. Check the kernel version on the installer and on the modules
    in the iso.

    Here You have the issue it the wiki:
    http://wiki.debian.org/DebianInstaller/Today

    # [18 Nov 2007] incomplete CDROMs, netboot works

    regards
    //Peter

    --

    bitrunner

    0708-460260
    Andra Långgatan 28
    41327 Göteborg
    Sweden


    --
    To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread