Package: linux-image-2.6.22-3-amd64
Followup-For: Bug #424661


Well, I've got this same problem with a Xerox Phaser 3124B printer in
two Debian unstable machines with linux-image-2.6.22-3 kernels; one
box is an amd64 and the other one is a x86. The printer is unusable.

Trying to write or read the device /dev/usb/lp0 produces the
desconnection and disappering of the device, which get reconnected. Of
course, cups trying to communicate to the printer produces the same
effect.

In some forums out there seems to be a similar problem in older
versions, which is related to ehci_hcd, and it's solved by removing that
module. I've tryed it but it has no effect here in any box.

IMHO the problem is related to some Debian patch to the kernel: I've
downloaded linux-2.6.23.1 from kernel.org and make it with the config
from linux-image-2.6.22-3 kernel package and the problem has gone.

I'm sure this is not hardware related, but I can provide other
information on demand.

Thanks for your dedicated job.

-- Package-specific info:

-- System Information:
Debian Release: lenny/sid
APT prefers unstable
APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.23.1 (SMP w/1 CPU core)
Locale: LANG=es_AR, LC_CTYPE=es_AR (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages linux-image-2.6.22-3-amd64 depends on:
ii e2fsprogs 1.40.2-1 ext2 file system utilities and lib
ii initramfs-tools [linux-initr 0.91b tools for generating an initramfs
ii module-init-tools 3.3-pre11-4 tools for managing Linux kernel mo

linux-image-2.6.22-3-amd64 recommends no packages.

-- debconf information:
shared/kernel-image/really-run-bootloader: true
linux-image-2.6.22-3-amd64/postinst/create-kimage-link-2.6.22-3-amd64: true
linux-image-2.6.22-3-amd64/postinst/depmod-error-initrd-2.6.22-3-amd64: false
linux-image-2.6.22-3-amd64/prerm/would-invalidate-boot-loader-2.6.22-3-amd64: true
linux-image-2.6.22-3-amd64/postinst/old-system-map-link-2.6.22-3-amd64: true
linux-image-2.6.22-3-amd64/preinst/overwriting-modules-2.6.22-3-amd64: true
linux-image-2.6.22-3-amd64/preinst/failed-to-move-modules-2.6.22-3-amd64:
linux-image-2.6.22-3-amd64/postinst/depmod-error-2.6.22-3-amd64: false
linux-image-2.6.22-3-amd64/prerm/removing-running-kernel-2.6.22-3-amd64: true
linux-image-2.6.22-3-amd64/postinst/bootloader-error-2.6.22-3-amd64:
linux-image-2.6.22-3-amd64/preinst/abort-overwrite-2.6.22-3-amd64:
linux-image-2.6.22-3-amd64/preinst/already-running-this-2.6.22-3-amd64:
linux-image-2.6.22-3-amd64/postinst/bootloader-test-error-2.6.22-3-amd64:
linux-image-2.6.22-3-amd64/postinst/old-initrd-link-2.6.22-3-amd64: true
linux-image-2.6.22-3-amd64/preinst/bootloader-initrd-2.6.22-3-amd64: true
linux-image-2.6.22-3-amd64/preinst/lilo-initrd-2.6.22-3-amd64: true
linux-image-2.6.22-3-amd64/preinst/lilo-has-ramdisk:
linux-image-2.6.22-3-amd64/preinst/abort-install-2.6.22-3-amd64:
linux-image-2.6.22-3-amd64/preinst/elilo-initrd-2.6.22-3-amd64: true
linux-image-2.6.22-3-amd64/postinst/old-dir-initrd-link-2.6.22-3-amd64: true
linux-image-2.6.22-3-amd64/preinst/initrd-2.6.22-3-amd64:
linux-image-2.6.22-3-amd64/postinst/kimage-is-a-directory:



--
To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org