[ please keep the bug report on cc,
that is not private conversation, cool thanks ]

On Mon, 08 Oct 2007, beojan@lavabit.com wrote:

>
> It's /scripts/init-premount
> Both the PS3 script and the thermal script have this error.
> However, this has not helped, and the initrd still doesn't boot.


i'm sorry but your initramfs-tools is not from debian,
we _never_ shipped with an modprobe -Q argument in those boot scripts.
check the following on any debian initramfs-tools release:
egrep -r modprobe /usr/share/initramfs-tools/scripts/init-premount/

also to diagnose your error i would need the actual error output
and btw yaird is not supported, for initramfs debugging see
-> http://wiki.debian.org/InitramfsDebug


> It tells me that it acpi_pm has been installed, then stalls.
> The initrd generated by yaird boots the ystem, but my usb devices,
> so I am counting on an improvement of this.
>
> You may wish to know that I switched to Debian from Feisty using
> dist-upgrade, and udev
> didn't get upgraded.


i see that is the explanation, so you'd need to reinstall a bunch
of stuff in that case.
apt-get --reinstall install initramfs-tools.

but i'm sorry cross distro changing is not supported,
you are pretty much on your own in that case.
i'd recommed using debian-installer to get a clean root on your
swap or such for a start, see daily build images
-> http://www.at.debian.org/devel/debian-installer/

best regards

--
maks



--
To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org