Package: linux-image-2.6.18-5-686
Version: 2.6.18.dfsg.1-13etch3

ifenslave version: ifenslave-2.6 1.1.0-6

After setting up bonding for two ethernet devices, the kernel complains
about an assertion failure (viewable with dmesg) in net/ipv4/devinet.c.
Bonding seems to work, but it's hardly comforting.

Configuration:

In /etc/network/interfaces:
auto bond0
iface bond0 inet static
address 10.0.0.2
netmask 255.255.255.0
gateway 10.0.0.1
broadcast 10.0.0.255
up ifenslave bond0 eth0 eth1
down ifenslave -d bond0 eth0 eth1

(IP information has been modified. Actual address is a 10.* address
with the same netmask, available in private email to a developer on
request).

/etc/modprobe.d/bonding:
alias bond0 bonding
options bond0 mode=balance-alb miimon=100

(this file also symlinked to /etc/modutils/bonding. have run
update-modules)


Computer is a Hewlett Packard DL380 G5, ethernet devices in lspci:
03:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet (rev 12)
05:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet (rev 12)

lspci -n:
03:00.0 0200: 14e4:164c (rev 12)
05:00.0 0200: 14e4:164c (rev 12)

relevant dmesg output:
ADDRCONF(NETDEV_UP): eth0: link is not ready
ADDRCONF(NETDEV_UP): eth1: link is not ready
ADDRCONF(NETDEV_UP): bond0: link is not ready
IPv6 over IPv4 tunneling driver
bnx2: eth0 NIC Link is Up, 100 Mbps full duplex, receive & transmit flow control ON
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
bonding: bond0: link status definitely up for interface eth0.
bonding: bond0: making interface eth0 the new active one.
RTNL: assertion failed at net/ipv4/devinet.c (985)
[] inetdev_event+0x3e/0x286
[] _spin_lock_bh+0xb/0x18
[] _spin_lock_bh+0x8/0x18
[] rt_run_flush+0x68/0x8f
[] notifier_call_chain+0x19/0x32
[] dev_set_mac_address+0x46/0x4b
[] alb_set_slave_mac_addr+0x5a/0x7f [bonding]
[] alb_swap_mac_addr+0x8a/0x138 [bonding]
[] bond_change_active_slave+0x187/0x27f [bonding]
[] bond_select_active_slave+0x8d/0xbb [bonding]
[] bond_mii_monitor+0x363/0x3a8 [bonding]
[] bond_mii_monitor+0x0/0x3a8 [bonding]
[] run_timer_softirq+0xfb/0x151
[] __do_softirq+0x5a/0xbb
[] do_softirq+0x36/0x3a
[] apic_timer_interrupt+0x1f/0x24
[] mwait_idle+0x25/0x38
[] cpu_idle+0x9f/0xb9
[] start_kernel+0x379/0x380
RTNL: assertion failed at net/ipv4/devinet.c (985)
[] inetdev_event+0x3e/0x286
[] _spin_lock_bh+0xb/0x18
[] _spin_lock_bh+0x8/0x18
[] rt_run_flush+0x68/0x8f
[] notifier_call_chain+0x19/0x32
[] dev_set_mac_address+0x46/0x4b
[] alb_set_slave_mac_addr+0x5a/0x7f [bonding]
[] alb_swap_mac_addr+0x99/0x138 [bonding]
[] bond_change_active_slave+0x187/0x27f [bonding]
[] bond_select_active_slave+0x8d/0xbb [bonding]
[] bond_mii_monitor+0x363/0x3a8 [bonding]
[] bond_mii_monitor+0x0/0x3a8 [bonding]
[] run_timer_softirq+0xfb/0x151
[] __do_softirq+0x5a/0xbb
[] do_softirq+0x36/0x3a
[] apic_timer_interrupt+0x1f/0x24
[] mwait_idle+0x25/0x38
[] cpu_idle+0x9f/0xb9
[] start_kernel+0x379/0x380
bonding: bond0: first active interface up!
ACPI: Power Button (FF) [PWRF]
ADDRCONF(NETDEV_CHANGE): bond0: link becomes ready
eth0: no IPv6 routers present
bond0: no IPv6 routers present


Thanks,
Řystein
--
Outgoing mail is certified Virus Free.



--
To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org