could not find vim component configuration menu - Debian

This is a discussion on could not find vim component configuration menu - Debian ; I could not find the "vim component configuration" menu in kcontrol as explained in http://docs.kde.org/development/en/k...omponents.html Is this document out of date? or kcontrol in Sid is inconsistent with the documentation? any ideas? thanks raju -- http://kamaraju.googlepages.com/cornell-bazaar http://groups.google.com/group/cornell-bazaar/about -- To UNSUBSCRIBE, ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: could not find vim component configuration menu

  1. could not find vim component configuration menu

    I could not find the "vim component configuration" menu in kcontrol as
    explained in

    http://docs.kde.org/development/en/k...omponents.html

    Is this document out of date? or kcontrol in Sid is inconsistent with the
    documentation?

    any ideas?

    thanks
    raju


    --
    http://kamaraju.googlepages.com/cornell-bazaar
    http://groups.google.com/group/cornell-bazaar/about


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: could not find vim component configuration menu

    On Thu, Jun 01, 2006 at 21:48:05 -0400, Kamaraju Kusumanchi wrote:
    > I could not find the "vim component configuration" menu in kcontrol as
    > explained in
    >
    > http://docs.kde.org/development/en/k...omponents.html
    >
    > Is this document out of date? or kcontrol in Sid is inconsistent with the
    > documentation?


    I have this menu in kcontrol 3.5.3-1; it is called "Vim Embedding" and
    does what is described in the above link.
    Maybe you are missing a package?

    $ dpkg -l \*vim\* | grep ^ii
    ii vim 7.0-017+4 Vi IMproved - enhanced vi editor
    ii vim-common 7.0-017+4 Vi IMproved - Common files
    ii vim-doc 7.0-017+4 Vi IMproved - HTML documentation
    ii vim-gtk 7.0-017+4 Vi IMproved - enhanced vi editor - with GTK2
    ii vim-gui-common 7.0-017+4 Vi IMproved - Common GUI files
    ii vim-runtime 7.0-017+4 Vi IMproved - Runtime files
    ii vimpart 3.4.3-1 embedded Vim text editor component for KDE

    --
    Regards,
    Florian


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Re: could not find vim component configuration menu

    On Friday 02 June 2006 01:50, Florian Kulzer wrote:
    > On Thu, Jun 01, 2006 at 21:48:05 -0400, Kamaraju Kusumanchi wrote:
    > > I could not find the "vim component configuration" menu in kcontrol as
    > > explained in
    > >
    > > http://docs.kde.org/development/en/k...ol-kde-compone
    > >nts.html
    > >
    > > Is this document out of date? or kcontrol in Sid is inconsistent with the
    > > documentation?

    >
    > I have this menu in kcontrol 3.5.3-1; it is called "Vim Embedding" and
    > does what is described in the above link.
    > Maybe you are missing a package?
    >
    > $ dpkg -l \*vim\* | grep ^ii
    > ii vim 7.0-017+4 Vi IMproved - enhanced vi editor
    > ii vim-common 7.0-017+4 Vi IMproved - Common files
    > ii vim-doc 7.0-017+4 Vi IMproved - HTML documentation
    > ii vim-gtk 7.0-017+4 Vi IMproved - enhanced vi editor - with
    > GTK2 ii vim-gui-common 7.0-017+4 Vi IMproved - Common GUI files
    > ii vim-runtime 7.0-017+4 Vi IMproved - Runtime files
    > ii vimpart 3.4.3-1 embedded Vim text editor component for
    > KDE
    >


    I am unable to install vimpart package. Other than that I have all the
    packages that you have installed. Could that be the problem?

    $wajig install vimpart
    Reading package lists... Done
    Building dependency tree... Done
    Package vimpart is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package vimpart has no installation candidate

    $apt-show-versions -a vimpart
    Not installed
    No unstable version
    vimpart not installed

    $dpkg -l \*vim\* | grep ^ii
    ii vim 7.0-017+4 Vi IMproved - enhanced vi editor
    ii vim-common 7.0-017+4 Vi IMproved - Common files
    ii vim-doc 7.0-017+4 Vi IMproved - HTML documentation
    ii vim-full 7.0-017+4 Vi IMproved - enhanced vi editor - full
    fled
    ii vim-gtk 7.0-017+4 Vi IMproved - enhanced vi editor - with
    GTK2
    ii vim-gui-common 7.0-017+4 Vi IMproved - Common GUI files
    ii vim-latexsuite 20060325-1 View, edit and compile LaTeX documents from
    ii vim-runtime 7.0-017+4 Vi IMproved - Runtime files
    ii vim-scripts 6-3 plugins for vim, adding bells and whistles
    ii vim-vimoutliner 0.3.3-6 script for building an outline editor on
    top


    --
    http://kamaraju.googlepages.com/cornell-bazaar
    http://groups.google.com/group/cornell-bazaar/about


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  4. Re: could not find vim component configuration menu

    On Fri, Jun 02, 2006 at 10:24:24 -0400, Kamaraju Kusumanchi wrote:
    > On Friday 02 June 2006 01:50, Florian Kulzer wrote:
    > > On Thu, Jun 01, 2006 at 21:48:05 -0400, Kamaraju Kusumanchi wrote:
    > > > I could not find the "vim component configuration" menu in kcontrol as
    > > > explained in
    > > >
    > > > http://docs.kde.org/development/en/k...ol-kde-compone
    > > >nts.html
    > > >
    > > > Is this document out of date? or kcontrol in Sid is inconsistent with the
    > > > documentation?

    > >
    > > I have this menu in kcontrol 3.5.3-1; it is called "Vim Embedding" and
    > > does what is described in the above link.
    > > Maybe you are missing a package?
    > >
    > > $ dpkg -l \*vim\* | grep ^ii
    > > ii vim 7.0-017+4 Vi IMproved - enhanced vi editor
    > > ii vim-common 7.0-017+4 Vi IMproved - Common files
    > > ii vim-doc 7.0-017+4 Vi IMproved - HTML documentation
    > > ii vim-gtk 7.0-017+4 Vi IMproved - enhanced vi editor - with
    > > GTK2 ii vim-gui-common 7.0-017+4 Vi IMproved - Common GUI files
    > > ii vim-runtime 7.0-017+4 Vi IMproved - Runtime files
    > > ii vimpart 3.4.3-1 embedded Vim text editor component for
    > > KDE
    > >

    >
    > I am unable to install vimpart package. Other than that I have all the
    > packages that you have installed. Could that be the problem?


    It seems that vimpart is only in stable, but not in testing or unstable:

    $ apt-cache policy vimpart
    vimpart:
    Installed: 4:3.4.3-1
    Candidate: 4:3.4.3-1
    Version table:
    *** 4:3.4.3-1 0
    100 /var/lib/dpkg/status
    4:3.3.2-4 0
    500 http://ftp.nl.debian.org stable/main Packages

    Truth be told, I don't recall how it ended up being installed on my
    system, but it looks like it used to be a dependency of kde-addons in
    KDE 3.3. The package description sounds like it is indeed responsible
    for making the embedding work:

    Description: embedded Vim text editor component for KDE
    This package allows the text editor Vim to be embedded into a number of
    different KDE applications. It does this by encapsulating Vim within a
    KPart (an embedded KDE component).

    --
    Regards,
    Florian


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  5. Re: could not find vim component configuration menu

    Kamaraju Kusumanchi wrote:
    > I could not find the "vim component configuration" menu in kcontrol as
    > explained in


    Vimpart is obsolete and was discontinued. If you want to have vi-class
    editor in KDE, use Yzis (the line to /etc/apt/sources.list is
    deb ftp://download.yzis.org/yzis ./ ), but it is still highly experimental
    and unstable).

    Matej


    --
    GPG Finger: 89EF 4BC6 288A BF43 1BAB 25C3 E09F EF25 D964 84AC
    http://www.ceplovi.cz/matej/blog/, Jabber: ceplma@jabber.cz
    23 Marion St. #3, (617) 876-1259, ICQ 132822213

    This is a test of the emergency signature system. Were this an
    actual signature, you would see amusing mottos, disclaimers,
    a zillion net addresses, or edifying philosophical statements.
    this is only test.


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  6. Re: could not find vim component configuration menu

    On Friday 02 June 2006 10:24 am, Kamaraju Kusumanchi wrote:

    > I am unable to install vimpart package. Other than that I have all the
    > packages that you have installed. Could that be the problem?


    It might be that he still has an old package installed, and you don't. The
    "vimpart" package disappeared a long time ago.

    --
    D. Michael 'Silvan' McIntyre ---- Silvan
    Linux fanatic, and certified Geek; registered Linux user #243621

    Author of Rosegarden Companion http://rosegarden.sourceforge.net/tutorial/


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread