kmail crash - Debian

This is a discussion on kmail crash - Debian ; Hi, I am having some trouble starting kmail. This has happened a few times recently but normally seems to fix itself (it's not this time though). Starting kmail from the command line gives the output shown below. This crash, I ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: kmail crash

  1. kmail crash

    Hi,

    I am having some trouble starting kmail. This has happened a few times
    recently but normally seems to fix itself (it's not this time though).

    Starting kmail from the command line gives the output shown below. This
    crash, I have noticed, is normally associated with kmail losing all my
    per folder settings which is very annoying.

    Anyone got any ideas what's wrong?

    Many thanks,

    Graham

    kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)]
    ignoring empty path
    kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)]
    ignoring empty path
    kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)]
    ignoring empty path
    kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)]
    ignoring empty path
    kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)]
    ignoring empty path
    kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)]
    ignoring empty path
    kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)]
    ignoring empty path
    WeaverThreadLogger: thread (ID: 1) suspended.
    WeaverThreadLogger: thread (ID: 2) suspended.
    WeaverThreadLogger: thread (ID: 3) suspended.
    WeaverThreadLogger: thread (ID: 4) suspended.
    kdecore (KAction): WARNING: KAction:lugAccel(): call to deprecated action.
    kdecore (KAction): WARNING: KAction:lugAccel( kacc = 0xa13340 ):
    KAccel object already contains an action name "delete"
    kdecore (KAction): WARNING: KAction:lugAccel(): call to deprecated action.
    kdecore (KAction): WARNING: KAction:lugAccel( kacc = 0xa13340 ):
    KAccel object already contains an action name "edit"
    kdecore (KAction): WARNING: KAction:lugAccel(): call to deprecated action.
    kdecore (KAction): WARNING: KAction:lugAccel( kacc = 0xa13340 ):
    KAccel object already contains an action name "display_message"
    doozer@doozer:/tmp$ *** KMail got signal 11 (Crashing)
    KCrash: Application 'kmail' crashing...


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: kmail crash

    Graham Smith wrote:

    > This
    > crash, I have noticed, is normally associated with kmail losing all my
    > per folder settings which is very annoying.
    >

    ime, _every_ KMail crash is associated with losing all per-folder settings.
    You're right, that's very annoying.

    Sorry, I can't help with the actual problem.
    --
    derek


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Re: kmail crash

    Ok, I couldn't find out specifically what was wrong but hunting around I heard
    quite a few people mentioning corrupt index files being a problem. I moved
    the contents of ~/.kde/share/apps/kmail/imap to another folder and tried
    kmail again (well kontact actually) and it worked.

    Of course this leads to two questions: what went wrong and how can I stop it
    going wrong again?

    I suppose there is a third as well: what can I do to help fix this exceedingly
    annoying bug? I'll file a bug report but it won't be much use as I have
    basically no information to go on.

    Graham

    On Thursday 16 February 2006 12:45, Graham Smith wrote:
    > Hi,
    >
    > I am having some trouble starting kmail. This has happened a few times
    > recently but normally seems to fix itself (it's not this time though).
    >
    > Starting kmail from the command line gives the output shown below. This
    > crash, I have noticed, is normally associated with kmail losing all my
    > per folder settings which is very annoying.
    >
    > Anyone got any ideas what's wrong?
    >
    > Many thanks,
    >
    > Graham
    >
    > kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)]
    > ignoring empty path
    > kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)]
    > ignoring empty path
    > kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)]
    > ignoring empty path
    > kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)]
    > ignoring empty path
    > kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)]
    > ignoring empty path
    > kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)]
    > ignoring empty path
    > kmail: WARNING: [void KMFolderImap::setImapPath(const QString&)]
    > ignoring empty path
    > WeaverThreadLogger: thread (ID: 1) suspended.
    > WeaverThreadLogger: thread (ID: 2) suspended.
    > WeaverThreadLogger: thread (ID: 3) suspended.
    > WeaverThreadLogger: thread (ID: 4) suspended.
    > kdecore (KAction): WARNING: KAction:lugAccel(): call to deprecated
    > action. kdecore (KAction): WARNING: KAction:lugAccel( kacc = 0xa13340 ):
    > KAccel object already contains an action name "delete"
    > kdecore (KAction): WARNING: KAction:lugAccel(): call to deprecated
    > action. kdecore (KAction): WARNING: KAction:lugAccel( kacc = 0xa13340 ):
    > KAccel object already contains an action name "edit"
    > kdecore (KAction): WARNING: KAction:lugAccel(): call to deprecated
    > action. kdecore (KAction): WARNING: KAction:lugAccel( kacc = 0xa13340 ):
    > KAccel object already contains an action name "display_message"
    > doozer@doozer:/tmp$ *** KMail got signal 11 (Crashing)
    > KCrash: Application 'kmail' crashing...



    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  4. Re: kmail crash

    Graham Smith skrev:

    >Ok, I couldn't find out specifically what was wrong but hunting around I heard
    >quite a few people mentioning corrupt index files being a problem. I moved
    >the contents of ~/.kde/share/apps/kmail/imap to another folder and tried
    >kmail again (well kontact actually) and it worked.
    >
    >Of course this leads to two questions: what went wrong and how can I stop it
    >going wrong again?
    >
    >I suppose there is a third as well: what can I do to help fix this exceedingly
    >annoying bug? I'll file a bug report but it won't be much use as I have
    >basically no information to go on.
    >
    >

    You are not alone. See this bug report:

    http://bugs.kde.org/show_bug.cgi?id=122124

    Anders


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread