Some trouble with kde-devel, libqt3-mt-dev and libgl1-mesa-dri - Debian

This is a discussion on Some trouble with kde-devel, libqt3-mt-dev and libgl1-mesa-dri - Debian ; Hi all I've a problem with libqt-mt-dev and libgl1-mesa-dri: I need libgl1-mesa-dri for the r300_dri.so library for 3d accel on an ibook with ati 9550 (it' doesn't work very well but this is another story...) and I need also libqt3-mt-dev ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Some trouble with kde-devel, libqt3-mt-dev and libgl1-mesa-dri

  1. Some trouble with kde-devel, libqt3-mt-dev and libgl1-mesa-dri

    Hi all
    I've a problem with libqt-mt-dev and libgl1-mesa-dri:
    I need libgl1-mesa-dri for the r300_dri.so library for 3d accel on an ibook
    with ati 9550 (it' doesn't work very well but this is another story...) and I
    need also libqt3-mt-dev and kdebase-dev that are needed as build-depends of
    kmobiletools that I maintain.

    When i try to install libqt3-mt-dev apt wants to remove the libgl1-mesa-dri:

    Tarja:/home/mind# apt-get install libqt3-mt-dev
    Lettura della lista dei pacchetti in corso... Fatto
    Generazione dell'albero delle dipendenze in corso... Fatto

    /* packages that will be installed */
    I seguenti pacchetti verranno inoltre installati:
    libglu1-xorg libglu1-xorg-dev xlibmesa-gl xlibmesa-gl-dev

    /* suggested packages */
    Pacchetti suggeriti:
    libqt3-i18n xlibmesa-dri

    /* packages that will be removed */
    I seguenti pacchetti saranno RIMOSSI:
    ---> libgl1-mesa-dri <--- libglu1-mesa

    I seguenti pacchetti NUOVI (NEW) saranno installati:
    libglu1-xorg libglu1-xorg-dev libqt3-mt-dev xlibmesa-gl xlibmesa-gl-dev
    0 aggiornati, 5 installati, 2 da rimuovere e 48 non aggiornati.

    i must use libgl1-mesa-dri because it is the only package that supply
    r300_dri.so

    what I can do in order to solve this problem?
    is this a potential bug of libgl1-mesa or libqt3-mt-dev? maybe of both?

    thanks in advance
    francesco

    p.s.: sorry for my awfull english
    --
    :wq


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: Some trouble with kde-devel, libqt3-mt-dev and libgl1-mesa-dri

    On Friday 03 February 2006 14:11, Francesco Pedrini wrote:
    > Hi all
    > I've a problem with libqt-mt-dev and libgl1-mesa-dri:
    > I need libgl1-mesa-dri for the r300_dri.so library for 3d accel on an
    > ibook with ati 9550 (it' doesn't work very well but this is another
    > story...) and I need also libqt3-mt-dev and kdebase-dev that are needed
    > as build-depends of kmobiletools that I maintain.
    >
    > When i try to install libqt3-mt-dev apt wants to remove the
    > libgl1-mesa-dri:
    >
    > what I can do in order to solve this problem?
    > is this a potential bug of libgl1-mesa or libqt3-mt-dev? maybe of both?


    I have the same hardware, and do have both libgl1-mesa and libqt3-mt-dev
    installed, so it is possible.

    I'd try apt-get installing libgl1-mesa-dev and libglu1-mesa-dev first,
    ensuring that libqt3-mt-dev's dependencies are satisfied, then trying again
    to install libqt3-mt-dev.

    Hope this helps.

    Cheers,
    Christopher Martin

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Signed by Christopher Martin

    iD8DBQBD47K8U+gWW+vtsysRAruYAJ49Xq7IOdg9uHPBrdKg07 63gKvcJACfVKIi
    HvGcbaFdspM5Nee0v9/U9IA=
    =WcYC
    -----END PGP SIGNATURE-----


  3. Re: Some trouble with kde-devel, libqt3-mt-dev and libgl1-mesa-dri

    On Friday 03 February 2006 20:44, Christopher Martin wrote:
    > On Friday 03 February 2006 14:11, Francesco Pedrini wrote:
    >
    > I have the same hardware, and do have both libgl1-mesa and libqt3-mt-dev
    > installed, so it is possible.
    >
    > I'd try apt-get installing libgl1-mesa-dev and libglu1-mesa-dev first,
    > ensuring that libqt3-mt-dev's dependencies are satisfied, then trying again
    > to install libqt3-mt-dev.


    libgl1-mesa-dev is broken here, and if i try to install libglu1-mesa-dev apt
    says that libgl1-mesa-dri will be removed:

    Tarja:/home/mind# apt-get install libglu1-mesa-dev
    Lettura della lista dei pacchetti in corso... Fatto
    Generazione dell'albero delle dipendenze in corso... Fatto

    /* packages that will be installed */

    I seguenti pacchetti verranno inoltre installati:
    libglu1-mesa xlibmesa-gl xlibmesa-gl-dev

    /* suggested packages /*

    Pacchetti suggeriti:
    xlibmesa-dri

    /* Packages that will be removed */

    I seguenti pacchetti saranno RIMOSSI:
    libgl1-mesa-dri libglu1-xorg

    libglu1-mesa is installed but libglu1-mesa-dev try to remove
    libgl1-mesa-dri , and this sounds *really* sad...

    With apt-cache show i can't find a conflict between this packages...

    > Hope this helps.


    unfortunately not (

    Thanks anyway

    > Cheers,
    > Christopher Martin


    bye
    Francesco

    --
    :wq


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread