k3b and k3blibs missing dependencies on Sid? - Debian

This is a discussion on k3b and k3blibs missing dependencies on Sid? - Debian ; Hello, I've been waiting to upgrade my Sid box to KDE3.5 as apt has been wanting to remove k3b and k3blibs but there seems to have been no progress on this. When I check for bugs all the bugs marked ...

+ Reply to Thread
Results 1 to 9 of 9

Thread: k3b and k3blibs missing dependencies on Sid?

  1. k3b and k3blibs missing dependencies on Sid?

    Hello,

    I've been waiting to upgrade my Sid box to KDE3.5 as apt has been wanting
    to remove k3b and k3blibs but there seems to have been no progress on
    this. When I check for bugs all the bugs marked grave have been marked
    as done.

    Running apt-get -o Debug:kgProblemResolver=yes dist-upgrade
    offers the following:

    Investigating libk3b2
    Package libk3b2 has broken dep on k3blibs
    Considering k3blibs 0 as a solution to libk3b2 0
    Holding Back libk3b2 rather than change k3blibs
    Investigating k3b
    Package k3b has broken dep on libk3b2
    Considering libk3b2 0 as a solution to k3b 0
    Removing k3b rather than change libk3b2

    Is anyone else experiencing the same problem? I'm trying to figure out
    if it is a problem with the state of my system or do I just need to keep
    waiting for k3b and k3blibs to catch up.

    Thanks,

    Ken


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: k3b and k3blibs missing dependencies on Sid?

    Try to upgrade and then reinstall k3b and k3blibs. It's a matter of the base
    dependencies.

    My Sid status:

    $ LANG=en_US apt-cache policy k3b k3blibs kdelibs4c2a
    k3b:
    Installed: 0.12.10-2
    Candidate: 0.12.10-2
    Version table:
    *** 0.12.10-2 0
    500 http://ftp.es.debian.org sid/main Packages
    100 /var/lib/dpkg/status
    k3blibs:
    Installed: (none)
    Candidate: (none)
    Version table:
    0.12.8-1+b1 0
    100 /var/lib/dpkg/status
    kdelibs4c2a:
    Installed: 4:3.5.0-3
    Candidate: 4:3.5.0-3
    Version table:
    *** 4:3.5.0-3 0
    500 http://ftp.es.debian.org sid/main Packages
    100 /var/lib/dpkg/status
    4:3.5.0-1 0
    500 http://pkg-kde.alioth.debian.org ./ Packages

    cu

    On 1/19/06, Ken Wahl wrote:
    >
    > Hello,
    >
    > I've been waiting to upgrade my Sid box to KDE3.5 as apt has been wanting
    > to remove k3b and k3blibs but there seems to have been no progress on
    > this. When I check for bugs all the bugs marked grave have been marked
    > as done.
    >
    > Running apt-get -o Debug:kgProblemResolver=yes dist-upgrade
    > offers the following:
    >
    > Investigating libk3b2
    > Package libk3b2 has broken dep on k3blibs
    > Considering k3blibs 0 as a solution to libk3b2 0
    > Holding Back libk3b2 rather than change k3blibs
    > Investigating k3b
    > Package k3b has broken dep on libk3b2
    > Considering libk3b2 0 as a solution to k3b 0
    > Removing k3b rather than change libk3b2
    >
    > Is anyone else experiencing the same problem? I'm trying to figure out
    > if it is a problem with the state of my system or do I just need to keep
    > waiting for k3b and k3blibs to catch up.
    >
    > Thanks,
    >
    > Ken
    >
    >
    > --
    > To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    > with a subject of "unsubscribe". Trouble? Contact
    > listmaster@lists.debian.org
    >
    >



  3. Re: k3b and k3blibs missing dependencies on Sid?

    On Thursday, 19 January 2006 18:48, Ken Wahl wrote:
    > Is anyone else experiencing the same problem? I'm trying to figure out
    > if it is a problem with the state of my system or do I just need to keep
    > waiting for k3b and k3blibs to catch up.

    A problem with the state of your system, k3blibs has been replaced by libk3b2.
    I guess just removing k3b and k3blibs and installing k3b will work.

    --
    Isaac Clerencia at Warp Networks, http://www.warp.es
    Work: | Debian:

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Signed by Isaac Clerencia

    iD8DBQBDz9LbQET2GFTmct4RAnF+AJ9ql4FgIA1KxmIAZa0X8n/RfMWO/QCfWOqO
    gLMI7j61g1uq6aXXo1l8v9Y=
    =G5Z4
    -----END PGP SIGNATURE-----


  4. Re: k3b and k3blibs missing dependencies on Sid?

    Hi!

    I'm experiencing the same problems. I removed k3b and k3blibs, installed kde
    and tried to reinstall k3b. I'm getting the message that

    dbus-1 (>= 0.23.4)
    dbus-qt-1c2 (>= 0.23.4)
    libhal0 (>= 0.4.0)

    are not installable. Dunno, I'm pretty new with Linux, so probably you can
    help me out...

    cya

    Jakob


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  5. Re: k3b and k3blibs missing dependencies on Sid?

    On Thursday 19 January 2006 19:31, Jakob Rohrhirsch wrote:
    > I'm experiencing the same problems. I removed k3b and k3blibs, installed kde
    > and tried to reinstall k3b. I'm getting the message that
    >
    > dbus-1 (>= 0.23.4)
    > dbus-qt-1c2 (>= 0.23.4)
    > libhal0 (>= 0.4.0)
    >
    > are not installable.


    I had that too with k3b 0.12.91+svn20051207.18-0rareware1.1
    I forced the installation of k3b from unstable, 0.12.10-2.
    This worked.


    --
    Wolfgang


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  6. Re: k3b and k3blibs missing dependencies on Sid?

    Kapke and Isaac,

    Thank you, your suggestions worked perfectly. I allowed k3b and k3blibs
    to be removed during the dist-upgrade and then reinstalled them
    afterwards and all is working.

    And thanks to the debian-kde development team. KDE 3.5 is noticeably
    faster than it's predecessor. Prettier too.

    All the best,

    Ken


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  7. Re: k3b and k3blibs missing dependencies on Sid?

    Am Thursday 19 January 2006 20:12 schrieb Wolfgang Rohdewald:
    > On Thursday 19 January 2006 19:31, Jakob Rohrhirsch wrote:
    > > I'm experiencing the same problems. I removed k3b and k3blibs, installed
    > > kde and tried to reinstall k3b. I'm getting the message that
    > >
    > > dbus-1 (>= 0.23.4)
    > > dbus-qt-1c2 (>= 0.23.4)
    > > libhal0 (>= 0.4.0)
    > >
    > > are not installable.

    >
    > I had that too with k3b 0.12.91+svn20051207.18-0rareware1.1
    > I forced the installation of k3b from unstable, 0.12.10-2.
    > This worked.
    >
    >
    > --
    > Wolfgang



    Thanks a lot, it worked, I'm finally able to burn CDs again...

    Dankeschön ;-)

  8. Re: k3b and k3blibs missing dependencies on Sid?

    On Thu, Jan 19, 2006 at 12:48:25PM -0500, Ken Wahl penned:
    > I've been waiting to upgrade my Sid box to KDE3.5 as apt has been wanting
    > to remove k3b and k3blibs but there seems to have been no progress on


    I've a similar problem on my machine runing testing. apt-get wants to
    remove k3b and k3blibs.

    > Running apt-get -o Debug:kgProblemResolver=yes dist-upgrade
    > offers the following:


    Running this on my machine results in:

    Package k3b is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package k3b has no installation candidate

    It's been like this for the last few weeks. Solutions? I don't want to
    move to KDE 3.5 until it moves into testing.

    bob
    --
    bob billson email: reb@nodot.org (primary) ham: kc2wz /)
    gpg key: 24B7FA67 reb@elbnet.com beekeeper -8|||}
    Athbhliain faoi shéan agus faoi shona duit! Linux geek \)

  9. Re: k3b and k3blibs missing dependencies on Sid?

    I will second that - I did the exact same thing (dist-upgrade, let it
    uninstall, and then reinstall it myself), and now i have kde3.5 + k3b
    and it's beautiful! Great work, debian - KDE developers!!


    On 1/19/06, Ken Wahl wrote:
    > Kapke and Isaac,
    >
    > Thank you, your suggestions worked perfectly. I allowed k3b and k3blibs
    > to be removed during the dist-upgrade and then reinstalled them
    > afterwards and all is working.
    >
    > And thanks to the debian-kde development team. KDE 3.5 is noticeably
    > faster than it's predecessor. Prettier too.
    >
    > All the best,
    >
    > Ken
    >
    >
    > --
    > To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    > with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian..org
    >
    >


+ Reply to Thread