The GTK Qt engine needs to be patched. - Debian

This is a discussion on The GTK Qt engine needs to be patched. - Debian ; -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Since this is a package more useful to KDE users than GNOME users, I thought this would be an appropriate place to mention this. The gtk2-engine-gtk-qt package is not patched to fixed the black ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: The GTK Qt engine needs to be patched.

  1. The GTK Qt engine needs to be patched.

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Since this is a package more useful to KDE users than GNOME users, I thought
    this would be an appropriate place to mention this.

    The gtk2-engine-gtk-qt package is not patched to fixed the black menus bug.
    Here is the patch for 0.6:

    - --------BEGIN PATCH--------
    diff -urN gtk-qt-engine-0.6.orig/src/qt_theme_draw.c
    gtk-qt-engine-0.6/src/qt_theme_draw.c
    - --- gtk-qt-engine-0.6.orig/src/qt_theme_draw.c 2004-12-21 21:28:34 +0600
    +++ gtk-qt-engine-0.6/src/qt_theme_draw.c 2005-09-30 08:20:50 +0700
    @@ -1777,6 +1777,7 @@
    {
    pixmap = pix_test;
    parent_relative = FALSE;
    + gdk_drawable_set_colormap(pixmap, style->colormap);
    }

    gdk_window_set_back_pixmap (window, pixmap, parent_relative);
    - ---------END PATCH---------
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)

    iD8DBQFDmySwXm341+YDm10RAiC5AKCfgTxCejZytLT0IIyMbB GQeC9E8ACfQU5W
    Y14YQHrI0iebvmrpJRs87pU=
    =9glq
    -----END PGP SIGNATURE-----


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: The GTK Qt engine needs to be patched.

    * Matt Sicker [Sat, 10 Dec 2005 12:55:44 -0600]:

    Matt, let's CC the maintainer of the package so that he can be aware.

    > Since this is a package more useful to KDE users than GNOME users, I thought
    > this would be an appropriate place to mention this.


    > The gtk2-engine-gtk-qt package is not patched to fixed the black menus bug.
    > Here is the patch for 0.6:


    > --------BEGIN PATCH--------
    > diff -urN gtk-qt-engine-0.6.orig/src/qt_theme_draw.c
    > gtk-qt-engine-0.6/src/qt_theme_draw.c
    > --- gtk-qt-engine-0.6.orig/src/qt_theme_draw.c 2004-12-21 21:28:34 +0600
    > +++ gtk-qt-engine-0.6/src/qt_theme_draw.c 2005-09-30 08:20:50 +0700
    > @@ -1777,6 +1777,7 @@
    > {
    > pixmap = pix_test;
    > parent_relative = FALSE;
    > + gdk_drawable_set_colormap(pixmap, style->colormap);



    > gdk_window_set_back_pixmap (window, pixmap, parent_relative);
    > ---------END PATCH---------


    Thanks,

    --
    Adeodato Simó dato at net.com.org.es
    Debian Developer adeodato at debian.org

    There is no man so good who, were he to submit all his thoughts to the
    laws, would not deserve hanging ten times in his life.
    -- Michel de Montaigne


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Re: The GTK Qt engine needs to be patched.

    On Saturday 10 December 2005 19:55, Matt Sicker wrote:
    > Since this is a package more useful to KDE users than GNOME users, I
    > thought this would be an appropriate place to mention this.
    >
    > The gtk2-engine-gtk-qt package is not patched to fixed the black menus bug.
    > Here is the patch for 0.6:


    I've rebuild gtk2-engines-gtk-qt with this fix, works like a charm. Package is
    available from http://debian.kcore.org/, use at own risk. It didn't eat my
    laptop tho

    Jan

    --
    sillema sillema nika su


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  4. Re: The GTK Qt engine needs to be patched.

    On Monday 19 December 2005 08:02, Jan De Luyck wrote:
    > On Saturday 10 December 2005 19:55, Matt Sicker wrote:
    > > Since this is a package more useful to KDE users than GNOME users, I
    > > thought this would be an appropriate place to mention this.
    > >
    > > The gtk2-engine-gtk-qt package is not patched to fixed the black menus
    > > bug. Here is the patch for 0.6:

    >
    > I've rebuild gtk2-engines-gtk-qt with this fix, works like a charm. Package
    > is available from http://debian.kcore.org/, use at own risk. It didn't eat
    > my laptop tho


    This package is built against kdelibs4c2a (>= 4:3.5.0-1), and I don't want to
    install kde from experimental. Does anybody know if there's a package
    available for unstable or testing?

    Thanks for any hint,
    Johannes


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  5. Re: The GTK Qt engine needs to be patched.

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Johannes Wolter wrote:

    > On Monday 19 December 2005 08:02, Jan De Luyck wrote:
    >> On Saturday 10 December 2005 19:55, Matt Sicker wrote:
    >> > Since this is a package more useful to KDE users than GNOME users, I
    >> > thought this would be an appropriate place to mention this.
    >> >
    >> > The gtk2-engine-gtk-qt package is not patched to fixed the black menus
    >> > bug. Here is the patch for 0.6:

    >>
    >> I've rebuild gtk2-engines-gtk-qt with this fix, works like a charm.
    >> Package is available from http://debian.kcore.org/, use at own risk. It
    >> didn't eat my laptop tho

    >
    > This package is built against kdelibs4c2a (>= 4:3.5.0-1), and I don't want
    > to install kde from experimental. Does anybody know if there's a package
    > available for unstable or testing?


    You can build it yourself quite easily. I used apt-src, like this:

    $ mkdir gtk-qt-src
    $ cd gtk-qt-src
    $ apt-src install gtk2-engines-gtk-qt
    $ patch -p0 patch the source file manually)
    $ sudo apt-src -i build gtk2-engines-gtk-qt

    Then I logged out and back in, and it seems to have fixed it.

    Adam
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)

    iD8DBQFDuyIB5+GdyTDsrJsRAnZ4AJsFfNry0yjXFL/xFToTFiF3CzBiCQCghOBn
    Z1Ge6p2Zv605v60Y4u7q7yI=
    =VAYA
    -----END PGP SIGNATURE-----


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread