Updating my system - Debian

This is a discussion on Updating my system - Debian ; Hi there, I recently tried to update my system and this is what I get: ------------------------------------------------------------------------------------- doctorvell:/home/docvell# apt-get build-dep k3b E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem. doctorvell:/home/docvell# dpkg --configure -a doctorvell:/home/docvell# ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Updating my system

  1. Updating my system

    Hi there,

    I recently tried to update my system and this is what I get:
    -------------------------------------------------------------------------------------

    doctorvell:/home/docvell# apt-get build-dep k3b
    E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to
    correct the problem.
    doctorvell:/home/docvell# dpkg --configure -a
    doctorvell:/home/docvell# apt-get build-dep k3b
    Reading package lists... Done
    Building dependency tree... Done
    The following packages will be REMOVED:
    bibletime celestia kdelibs4c2 libarts1c2 libboost-python1.33.0 libfam0c102
    libmimelib1c2 libmusicbrainz4c2 libopenexr2c2 libtag1c2 libtunepimp2c2
    The following NEW packages will be installed:
    comerr-dev dbus-1-dev dbus-qt-1-dev flac kdelibs4-dev kdelibs4c2a
    libart-2.0-dev libarts1-dev libarts1c2a libartsc0-dev libasound2-dev
    libaspell-dev libaudio-dev libaudiofile-dev libboost-python1.33.0c2a
    libbz2-dev libcupsys2-dev libdb4.3++c2 libesd0-dev libexpat1-dev
    libfam-dev
    libfam0 libflac++-dev libflac-dev libfontconfig1-dev libfreetype6-dev
    libgcrypt11-dev libglib1.2-dev libglib2.0-dev libglu1-xorg-dev
    libgnutls-dev
    libgpg-error-dev libhal-dev libhal-storage-dev libice-dev libidn11-dev
    libjack0.100.0-dev libjasper-1.701-dev libjpeg62-dev libkadm55 libkrb5-dev
    liblcms1-dev libmad0-dev libmimelib1c2a libmng-dev libmpcdec-dev
    libmusicbrainz4-dev libmusicbrainz4c2a libogg-dev libopencdk8-dev
    libopenexr-dev libopenexr2c2a libpcre3-dev libpcrecpp0 libpng12-dev
    libpopt-dev libqt3-compat-headers libqt3-headers libqt3-mt-dev
    libresmgr-dev
    libsasl2-dev libsm-dev libsnmp9 libssl-dev libtag1-dev libtag1c2a
    libtasn1-2-dev libtiff4-dev libtiffxx0c2 libtunepimp2c2a libvorbis-dev
    libx11-dev libxcursor-dev libxext-dev libxft-dev libxi-dev libxinerama-dev
    libxkbfile-dev libxml2-dev libxmu-dev libxrandr-dev libxrender-dev
    libxslt1-dev libxt-dev libxv-dev qt3-dev-tools render-dev x-dev
    xlibmesa-gl-dev xlibs-static-dev zlib1g-dev
    The following packages will be upgraded:
    akode akregator amor ark arts artsbuilder aspell atlantik atlantikdesigner
    cervisia cpp-4.0 dbus-1 dbus-qt-1c2 dcoprss eyesapplet fifteenapplet
    g++-4.0
    gcc-4.0 gcc-4.0-base gij-4.0 juk k3b k3blibs kaboodle kaddressbook
    kaddressbook-plugins kalarm kalzium kamera kandy kappfinder karm
    kasteroids
    kate kate-plugins katomic kaudiocreator kbackgammon kbattleship kblackbox
    kbounce kbruch kcalc kcharselect kcoloredit kcontrol kcron kdat
    kdeaddons-kfile-plugins kdeadmin-kfile-plugins kdeartwork-style
    kdeartwork-theme-window kdebase-bin kdebase-data kdebase-kio-plugins
    kdegraphics-kfile-plugins kdelibs kdelibs-bin kdelibs-data kdelirc
    kdemultimedia-kfile-plugins kdemultimedia-kio-plugins
    kdenetwork-filesharing
    kdenetwork-kfile-plugins kdepasswd kdepim kdepim-kfile-plugins
    kdepim-kio-plugins kdepim-kresources kdepim-wizards kdeprint kdesktop
    kdessh
    kdf kdict kdm kdoomsday kdvi kedit keduca kenolaba kfax kfilereplace kfind
    kfloppy kfouleggs kgamma kget kghostview kgoldrunner kgpg khangman
    khelpcenter khexedit kicker kicker-applets kiconedit kig kimagemapeditor
    kitchensync kiten kjots kjumpingcube klaptopdaemon klatin kleopatra
    klettres
    klettres-data klickety klines klinkstatus klipper kmahjongg kmail kmailcvt
    kmenuedit kmessedwords kmid kmilo kmines kmix kmoon kmplot kmrml
    knewsticker
    knode knotes kodo kolf kolourpaint kommander kompare konq-plugins
    konqueror
    konqueror-nsplugins konquest konsole konsolekalendar kontact kooka kopete
    korganizer korn kpackage kpager kpat kpdf kpercentage kpersonalizer kpf
    kpilot kpoker kpovmodeler kppp krdc krec kregexpeditor kreversi krfb
    kruler
    ksame kscd kscreensaver kscreensaver-xsavers kshisen ksig ksim ksirc
    ksirtet
    ksmiletris ksmserver ksnake ksnapshot ksokoban kspaceduel ksplash kstars
    kstars-data ksvg ksync ksysguard ksysguardd ksysv ktalkd kteatime ktimer
    ktip ktnef ktouch ktron ktuberling kturtle ktux kuickshow kuser kverbos
    kview kviewshell kvoctrain kwalletmanager kweather kwifimanager kwin kwin4
    kwordquiz kworldclock kxsldbg lib64stdc++6 libarts1-audiofile
    libarts1-mpeglib libarts1-xine libartsc0 libasound2 libaspell15
    libaspell15c2 libbz2-1.0 libcvsservice0 libflac++5 libflac7 libfontconfig1
    libfribidi0 libgadu3 libgcc1 libgcj6 libglib2.0-0 libglib2.0-data
    libglu1-xorg libgnutls12 libgphoto2-2 libgphoto2-port0 libhal-storage0
    libhal0 libice6 libkcal2b libkcddb1 libkdeedu1 libkdegames1 libkdepim1a
    libkgantt0 libkiten1 libkleopatra0a libkmime2 libkonq4 libkpimexchange1
    libkpimidentities1 libkrb53 libkscan1 libksieve0 libktnef1 libpcre3
    libqt3-mt librss1 libsasl2 libsasl2-modules libsensors3 libsm6
    libsnmp-base
    libssl0.9.8 libstdc++6 libstdc++6-4.0-dev libtasn1-2 libtiff4
    libtunepimp-bin libx11-6 libxext6 libxi6 libxinerama1 libxkbfile1 libxml2
    libxmu6 libxrandr2 libxslt1.1 libxt6 libxv1 lilo-config lisa lskat mpeglib
    networkstatus noatun noatun-plugins okle quanta quanta-data secpolicy
    sound-juicer vimpart xlibmesa-gl zlib1g
    289 upgraded, 91 newly installed, 11 to remove and 653 not upgraded.
    1 not fully installed or removed.
    E: I wasn't able to locate file for the nano package. This might mean
    you need to manually fix this package.
    E: Failed to process build dependencies
    ------------------------------------------------
    I have no idea what to do now? I just want to upgrade my system..

    Currently I have Debian 3.1 UNSTABLE version (I prefer it that way
    actually).

    Thanks..


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: Updating my system

    El miércoles, 7 de diciembre de 2005 05:57, Richard Wegner escribió:
    > Hi there,
    >
    > I recently tried to update my system and this is what I get:

    [...]
    > ------------------------------------------------
    > I have no idea what to do now? I just want to upgrade my system..
    >
    > Currently I have Debian 3.1 UNSTABLE version (I prefer it that way
    > actually).


    Then this is not a good time to upgrade your system to current sid if you do
    not know what is going on with such a message.

    Due to another C++ global change, a lot of C++ libraries are again affected.
    Do you remember the last C++ ABI havoc? More or less this is the same, but
    probably it will be much shorter. Simply relax and wait another week to
    upgrade. You do not *really* need the latest sid. Believe me. :-)


    Ender.
    --
    I once farted on the set of Blue Lagoon.
    -- Brooke Shields (South Park).
    --
    Desarrollador de Debian
    Debian developer

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)

    iD8DBQBDlrxeWs/EhA1iABsRAsBLAJ0U+YcnMY5CKNqdNM8z5yXhO7/QkACeMZ6g
    KGBQ4DVciqaELOvNewBt8l8=
    =sUC7
    -----END PGP SIGNATURE-----


+ Reply to Thread