3.4 in testing: dependency issues - Debian

This is a discussion on 3.4 in testing: dependency issues - Debian ; Hi, As I'm sure many of you know, KDE 3.4 has arrived in testing. Congratulations and thanks to the Debian team! My report: With my package-set, the new kdeedu and kig packages had unsatisfied dependencies which meant a full upgrade ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: 3.4 in testing: dependency issues

  1. 3.4 in testing: dependency issues

    Hi,

    As I'm sure many of you know, KDE 3.4 has arrived in testing. Congratulations
    and thanks to the Debian team!

    My report:

    With my package-set, the new kdeedu and kig packages had unsatisfied
    dependencies which meant a full upgrade could not proceed in testing.

    With those two packages un-selected for upgrade, the upgrade is able to
    proceed, however, apt-get warns that:

    The following packages will be REMOVED:
    ardour-gtk atlantikdesigner basket hotplug k3b k3blibs kaddressbook-plugins
    kaffeine kate-plugins kbear kcmlinuz kde kde-amusements kdeaddons
    kdeaddons-kfile-plugins kdeedu kdelibs4 kdewebdev kfilereplace
    kicker-applets kig kimagemapeditor klinkstatus kmplayer kommander
    konq-plugins ksig kwin-baghira kxdocker kxdocker-data kxsldbg libarts1
    libbio2jack0 libjack0.80.0-0 libjack0.80.0-dev libkcal2a libkdenetwork2
    libkdepim1 libmimelib1a libmodplug0 libmusicbrainz4 libopenexr2 libqt-perl
    libqt3c102-mt libtag1 libtunepimp2 libwv2-1 mplayer-386 noatun-plugins qgo
    quanta rosegarden4 vimpart xmms-xmmplayer

    Of particular concern for me are ardour, rosegarden4, and basket, which I use
    extensively for work; and to a lesser extent k3b, kaffeine, kxdocker and
    kwin-baghira, which I like!

    I'm very keen to try KDE 3.4 in testing, but not without these programs. Is it
    just a matter of waiting until the dependencies are sorted out out fully, or
    is there a workaround?

    IIRC, the rosegarden4 issue may relate to a dependency on libjack0.80.0-0
    which is being replaced by libjack0.100.0-0. Is this correct?

    Any info about the status or upgradeabilty of any the above programs would be
    appreciated.

    Thanks,

    John


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: 3.4 in testing: dependency issues

    On Tuesday 01 November 2005 10:14 pm, John O'Hagan wrote:

    > IIRC, the rosegarden4 issue may relate to a dependency on libjack0.80.0-0
    > which is being replaced by libjack0.100.0-0. Is this correct?
    >
    > Any info about the status or upgradeabilty of any the above programs would
    > be appreciated.


    Probably just wait. I went through this on Sid already, and it finally got
    sorted out after a protracted mess.

    I've got everything installed from packages now, I think, except ZynAddSubFX.
    I expect this will all trickle into testing in due course, and hopefully
    faster than it took for these issues to settle out of Sid.

    --
    Michael McIntyre ---- Silvan

    http://rosegarden.sourceforge.net/tutorial/


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Re: 3.4 in testing: dependency issues

    John O'Hagan wrote:
    > As I'm sure many of you know, KDE 3.4 has arrived in testing.
    > Congratulations and thanks to the Debian team!


    And you know whom to thank for it -- out of sheer desperation from lacking
    3.4.2 (and openoffice-kde) I have switched yesterday to sid, which is
    always best way how to make testing updated :-)).

    Matěj

    --
    Matej Cepl, http://www.ceplovi.cz/matej/blog/
    GPG Finger: 89EF 4BC6 288A BF43 1BAB 25C3 E09F EF25 D964 84AC

    I know of no country in which there is so little independence of
    mind and real freedom of discussion as in America.
    -- Alexis de Tocqueville



    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread