skype and KDE 3.4.2 on debian unstable - Debian

This is a discussion on skype and KDE 3.4.2 on debian unstable - Debian ; Hi, The skype .deb from the official site cannot be installed on a up-to-date sid machine because it depends on libqt3c102-mt. But the one from http://frankandjacq.com/ubuntuguide/....11-1_i386.deb installs flawlessly and seems to depend on libqt-mt.so.3. I thought skype was closed-source so ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: skype and KDE 3.4.2 on debian unstable

  1. skype and KDE 3.4.2 on debian unstable

    Hi,

    The skype .deb from the official site cannot be installed on a
    up-to-date sid machine because it depends on libqt3c102-mt.

    But the one from
    http://frankandjacq.com/ubuntuguide/....11-1_i386.deb installs
    flawlessly and seems to depend on libqt-mt.so.3. I thought skype was
    closed-source so how did they manage to rebuild it with the correct gcc
    4.x ABI ?

    Best regards,

    Serge


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: skype and KDE 3.4.2 on debian unstable

    Am Freitag, 23. September 2005 22:40 schrieb Serge Koganovitsch:
    > The skype .deb from the official site cannot be installed on a
    > up-to-date sid machine because it depends on libqt3c102-mt.
    >
    > But the one from
    > http://frankandjacq.com/ubuntuguide/....11-1_i386.deb installs
    > flawlessly and seems to depend on libqt-mt.so.3. I thought skype was
    > closed-source so how did they manage to rebuild it with the correct gcc
    > 4.x ABI ?


    They didn't, they probably just repackaged the binary files.
    Me just wonders how they deal with the gcc-abi change? The binary seemed to
    run with _both_ gcc packages (although the contacts were not visible with the
    c2 version of libqt).
    Currently, I use the statically linked version.

    But who cares: skype sucks. They stick with a really bad audio device access
    implementation (OSS-only) that breaks very often.

    HS


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Re: skype and KDE 3.4.2 on debian unstable

    Serge Koganovitsch wrote:
    > Hi,
    >
    > The skype .deb from the official site cannot be installed on a
    > up-to-date sid machine because it depends on libqt3c102-mt.


    Just FYI, I saw the same and then forced the installation with
    --force-all, which worked.

    Only, when I run skype through artsdsp, it crashes as soon as someone
    writes me a message :-(


    > But the one from
    > http://frankandjacq.com/ubuntuguide/....11-1_i386.deb installs
    > flawlessly and seems to depend on libqt-mt.so.3. I thought skype was
    > closed-source so how did they manage to rebuild it with the correct gcc
    > 4.x ABI ?
    >
    > Best regards,
    >
    > Serge
    >
    >



    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread