Problem getting KDE 3.4 (sid)/apt troubles - Debian

This is a discussion on Problem getting KDE 3.4 (sid)/apt troubles - Debian ; Hi, I am running Debian unstable. I noticed that KDE 3.4 had become available quite a while ago and had not been installed to my machine when I did dist-upgrade. If I try to push aptitude to install 3.4 I ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Problem getting KDE 3.4 (sid)/apt troubles

  1. Problem getting KDE 3.4 (sid)/apt troubles

    Hi,

    I am running Debian unstable. I noticed that KDE 3.4 had become
    available quite a while ago and had not been installed to my machine
    when I did dist-upgrade.

    If I try to push aptitude to install 3.4 I get dependancies/broken
    packages errors.

    How should I fix those?

    Here is what I get:

    andrei@cibo:~$ sudo aptitude install kdebase
    Reading Package Lists... Done
    Building Dependency Tree
    Reading extended state information
    Initializing package states... Done
    Reading task descriptions... Done
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B of archives. After unpacking 0B will be used.
    Writing extended state information... Done
    Reading Package Lists... Done
    Building Dependency Tree
    Reading extended state information
    Initializing package states... Done
    Reading task descriptions... Done

    andrei@cibo:~$ sudo aptitude install kdebase/unstable
    Reading Package Lists... Done
    Building Dependency Tree
    Reading extended state information
    Initializing package states... Done
    Reading task descriptions... Done
    E: Unable to correct problems, you have held broken packages.
    E: Unable to correct dependencies, some packages cannot be installed
    E: Unable to resolve some dependencies!
    Some packages had unmet dependencies. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.

    The following packages have unmet dependencies:
    kdebase: Depends: kappfinder (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: kate (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: kcontrol (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: kdebase-bin (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: kdebase-data (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: kdebase-kio-plugins (>= 4:3.4.2-2) but 4:3.3.2-1 is
    installed.
    Depends: kdepasswd (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: kdeprint (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: kdesktop (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: kfind (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: khelpcenter (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: kicker (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: klipper (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: kmenuedit (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: konqueror-nsplugins (>= 4:3.4.2-2) but 4:3.3.2-1 is
    installed.
    Depends: konqueror (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: konsole (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: kpager (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: kpersonalizer (>= 4:3.4.2-2) but 4:3.3.2-1 is
    installed.
    Depends: ksmserver (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: ksplash (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: ksysguard (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: ktip (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: kwin (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.
    Depends: libkonq4 (>= 4:3.4.2-2) but 4:3.3.2-1 is installed.


    Thanks in advance,

    Andrey


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: Problem getting KDE 3.4 (sid)/apt troubles

    On Tuesday 06 September 2005 02:59 pm, Andrey Andreev wrote:
    > Hi,
    >
    > I am running Debian unstable. I noticed that KDE 3.4 had become
    > available quite a while ago and had not been installed to my machine
    > when I did dist-upgrade.
    >
    > If I try to push aptitude to install 3.4 I get dependancies/broken
    > packages errors.
    >
    > How should I fix those?


    It looks to me like you must be using apt preferences to pin testing at 990
    (or some other number > 900). If this is the case, I would unpin testing,
    install the kde packages you want, then reset your preferences to what they
    are now.

    Josh


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Re: Problem getting KDE 3.4 (sid)/apt troubles

    Josh Metzler wrote:
    > It looks to me like you must be using apt preferences to pin testing at 990
    > (or some other number > 900). If this is the case, I would unpin testing,
    > install the kde packages you want, then reset your preferences to what they
    > are now.


    Well, actually, no. But probably I need to set my preferences right anyway.

    Anyway, I decided to do:

    aptitude -t unstable dist-upgrade

    which does seem to have some unpleasant effects, but if it will lead to
    a more consistent system, I am quite happy, and will fix the rest later
    myself. (when it ends running in a few hours i will let you know)

    At the moment my preferences and sources.list go as folows:

    andrei@cibo:~$ cat /etc/apt/preferences
    Package: *
    Pin: release o=Debian,a=unstable
    Pin-Priority: 300

    Package: *
    Pin: origin experimental
    Pin-Priority: 200

    Package: *
    Pin: origin debian.linux-systeme.com
    Pin-Priority: 120

    Package: *
    Pin: origin maemo
    Pin-Priority: -2



    andrei@cibo:~$ cat /etc/apt/sources.list
    #deb file:///cdrom/ sarge main

    deb http://ftp.fi.debian.org/debian/ unstable main contrib non-free
    deb-src http://ftp.fi.debian.org/debian/ unstable main contrib non-free

    #------------------------------mplayer-----------------------------
    deb ftp://ftp.nerim.net/debian-marillat/ unstable main

    # bootsplash & skype
    deb http://www.bootsplash.de/files/debian/ unstable main

    #skype kdeart
    deb http://debian.neo.pl/wfmh unstable main contrib non-free


    #java
    deb http://debian.ethz.ch/debian/ testing main contrib non-free
    deb-src http://debian.ethz.ch/debian/ testing main contrib non-free

    #azureus
    deb http://www.plaisthos.de/deb/ ./
    deb-src http://www.plaisthos.de/deb/ ./

    #yzis
    deb ftp://download.yzis.org/yzis ./

    #coda
    deb http://www.coda.cs.cmu.edu/debian unstable/

    #For Xorg
    deb http://debian.linux-systeme.com sid main
    deb-src http://debian.linux-systeme.com sid main


    Best regards,

    Andro


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread