konq-plugins vs. kdelibs-data - Debian

This is a discussion on konq-plugins vs. kdelibs-data - Debian ; I am living dangerously and running Sid with the Alioth KDE 3.4.1 packages. For the most part it's been reasonably stable, but I have run into an apt-snag. kdeaddons will not upgrade or install, because it depends on konq-plugins >= ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: konq-plugins vs. kdelibs-data

  1. konq-plugins vs. kdelibs-data

    I am living dangerously and running Sid with the Alioth KDE 3.4.1 packages.
    For the most part it's been reasonably stable, but I have run into an
    apt-snag.

    kdeaddons will not upgrade or install, because it depends on konq-plugins >=
    3.3.2. konq-plugins 3.3.2 is available (via sarge), but it won't install
    because it is:

    "trying to overwrite `/usr/share/mimelnk/application/x-webarchive.desktop',
    which is also in package kdelibs-data"

    I've tried apt-get -f and aptitude -f on konq-plugins, and moving/removing
    that file. It still refuses to install konq-plugins, which in turn holds
    various other things back (and of course means I don't have konq-plugins
    installed). Uninstalling and reinstalling kdelibs-data, of course, would
    take with it nearly all of KDE, so I haven't done that. :-)

    Any advice on how to unjam apt without totally blowing away KDE and starting
    from scratch?

    --
    Larry Garfield AIM: LOLG42
    larry@garfieldtech.com ICQ: 6817012

    "If nature has made any one thing less susceptible than all others of
    exclusive property, it is the action of the thinking power called an idea,
    which an individual may exclusively possess as long as he keeps it to
    himself; but the moment it is divulged, it forces itself into the possession
    of every one, and the receiver cannot dispossess himself of it." -- Thomas
    Jefferson


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: konq-plugins vs. kdelibs-data

    On Monday 15 August 2005 11:47, Larry Garfield wrote:
    > I am living dangerously and running Sid with the Alioth KDE 3.4.1 packages.
    > For the most part it's been reasonably stable, but I have run into an
    > apt-snag.
    >
    > kdeaddons will not upgrade or install, because it depends on konq-plugins
    > >= 3.3.2. konq-plugins 3.3.2 is available (via sarge), but it won't

    > install because it is:
    >
    > "trying to overwrite `/usr/share/mimelnk/application/x-webarchive.desktop',
    > which is also in package kdelibs-data"
    >
    > I've tried apt-get -f and aptitude -f on konq-plugins, and moving/removing
    > that file. It still refuses to install konq-plugins, which in turn holds
    > various other things back (and of course means I don't have konq-plugins
    > installed). Uninstalling and reinstalling kdelibs-data, of course, would
    > take with it nearly all of KDE, so I haven't done that. :-)
    >
    > Any advice on how to unjam apt without totally blowing away KDE and
    > starting from scratch?
    >
    > --
    > Larry Garfield AIM: LOLG42
    > larry@garfieldtech.com ICQ: 6817012
    >
    > "If nature has made any one thing less susceptible than all others of
    > exclusive property, it is the action of the thinking power called an idea,
    > which an individual may exclusively possess as long as he keeps it to
    > himself; but the moment it is divulged, it forces itself into the
    > possession of every one, and the receiver cannot dispossess himself of it."
    > -- Thomas Jefferson

    hey!
    i think "dpkg -i --force-overwrite /var/cache/apt/archive/konq...." should do
    you the job!

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.1 (GNU/Linux)

    iD8DBQBDAIo3gRmtYySq9WARAgWqAKDMRF8ttpS+Byyy26nyrG D5goPydwCbBDY1
    KNfm+J9iDpwXHqOKH12nlKk=
    =1kRP
    -----END PGP SIGNATURE-----


+ Reply to Thread