kde 3.4.1 packages - Debian

This is a discussion on kde 3.4.1 packages - Debian ; the QT-KDE team just uploaded to experimental packages for the 3.4.1 kde following modules : * arts * kdelibs * kdeadmin * kdegraphics * kdetoys * kdebase * kdeutils * kdeartwork * kdemultimedia * kdeaccessibility the other kde modules are ...

+ Reply to Thread
Results 1 to 13 of 13

Thread: kde 3.4.1 packages

  1. kde 3.4.1 packages

    the QT-KDE team just uploaded to experimental packages for the 3.4.1 kde
    following modules :

    * arts
    * kdelibs
    * kdeadmin
    * kdegraphics
    * kdetoys
    * kdebase
    * kdeutils
    * kdeartwork
    * kdemultimedia
    * kdeaccessibility

    the other kde modules are either maintained outside from the team, or
    depends upon packages that are maintained outside from the team (here
    is a nice picture showing the build deps and the maintainers of the
    official kde modules [1]).

    A mirror has been set up on alioth :

    deb http://pkg-kde.alioth.debian.org/kde-3.4.1/ ./
    deb-src http://pkg-kde.alioth.debian.org/kde-3.4.1/ ./


    In order to install the package, you will need the dbus-1-qt package
    from current experimental. this package has not been mirrored on alioth
    yet.

    kde 3.4.1 has to wait for dbus to migrate into unstable, and for obvious
    reasons, this move will wait for sarge to be released (which *should*
    happen next week).


    [1] http://people.debian.org/~madcoder/kde.png


    Nota:
    * There is currently no ETA for the missing kde modules, and *PLEASE*
    don't ask for one.
    * Moreover, this upload to experimental should trigger a lot of NEW
    processing, and the package may not show up immediately.

    Cheers,
    --
    ·O· Pierre Habouzit
    ··O madcoder@debian.org
    OOO http://www.madism.org

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.1 (GNU/Linux)

    iD8DBQBCndHAvGr7W6HudhwRAheoAJ93X33k+W6WJfCLkXAtP0 okuzdmNwCeMm8+
    aCJ+7yB/5UWKVCMsqRi+eZI=
    =yl2f
    -----END PGP SIGNATURE-----


  2. Re: kde 3.4.1 packages

    > A mirror has been set up on alioth :
    >
    > deb http://pkg-kde.alioth.debian.org/kde-3.4.1/ ./
    > deb-src http://pkg-kde.alioth.debian.org/kde-3.4.1/ ./


    I am currently populating the mirror with packages for amd64 (and if I
    have enough time for ppc as well).

    Cheers,
    --
    ·O· Pierre Habouzit
    ··O madcoder@debian.org
    OOO http://www.madism.org

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.1 (GNU/Linux)

    iD8DBQBCnrI4vGr7W6HudhwRAjz1AJ4kaNNCnjK5jLU+PXgfpk EjYUtD9QCgl1ln
    o+zFMk4lt68c4MXiqS3gt1k=
    =cexm
    -----END PGP SIGNATURE-----


  3. Re: kde 3.4.1 packages

    On 6/1/05, Pierre Habouzit wrote:
    > the QT-KDE team just uploaded to experimental packages for the 3.4.1 kde
    > following modules :


    Thanks, I'm enjoying them now. BTW, when I try to access the
    Kommander handbook, the khelp says the requested file could not be
    found. Check that you have installed the documentation. Is it
    missing or did I miss some packages?

    hacker

  4. Re: kde 3.4.1 packages

    Le Jeudi 2 Juin 2005 16:43, hacker a écrit*:
    > On 6/1/05, Pierre Habouzit wrote:
    > > the QT-KDE team just uploaded to experimental packages for the
    > > 3.4.1 kde following modules :

    >
    > Thanks, I'm enjoying them now. BTW, when I try to access the
    > Kommander handbook, the khelp says the requested file could not be
    > found. Check that you have installed the documentation. Is it
    > missing or did I miss some packages?


    kommander is part of kdewebdev and has not been packaged yet (see my
    mail)

    --
    ·O· Pierre Habouzit
    ··O madcoder@debian.org
    OOO http://www.madism.org

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.1 (GNU/Linux)

    iD8DBQBCnx/EvGr7W6HudhwRAuVjAJwKjp3J/5u60oCZVcdl6xWWdNgxngCfV0VW
    oDpSvmx+7jYQM4B0NXTexIU=
    =XHXF
    -----END PGP SIGNATURE-----


  5. Re: kde 3.4.1 packages

    On June 2, 2005 11:03, Pierre Habouzit wrote:
    > Le Jeudi 2 Juin 2005 16:43, hacker a écrit*:
    > > On 6/1/05, Pierre Habouzit wrote:
    > > > the QT-KDE team just uploaded to experimental packages for the
    > > > 3.4.1 kde following modules :

    > >
    > > Thanks, I'm enjoying them now. BTW, when I try to access the
    > > Kommander handbook, the khelp says the requested file could not be
    > > found. Check that you have installed the documentation. Is it
    > > missing or did I miss some packages?

    >
    > kommander is part of kdewebdev and has not been packaged yet (see my
    > mail)


    To elaborate further, there is a bug in kdewebdev 3.4.0 that makes kommander
    look for its handbook in the wrong location. We've patched this, and the
    fix will be in the 3.4.1 packages.

    Cheers,
    Christopher Martin

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.1 (GNU/Linux)
    Comment: Signed by Christopher Martin

    iD8DBQBCn0SwU+gWW+vtsysRAkavAJ9lrTOIKjMNomvWlp56Fq JFL8JehQCfSYGU
    S29uoSoOBEuKdcU+yVQfRqI=
    =XOC7
    -----END PGP SIGNATURE-----


  6. Re: kde 3.4.1 packages

    On 6/2/05, Christopher Martin wrote:
    > On June 2, 2005 11:03, Pierre Habouzit wrote:
    > > Le Jeudi 2 Juin 2005 16:43, hacker a écrit:

    > To elaborate further, there is a bug in kdewebdev 3.4.0 that makes kommander
    > look for its handbook in the wrong location. We've patched this, and the
    > fix will be in the 3.4.1 packages.
    >
    > Cheers,
    > Christopher Martin


    That's great.

    OK, I just realized that I'm running a mix of kde-3.4.0-pre and 3.4.1
    (i.e. kmail is 3.4.0, but kppp is 3.4.1). Things seem to working ok
    so far, but I hopefully this won't be for too long.

    hacker

  7. Re: kde 3.4.1 packages

    On June 2, 2005 16:31, hacker wrote:
    > OK, I just realized that I'm running a mix of kde-3.4.0-pre and 3.4.1
    > (i.e. kmail is 3.4.0, but kppp is 3.4.1). Things seem to working ok
    > so far, but I hopefully this won't be for too long.


    As the original kde-3.4.1 announcement mentioned, "the other kde modules are
    either maintained outside from the team, or depends upon packages that are
    maintained outside from the team." This means that they'll come in time,
    but we have no ETA, since we're not ultimately responsible for them.
    kdewebdev is a special case, since it depends on kdesdk, which has not yet
    been updated to 3.4.1. Once that is done, we will upload kdewebdev 3.4.1 to
    go along with it. Meanwhile, you shouldn't have any problems.

    Cheers,
    Christopher Martin

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.1 (GNU/Linux)
    Comment: Signed by Christopher Martin

    iD8DBQBCn3BaU+gWW+vtsysRAkzMAJ98Q+B+rp857rq3PSSI0r Fk4mwMYgCfWM/y
    4oUVdUgmx3FQN1M/wwpVr14=
    =YkRI
    -----END PGP SIGNATURE-----


  8. Re: kde 3.4.1 packages

    Daniel Shepler just packaged kdepim and kdegames. they are now on
    alioth.

    I'm building kdepim for amd64, and it will be on alioth soon.
    --
    ·O· Pierre Habouzit
    ··O madcoder@debian.org
    OOO http://www.madism.org

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.1 (GNU/Linux)

    iD8DBQBCoBAfvGr7W6HudhwRAlZhAKCDWXSYeVWmW+f5GKShWZ Szuck2wwCfaoxv
    EPD5JQGdxn/QJ4r0SfvOosc=
    =INog
    -----END PGP SIGNATURE-----


  9. Re: kde 3.4.1 packages

    On Wednesday 01 June 2005 18:18, Pierre Habouzit wrote:
    > the QT-KDE team just uploaded to experimental packages for the 3.4.1 kde


    >
    > deb http://pkg-kde.alioth.debian.org/kde-3.4.1/ ./
    > deb-src http://pkg-kde.alioth.debian.org/kde-3.4.1/ ./


    If anyone is interested in running kde-3.4.1 with xorg, I've updated
    kdebase-3.4.1 to include kompmgr. The new package along with xorg are
    available via the following repository (check
    http://helion.xcyb.org/debian-xcyborg/ for more info):

    # binary packages for i386 and amd64 architectures
    deb http://helion.xcyb.org/debian-xcyborg unstable main

    # sources
    deb-src http://helion.xcyb.org/debian-xcyborg unstable main


    Mihai


    --
    This message was scanned for spam and viruses by BitDefender.
    For more information please visit http://www.bitdefender.com/


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  10. Re: kde 3.4.1 packages

    My kmail 3.4.1 (alioth, amd64) segfaults all the time when deleting many mails
    in a row (that's pressing "del" a couple of seconds...). Didn't use to happen
    with 3.4.0

    Regards,

    Rafael Rodríguez

    El Viernes, 3 de Junio de 2005 15:47, Mihai Maties escribió:
    > On Wednesday 01 June 2005 18:18, Pierre Habouzit wrote:
    > > the QT-KDE team just uploaded to experimental packages for the 3.4.1 kde

    >
    >
    >
    > > deb http://pkg-kde.alioth.debian.org/kde-3.4.1/ ./
    > > deb-src http://pkg-kde.alioth.debian.org/kde-3.4.1/ ./

    >
    > If anyone is interested in running kde-3.4.1 with xorg, I've updated
    > kdebase-3.4.1 to include kompmgr. The new package along with xorg are
    > available via the following repository (check
    > http://helion.xcyb.org/debian-xcyborg/ for more info):
    >
    > # binary packages for i386 and amd64 architectures
    > deb http://helion.xcyb.org/debian-xcyborg unstable main
    >
    > # sources
    > deb-src http://helion.xcyb.org/debian-xcyborg unstable main
    >
    >
    > Mihai
    >
    >
    > --
    > This message was scanned for spam and viruses by BitDefender.
    > For more information please visit http://www.bitdefender.com/


  11. Re: kde 3.4.1 packages

    Works fine for me on i386.

    I already had xorg but, so that was mainly an update fro 3.3.2 to 3.4.1.
    Neverthless all your xorg got downloaded (that was normal).

    - Few glitches at install / perhaps my fault - don't know
    Unpacking replacement kdict ...
    dpkg: error processing /var/cache/apt/archives/kdict_4%3a3.4.1-1_i386.deb (--unpack):
    trying to overwrite `/usr/share/icons/crystalsvg/scalable/apps/kdict.svgz', which is also in package kdebase-data
    dpkg-deb: subprocess paste killed by signal (Broken pipe)

    Preparing to replace kdelibs-data 4:3.3.2-6.1 (using .../kdelibs-data_4%3a3.4.1-1_all.deb) ...
    Unpacking replacement kdelibs-data ...
    Replacing files in old package konq-plugins ...
    dpkg: error processing /var/cache/apt/archives/kdelibs-data_4%3a3.4.1-1_all.deb (--unpack):
    trying to overwrite `/usr/share/services/mmst.protocol', which is also in package kplayer
    dpkg-deb: subprocess paste killed by signal (Broken pipe)

    A forced dpkg/apt-get -f install solved that.

    - I add to refetch the feeds to get them displayed in kontact. Minor thing.
    - konsole forgot my default font, that I putted back to 'Linux'. Minor again.
    - kompmgr works
    - For the gory, this is perhaps unrelated, but swsusp2 on it worked fine.

    And well, 3.4.1 has a great look and feel. I have to say that the transition from 3.3.2
    to 3.4.1 globally worked very well, given the big number of packages upgraded.
    Except the two dpkg errors mentionned upper, it worked out of the box. Well done!

    So many many thanks for this great work to You and All the alioth poeple!

    Cheers, JD.

    On Friday 03 June 2005 16:47, Mihai Maties wrote:
    MM > On Wednesday 01 June 2005 18:18, Pierre Habouzit wrote:
    MM > > the QT-KDE team just uploaded to experimental packages for the 3.4.1 kde
    MM >
    MM > >
    MM > > deb http://pkg-kde.alioth.debian.org/kde-3.4.1/ ./
    MM > > deb-src http://pkg-kde.alioth.debian.org/kde-3.4.1/ ./
    MM >
    MM > If anyone is interested in running kde-3.4.1 with xorg, I've updated
    MM > kdebase-3.4.1 to include kompmgr. The new package along with xorg are
    MM > available via the following repository (check
    MM > http://helion.xcyb.org/debian-xcyborg/ for more info):
    MM >
    MM > # binary packages for i386 and amd64 architectures
    MM > deb http://helion.xcyb.org/debian-xcyborg unstable main
    MM >
    MM > # sources
    MM > deb-src http://helion.xcyb.org/debian-xcyborg unstable main
    MM >
    MM >
    MM > Mihai
    MM >
    MM >
    MM > --
    MM > This message was scanned for spam and viruses by BitDefender.
    MM > For more information please visit http://www.bitdefender.com/
    MM >
    MM >

    --
    Jean-Damien Durand CERN/IT/ADC/CA - Geneva, Switzerland
    PGP PUBLIC KEY: http://home.cern.ch/~jdurand/public_key.asc
    This mail is signed using CERN CA, please use my PGP key otherwise
    CERN CA root certificate: http://cern.ch/service-grid-ca/crt/root_crt.html


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  12. Re: kde 3.4.1 packages

    * Jean-Damien Durand [Sat, 04 Jun 2005 13:08:58 +0200]:

    Hi!

    > - Few glitches at install / perhaps my fault - don't know
    > Unpacking replacement kdict ...
    > dpkg: error processing /var/cache/apt/archives/kdict_4%3a3.4.1-1_i386.deb (--unpack):
    > trying to overwrite `/usr/share/icons/crystalsvg/scalable/apps/kdict.svgz', which is also in package kdebase-data
    > dpkg-deb: subprocess paste killed by signal (Broken pipe)


    Oh, so we finally didn't have this fixed. Thanks for the notice.

    > Preparing to replace kdelibs-data 4:3.3.2-6.1 (using .../kdelibs-data_4%3a3.4.1-1_all.deb) ...
    > Unpacking replacement kdelibs-data ...
    > Replacing files in old package konq-plugins ...
    > dpkg: error processing /var/cache/apt/archives/kdelibs-data_4%3a3.4.1-1_all.deb (--unpack):
    > trying to overwrite `/usr/share/services/mmst.protocol', which is also in package kplayer
    > dpkg-deb: subprocess paste killed by signal (Broken pipe)


    Please inform of this to the provider of the kplayer package (which is
    not in Debian).

    Cheers,

    --
    Adeodato Simó
    EM: asp16 [ykwim] alu.ua.es | PK: DA6AE621

    And don't get me wrong - I don't mind getting proven wrong. I change my
    opinions the way some people change underwear. And I think that's ok.
    -- Linus Torvalds


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  13. Re: kde 3.4.1 packages


    >> Preparing to replace kdelibs-data 4:3.3.2-6.1 (using .../kdelibs-data_4%3a3.4.1-1_all.deb) ...
    >> Unpacking replacement kdelibs-data ...
    >> Replacing files in old package konq-plugins ...
    >> dpkg: error processing /var/cache/apt/archives/kdelibs-data_4%3a3.4.1-1_all.deb (--unpack):
    >> trying to overwrite `/usr/share/services/mmst.protocol', which is also in package kplayer
    >> dpkg-deb: subprocess paste killed by signal (Broken pipe)

    >
    > Please inform of this to the provider of the kplayer package (which is
    > not in Debian).


    Workaround is to uninstall kplayer, after which kdelibs-data will
    finishing installing; then reinstall kplayer.


    --
    To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread