Bug#417937: debian-installer does not support raid10 for partitioning - Debian

This is a discussion on Bug#417937: debian-installer does not support raid10 for partitioning - Debian ; Package: installation-reports Boot method: CD Image version: http://cdimage.debian.org/cdimage/et...2/i386/iso-cd/ Date: 03 Apr 2007 Machine: Supermicro PDSMi-based rackmount system Processor: Core2Duo Xeon 2.4GHz Memory: 4GiB Partitions: No partitions were created because didn't get that far Output of lspci -nn and lspci -vnn: ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Bug#417937: debian-installer does not support raid10 for partitioning

  1. Bug#417937: debian-installer does not support raid10 for partitioning

    Package: installation-reports

    Boot method: CD
    Image version: http://cdimage.debian.org/cdimage/et...2/i386/iso-cd/
    Date: 03 Apr 2007

    Machine: Supermicro PDSMi-based rackmount system
    Processor: Core2Duo Xeon 2.4GHz
    Memory: 4GiB
    Partitions: No partitions were created because didn't get that far

    Output of lspci -nn and lspci -vnn: Ditto

    Base System Installation Checklist:
    [O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

    Initial boot: [O]
    Detect network card: [O]
    Configure network: [O]
    Detect CD: [O]
    Load installer modules: [O]
    Detect hard drives: [O]
    Partition hard drives: [E]
    Install base system: [ ]
    Clock/timezone setup: [ ]
    User/password setup: [ ]
    Install tasks: [ ]
    Install boot loader: [ ]
    Overall install: [ ]

    Comments/Problems:

    Installer offers to create software RAID arrays from partitions
    marked as RAID members, but does not support raid10 which was a
    show-stopper for the installation of this server with 4 disks,
    intended to be almost entirely on raid10.

    Switching to a terminal and issuing lsmod I could see the raid0, 1
    and 5 modules loaded but no raid10. raid10 module was also not
    present in the filesystem so I assume it is not supported.

    Of course it is not possible to boot from raid10, which is why I
    intended to create a small /boot in raid1, but I wanted everything
    else in raid10.

    In the end I booted from a livecd and installed by debootstrap.

    Obviously a bit of a fringe case, but "it would be nice".


    --
    To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Bug#417937: debian-installer does not support raid10 for partitioning

    reassign 417937 partman-md
    severity 417937 wishlist
    thanks

    On Thursday 05 April 2007 17:20, Andy Smith wrote:
    > Comments/Problems:
    > Installer offers to create software RAID arrays from partitions
    > marked as RAID members, but does not support raid10 which was a
    > show-stopper for the installation of this server with 4 disks,
    > intended to be almost entirely on raid10.


    This has been mentioned before and I've now added this to:
    http://wiki.debian.org/DebianInstaller/LennyGoals

    Cheers,
    FJP


    --
    To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Processed: Re: Bug#417937: debian-installer does not support raid10 for partitioning

    Processing commands for control@bugs.debian.org:

    > reassign 417937 partman-md

    Bug#417937: debian-installer does not support raid10 for partitioning
    Bug reassigned from package `installation-reports' to `partman-md'.

    > severity 417937 wishlist

    Bug#417937: debian-installer does not support raid10 for partitioning
    Severity set to `wishlist' from `normal'

    > thanks

    Stopping processing here.

    Please contact me if you need assistance.

    Debian bug tracking system administrator
    (administrator, Debian Bugs database)


    --
    To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  4. Bug#417937: marked as done (debian-installer does not support raid10 for partitioning)


    Your message dated Thu, 4 Sep 2008 12:04:46 +0200
    with message-id <20080904100446.GA1257@qamar>
    and subject line Re: Bug#417937: debian-installer does not support raid10 for partitioning
    has caused the Debian Bug report #417937,
    regarding debian-installer does not support raid10 for partitioning
    to be marked as done.

    This means that you claim that the problem has been dealt with.
    If this is not the case it is now your responsibility to reopen the
    Bug report if necessary, and/or fix the problem forthwith.

    (NB: If you are a system administrator and have no idea what this
    message is talking about, this may indicate a serious mail system
    misconfiguration somewhere. Please contact owner@bugs.debian.org
    immediately.)


    --
    417937: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=417937
    Debian Bug Tracking System
    Contact owner@bugs.debian.org with problems


+ Reply to Thread