LVM2 + LUKS Installation Failure (netinstall) due to device-mapper - Debian

This is a discussion on LVM2 + LUKS Installation Failure (netinstall) due to device-mapper - Debian ; Hello, I have tried installing via netinstall CD (daily build - few days old), but if I select LVM2 with Encryption (LUKS), I receive the following error on the Partition section: Partition disks Configuration of encrypted volumes failed An error ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: LVM2 + LUKS Installation Failure (netinstall) due to device-mapper

  1. LVM2 + LUKS Installation Failure (netinstall) due to device-mapper

    Hello,

    I have tried installing via netinstall CD (daily build - few days old), but if
    I select LVM2 with Encryption (LUKS), I receive the following error on the
    Partition section:

    Partition disks
    Configuration of encrypted volumes failed
    An error occured while configuring encrypted volumes
    The configuration has been aborted

    In vt2, dmesg gave this output:
    ....
    device-mapper: table 254:0 crypt: Error allocating crypto tfm
    device-mapper: ioctl: error adding target to table
    device-mapper: ioctl: device doesn't appear to be in the dev hash table

    ls /dev/hd* results in "no such file or directory" - although I do not know if
    this is anything out of the ordinary.

    Does anyone know why this is happening? Any ideas towards a solution?

    Thank you.


    --
    To UNSUBSCRIBE, email to debian-laptop-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: LVM2 + LUKS Installation Failure (netinstall) due to device-mapper

    CORRECTION:
    ls /dev/sd* does work and this is the (correct) result:
    /dev/sda /dev/sda1 /dev/sda5


    --
    To UNSUBSCRIBE, email to debian-laptop-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread