m-a a-i fglrx-kernel-src and m-a a-i alsa-source failed - Debian

This is a discussion on m-a a-i fglrx-kernel-src and m-a a-i alsa-source failed - Debian ; Hello, I installed linux-image-2.6.20-1-amd64 on my laptop acer aspire 5102wmli. I use unstable. When I ran m-a a-i alsa-source and m-a a-i fglrx-kernel-src I got error: my /var/cache/modass/alsa-source.buildlog.2.6.20-1-amd64.1178477634 contains: ....... make[3]: entrant dans le répertoire « /usr/src/linux-headers-2.6.20-1-amd64 » CC [M] ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: m-a a-i fglrx-kernel-src and m-a a-i alsa-source failed

  1. m-a a-i fglrx-kernel-src and m-a a-i alsa-source failed

    Hello,
    I installed linux-image-2.6.20-1-amd64 on my laptop acer aspire
    5102wmli.
    I use unstable.

    When I ran m-a a-i alsa-source and m-a a-i fglrx-kernel-src I got
    error:

    my /var/cache/modass/alsa-source.buildlog.2.6.20-1-amd64.1178477634
    contains:
    .......
    make[3]: entrant dans le répertoire « /usr/src/linux-headers-2.6.20-1-amd64 »
    CC [M] /usr/src/modules/alsa-driver/acore/hwdep.o
    CC [M] /usr/src/modules/alsa-driver/acore/memalloc.o
    CC [M] /usr/src/modules/alsa-driver/acore/sgbuf.o
    CC [M] /usr/src/modules/alsa-driver/acore/memory_wrapper.o
    CC [M] /usr/src/modules/alsa-driver/acore/pcm.o
    In file included from /usr/src/modules/alsa-driver/acore/../alsa-kernel/core/pcm.c:29,
    from /usr/src/modules/alsa-driver/acore/pcm.c:1:
    /usr/src/modules/alsa-driver/include/sound/pcm.h: In function 'snd_pcm_mmap_data_open':
    /usr/src/modules/alsa-driver/include/sound/pcm.h:977: error: dereferencing pointer to incomplete type
    /usr/src/modules/alsa-driver/include/sound/pcm.h: In function 'snd_pcm_mmap_data_close':
    /usr/src/modules/alsa-driver/include/sound/pcm.h:983: error: dereferencing pointer to incomplete type
    make[6]: *** [/usr/src/modules/alsa-driver/acore/pcm.o] Erreur 1
    make[5]: *** [/usr/src/modules/alsa-driver/acore] Erreur 2
    make[4]: *** [_module_/usr/src/modules/alsa-driver] Erreur 2
    make[3]: *** [modules] Erreur 2
    make[3]: quittant le répertoire « /usr/src/linux-headers-2.6.20-1-amd64»
    make[2]: *** [compile] Erreur 2
    make[2]: quittant le répertoire « /usr/src/modules/alsa-driver »
    make[1]: *** [build-stamp] Erreur 2
    make[1]: quittant le répertoire « /usr/src/modules/alsa-driver »
    make: *** [kdist_image] Erreur 2

    my /var/cache/modass/fglrx-kernel-src.buildlog.2.6.20-1-amd64.1178476313
    contains:
    .............
    /usr/bin/make -C /lib/modules/2.6.20-1-amd64/build SUBDIRS=/usr/src/modules/fglrx modules
    make[1]: entrant dans le répertoire « /usr/src/linux-headers-2.6.20-1-amd64 »
    CC [M] /usr/src/modules/fglrx/firegl_public.o
    /usr/src/modules/fglrx/firegl_public.c:185: error: expected declaration specifiers or '...' before 'mlock'
    /usr/src/modules/fglrx/firegl_public.c:185: error: expected declaration specifiers or '...' before 'addr'
    /usr/src/modules/fglrx/firegl_public.c:185: error: expected declaration specifiers or '...' before 'len'
    /usr/src/modules/fglrx/firegl_public.c:187: warning: return type defaults to 'int'
    /usr/src/modules/fglrx/firegl_public.c: In function '_syscall2':
    /usr/src/modules/fglrx/firegl_public.c:187: error: expected declaration specifiers before '_syscall2'
    /usr/src/modules/fglrx/firegl_public.c:224: error: parameter '__ke_debuglevel' is initialized
    /usr/src/modules/fglrx/firegl_public.c:225: error: parameter '__ke_moduleflags' is initialized
    /usr/src/modules/fglrx/firegl_public.c:228: error: storage class specified for parameter '__mod_author228'
    /usr/src/modules/fglrx/firegl_public.c:228: error: parameter '__mod_author228' is initialized
    /usr/src/modules/fglrx/firegl_public.c:228: warning: '__used__' attribute ignored
    /usr/src/modules/fglrx/firegl_public.c:228: error: section attribute not allowed for '__mod_author228'
    /usr/src/modules/fglrx/firegl_public.c:229: error: storage class specified for parameter '__mod_description229'
    /usr/src/modules/fglrx/firegl_public.c:229: error: parameter '__mod_description229' is initialized
    /usr/src/modules/fglrx/firegl_public.c:229: warning: '__used__' attribute ignored
    /usr/src/modules/fglrx/firegl_public.c:229: error: section attribute not allowed for '__mod_description229'
    /usr/src/modules/fglrx/firegl_public.c:233: error: expected '=', ',', ';', 'asm' or '__attribute__' before '{' token
    ...........
    ...........
    /usr/src/modules/fglrx/firegl_public.c:3794: error: expected '=', ',', ';', 'asm' or '__attribute__' before '{' token
    /usr/src/modules/fglrx/firegl_public.c:3865: error: expected '=', ',', ';', 'asm' or '__attribute__' before '{' token
    /usr/src/modules/fglrx/firegl_public.c:3881: error: expected '=', ',', ';', 'asm' or '__attribute__' before '{' token
    /usr/src/modules/fglrx/firegl_public.c:3887: error: expected '=', ',', ';', 'asm' or '__attribute__' before '{' token
    /usr/src/modules/fglrx/firegl_public.c:3891: error: old-style parameter declarations in prototyped function definition
    /usr/src/modules/fglrx/firegl_public.c:185: error: parameter name omitted
    /usr/src/modules/fglrx/firegl_public.c:185: error: parameter name omitted
    /usr/src/modules/fglrx/firegl_public.c:185: error: parameter name omitted
    /usr/src/modules/fglrx/firegl_public.c:3891: error: expected '{' at end of input
    make[2]: *** [/usr/src/modules/fglrx/firegl_public.o] Erreur 1
    make[1]: *** [_module_/usr/src/modules/fglrx] Erreur 2
    make[1]: quittant le répertoire « /usr/src/linux-headers-2.6.20-1-amd64»
    make: *** [build] Erreur 2


    Has someone encountered this problem and solved it ?

    Thanks in advance for any advices.
    --
    Gérard

  2. Re: m-a a-i fglrx-kernel-src and m-a a-i alsa-source failed

    On date Sunday 2007-05-06 21:42:49 +0200, Gerard Robin, wrote:
    > Hello,
    > I installed linux-image-2.6.20-1-amd64 on my laptop acer aspire
    > 5102wmli.
    > I use unstable.
    >
    > When I ran m-a a-i alsa-source and m-a a-i fglrx-kernel-src I got
    > error:
    > [...]
    > Has someone encountered this problem and solved it ?


    Hi Gérard,

    yes, I also tried to compile fglrx-kernel-src with linux 2.6.20: as
    far as I know that package isn't supposed to work with linux 2.6.20,
    but only with linux 2.6.18 (and it's likely the same for the alsa
    source).

    You have to downgrade your kernel or use the upstream source code.

    HTH
    --
    Stefano Sabatini
    Linux user number 337176 (see http://counter.li.org)


    --
    To UNSUBSCRIBE, email to debian-laptop-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Re: m-a a-i fglrx-kernel-src and m-a a-i alsa-source failed


    > Hi Gérard,
    >
    > yes, I also tried to compile fglrx-kernel-src with linux 2.6.20: as
    > far as I know that package isn't supposed to work with linux 2.6.20,
    > but only with linux 2.6.18 (and it's likely the same for the alsa
    > source).
    >
    > You have to downgrade your kernel or use the upstream source code.


    You can get replacement packages for Debian out from the upstream installer and install them with "dpkg -i", IIRC with ./installername.run --buildpkg Debian/etch or so. See its help for details.

    After that you should be able to install m-a as intended.


    --
    To UNSUBSCRIBE, email to debian-laptop-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  4. Re: m-a a-i fglrx-kernel-src and m-a a-i alsa-source failed

    On Mon, May 07, 2007 at 12:29:49PM +0200, Stefano Sabatini wrote:
    >From: Stefano Sabatini
    >To: debian-laptop@lists.debian.org
    >Subject: Re: m-a a-i fglrx-kernel-src and m-a a-i alsa-source failed
    >On date Sunday 2007-05-06 21:42:49 +0200, Gerard Robin, wrote:
    >> Hello,
    >> I installed linux-image-2.6.20-1-amd64 on my laptop acer aspire
    >> 5102wmli.
    >> I use unstable.
    >>
    >> When I ran m-a a-i alsa-source and m-a a-i fglrx-kernel-src I got
    >> error:
    >> [...]
    >> Has someone encountered this problem and solved it ?


    >Hi Gérard,


    >yes, I also tried to compile fglrx-kernel-src with linux 2.6.20: as
    >far as I know that package isn't supposed to work with linux 2.6.20,
    >but only with linux 2.6.18 (and it's likely the same for the alsa
    >source).


    >You have to downgrade your kernel or use the upstream source code.


    Ok I booted to the 2.6.18 kernel and then m-a a-i .... ran fine.
    Many thanks to those who helped me.

    --
    Gérard

+ Reply to Thread