Re: Video issues with T42 running Etch and more - Debian

This is a discussion on Re: Video issues with T42 running Etch and more - Debian ; Hi, for thinkpads and linux there is really good site.. thinkwiki On Don, 01 Feb 2007, justin joseph wrote: > Have now come up against a stone wall and need help. The video card > on this machine is a ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Re: Video issues with T42 running Etch and more

  1. Re: Video issues with T42 running Etch and more

    Hi,

    for thinkpads and linux there is really good site..

    thinkwiki



    On Don, 01 Feb 2007, justin joseph wrote:

    > Have now come up against a stone wall and need help. The video card
    > on this machine is a ATI Technologies Inc Radeon Mobility M7 LW
    > [Radeon Mobility 7500]. X is working but I don't think its working
    > the way it should.
    >
    > I am unable to find from google, why lspci says that this card is
    > 128MB whereas it is 32MB.


    this is only the memory area use by your card.
    your cpu is capable to address at least 4gb of ram, and a physicall devices
    grab just some of the addresses so the cpu can work with them.

    512mb are grabbed by your system memory
    and every pci device takes some memory

    > justin@thinkpad:~$ free -m
    > total used free shared buffers cached
    > Mem: 504 230 273 0 8 96
    > -/+ buffers/cache: 125 379
    > Swap: 1011 0 1011
    > justin@thinkpad:~$
    >
    > I see that there is only 504MB of ram where as it must have been 512.
    > where has the rest 8mb gone? I understand that this happens only when
    > its shared by the VGA controller and in this case why would the VGA
    > controller share it because its got 32 MB of vram.


    i bet 8mb are lost because auf AGP, the agpgart driver in linux by default
    grabs 8mb of memory.

    > I can provide the full lspci output if required and would be nice if
    > someone could send me an xorg.conf which fully utilizes this system.


    as above .. take a look to thinkwiki

    > on the sidelines, I were wondering why *most* of the subsystems on
    > this T42 shows up as R50e on the lspci output. It that usual or has
    > Lenovo conned me into purchasing R50e machine with just T42 name with
    > better lid material.


    lspci just reads the PCI IDs of your devices, then uses some sort of databae
    to print _you_ a human readable device name. So don't take the text displayed
    to serious.

    --
    Florian Reitmeir


    --
    To UNSUBSCRIBE, email to debian-laptop-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: Video issues with T42 running Etch and more

    On 2/1/07, Florian Reitmeir wrote:

    > > I see that there is only 504MB of ram where as it must have been 512.
    > > where has the rest 8mb gone? I understand that this happens only when
    > > its shared by the VGA controller and in this case why would the VGA
    > > controller share it because its got 32 MB of vram.

    >
    > i bet 8mb are lost because auf AGP, the agpgart driver in linux by default
    > grabs 8mb of memory.


    I were wondering why video drivers would grab memory outside of the
    allready existing 32 mb vram that there on the vedeo card. My 600E
    did'nt have any missing physical memory even though it had only 2mb
    vram. anything... thank you.




    >


    > Florian Reitmeir
    >
    >
    > --
    > To UNSUBSCRIBE, email to debian-laptop-REQUEST@lists.debian.org
    > with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
    >
    >



    --
    To UNSUBSCRIBE, email to debian-laptop-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread