wifi failed with acer aspire 5102wlmi - Debian

This is a discussion on wifi failed with acer aspire 5102wlmi - Debian ; Hello, I succeded to install etch on my laptop, almost all work fine, but I encounter some problems with the wireless card. Atheros. I found doc and examples on http://madwifi.org/users-guide/ http://www.burghardt.pl/wiki/article...spire_5102wlmi I did all the steps requested, and I can't ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: wifi failed with acer aspire 5102wlmi

  1. wifi failed with acer aspire 5102wlmi

    Hello,
    I succeded to install etch on my laptop, almost all work fine, but I
    encounter some problems with the wireless card. Atheros.

    I found doc and examples on
    http://madwifi.org/users-guide/
    http://www.burghardt.pl/wiki/article...spire_5102wlmi
    I did all the steps requested, and I can't connect my box on the
    internet.

    wlanconfig ath0 destroy
    wlanconfig ath0 create wlandev wifi0 wlanmode sta
    modprobe ath_pci
    I edited /etc/network/interfaces.
    - iwlist ath0 scan gave me the AP's
    - iwconfig ath0 ap AP's
    - iwconfig ath0 gives all that we need:

    ath0 IEEE 802.11g ESSID:"XXXX"
    Mode:Managed Frequency:2.412 GHz Access Point: XX:XX:XX:XX:XX:XX
    Bit Rate:36 Mb/s Tx-Power:9 dBm Sensitivity=0/3
    Retryff RTS thrff Fragment thrff
    Encryption key:XXXX-XXXX-XX Security mode:restricted
    Power Managementff
    Link Quality=57/94 Signal level=-38 dBm Noise level=-95 dBm
    Rx invalid nwid:149041 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0
    where ESSID, Acess Point, and key are those expected.

    When I rebooted the machine I can see:
    SIOCADDRT Network is unreachable.
    failed to bring up ath0.
    What I have missed ?
    (my wireless connection works fine with windows ;-))
    Thanks in advance for any help.

    --
    Gérard

  2. Re: wifi failed with acer aspire 5102wlmi

    Hi,

    maybe it would help to issue the "modprobe ath_pci"-command before the wlanconfig-stuff.


    Greetings,
    Stefan


    --
    To UNSUBSCRIBE, email to debian-laptop-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Re: wifi failed with acer aspire 5102wlmi

    On Mon, Jan 29, 2007 at 10:18:38AM +0100, Stefan Mussmann wrote:
    >From: Stefan Mussmann
    >To: debian-laptop@lists.debian.org
    >Subject: Re: wifi failed with acer aspire 5102wlmi
    >X-Spam-Checker-Version: SpamAssassin 3.1.4 (2006-07-26) on murphy.debian.org
    >X-Spam-Level:
    >X-Spam-Status: No, score=-8.0 required=4.0 tests=BAYES_00,LDOSUBSCRIBER,
    > SPF_PASS autolearn=ham version=3.1.4
    >X-Mailer: WWW-Mail 6100 (Global Message Exchange)
    >
    >Hi,
    >
    >maybe it would help to issue the "modprobe ath_pci"-command before the wlanconfig-stuff.


    Hi

    lsmod | grep ath_pci
    ath_pci 98344 0
    ath_rate_sample 19584 1 ath_pci
    wlan 201152 5 wlan_wep,wlan_scan_sta,ath_pci,ath_rate_sample
    ath_hal 222960 3 ath_pci,ath_rate_sample

    On my provider I set a WPA key and on my box I have a WEP key. How to
    set a WPA key on my box ?

    Thanks.
    --
    Gérard

  4. Re: wifi failed with acer aspire 5102wlmi

    On date Monday 2007-01-29 00:17:23 +0100, Gerard Robin, wrote:
    > Hello,
    > I succeded to install etch on my laptop, almost all work fine, but I
    > encounter some problems with the wireless card. Atheros.
    >
    > I found doc and examples on
    > http://madwifi.org/users-guide/
    > http://www.burghardt.pl/wiki/article...spire_5102wlmi
    > I did all the steps requested, and I can't connect my box on the
    > internet.
    >
    > wlanconfig ath0 destroy
    > wlanconfig ath0 create wlandev wifi0 wlanmode sta
    > modprobe ath_pci
    > I edited /etc/network/interfaces.
    > - iwlist ath0 scan gave me the AP's
    > - iwconfig ath0 ap AP's
    > - iwconfig ath0 gives all that we need:
    >
    > ath0 IEEE 802.11g ESSID:"XXXX"
    > Mode:Managed Frequency:2.412 GHz Access Point: XX:XX:XX:XX:XX:XX
    > Bit Rate:36 Mb/s Tx-Power:9 dBm Sensitivity=0/3
    > Retryff RTS thrff Fragment thrff
    > Encryption key:XXXX-XXXX-XX Security mode:restricted
    > Power Managementff
    > Link Quality=57/94 Signal level=-38 dBm Noise level=-95 dBm
    > Rx invalid nwid:149041 Rx invalid crypt:0 Rx invalid frag:0
    > Tx excessive retries:0 Invalid misc:0 Missed beacon:0
    > where ESSID, Acess Point, and key are those expected.
    >
    > When I rebooted the machine I can see:
    > SIOCADDRT Network is unreachable.
    > failed to bring up ath0.
    > What I have missed ?
    > (my wireless connection works fine with windows ;-))
    > Thanks in advance for any help.


    It's possible there are problems with the wireless button.
    I have an Acer Aspire 1673WLMi, I can modprobe the ndiswrapper module,
    but in order to get it working I have to switch on the wireless button
    *before* to load the module.

    The acerhk module may help:
    http://freshmeat.net/projects/acerhk/

    Note that it doesn't compile with linux >= 2.6.19 (you have to simply
    comment in the line in the source with:
    #include

    since config.h is now deprecated).

    If you need I'll send you an hacked version of acerhk that works on my
    laptop.

    HTH
    --
    Stefano Sabatini
    Linux user number 337176 (see http://counter.li.org)


    --
    To UNSUBSCRIBE, email to debian-laptop-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  5. Re: wifi failed with acer aspire 5102wlmi

    Gérard Robin wrote:
    >
    > On my provider I set a WPA key and on my box I have a WEP key. How to
    > set a WPA key on my box ?
    >
    > Thanks.

    Did you install wpa_supplicant? This is the only way I know to operate WPA.

    cu
    Stefan


    --
    To UNSUBSCRIBE, email to debian-laptop-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  6. Re: wifi failed with acer aspire 5102wlmi

    On Mon, Jan 29, 2007 at 08:48:01PM +0100, Stefan Mussmann wrote:
    >From: Stefan Mussmann
    >To: debian-laptop
    >Subject: Re: wifi failed with acer aspire 5102wlmi
    >X-Spam-Checker-Version: SpamAssassin 3.1.4 (2006-07-26) on murphy.debian.org
    >X-Spam-Level:
    >X-Spam-Status: No, score=-8.0 required=4.0 tests=BAYES_00,LDOSUBSCRIBER,
    > SPF_PASS autolearn=ham version=3.1.4
    >
    >Gérard Robin wrote:
    >>
    >>On my provider I set a WPA key and on my box I have a WEP key. How to
    >>set a WPA key on my box ?
    >>
    >>Thanks.

    >Did you install wpa_supplicant? This is the only way I know to operate WPA.


    I did andI have found good tutorials here:
    http://madwifi.org/users-guide/node1.html
    http://zongo.be/wiki/MacBook/DebianEtch

    The second url is in french ;-) but very clear for wpasupplicant

    wifi is working fine now :-)

    Thanks to those which help me.
    --
    Gérard

+ Reply to Thread