Rodolfo wrote:

> I'm trying to connect to internet with a gprs cellular phone, a Motorola c350,
> connected to my laptop Hyundai 255KI 15 with a mini usb cable.
> Debian Sarge 3.1 is installed.
> I've been following the howto at:
>
> http://www.debianitalia.org/modules/...1&articleid=96
>
> . First I made sure the acm driver was there, with:
>
> # dmesg |fgrep acm
>
> . Then I did:
>
> # mknod /dev/usb/ttyACM0 c 166 0
>
> . Then I created a file /etc/pppd/peers/provider and filled it with:
>
>
> # Speed
> 115200
> # Use hardware flow control (i.e. RTS/CTS) to control the flow
> # of data on the serial port.
> crtscts
> # Use the modem control lines.
> modem
> # Specifies that pppd should create a UUCP-style lock file for
> # the serial device to ensure exclusive access to the device.
> lock
> # Disable Van Jacobson style TCP/IP header compression in both
> # the transmit and the receive direction.
> novj
> # Disables the default behaviour when no local IP address is
> # specified, which is to determine (if possible) the local IP
> # address from the hostname.
> noipdefault
> # This option causes pppd to create such a default route when
> # IPCP comes up, and delete it when the link is terminated.
> defaultroute
> disconnect '/usr/sbin/chat -e -f /etc/chatscripts/disconnect -v'
> connect '/usr/sbin/chat -e -f /etc/chatscripts/provider -v'
> /dev/usb/ttyACM0
> user anythingAT

OK
AT+CGDCONT=1,"IP","web.omnitel.it"
OK
ATDT*99#
CONNECT
Serial connection established.
using channel 1
Using interface ppp0
Connect: ppp0 <--> /dev/usb/ttyACM0
sent [LCP ConfReq id=0x1 ]
rcvd [LCP ConfAck id=0x1 ]
rcvd [LCP ConfReq id=0x1 ]
sent [LCP ConfAck id=0x1 ]
sent [LCP EchoReq id=0x0 magic=0x9dc63d95]
sent [PAP AuthReq id=0x1 user="anything" password=]
rcvd [LCP EchoRep id=0x0 magic=0x11a80f0]
rcvd [PAP AuthAck id=0x1]
PAP authentication succeeded
sent [IPCP ConfReq id=0x1 ]
sent [IPCP ConfReq id=0x1 ]
rcvd [IPCP ConfNak id=0x1 ]
sent [IPCP ConfReq id=0x2 ]
rcvd [IPCP ConfAck id=0x2 ]
rcvd [IPCP ConfReq id=0x2 ]
sent [IPCP ConfAck id=0x2 ]
Cannot determine ethernet address for proxy ARP
local IP address 83.225.139.145
remote IP address 192.168.100.101
Script /etc/ppp/ip-up started (pid 1873)
Script /etc/ppp/ip-up finished (pid 1873), status = 0x0
Terminating on signal 15
Connect time 0.3 minutes.
Sent 0 bytes, received 0 bytes.
Script /etc/ppp/ip-down started (pid 1904)
sent [LCP TermReq id=0x2 "User request"]
rcvd [LCP TermAck id=0x2 "User request"]
Connection terminated.
disconnect script failed
Waiting for 1 child processes...
script /etc/ppp/ip-down, pid 1904
Script /etc/ppp/ip-down finished (pid 1904), status = 0x0
> password anything
> #With this option, pppd will accept all control characters from the peer, including those marked in the receive asyncmap
> receive-all
> logfile "/var/log/pppd.log"
> nobsdcomp
> nodeflate
>
>
>
> . Then I created a file /etc/chatscripts/provider and filled it with:
>
>
> '' AT
> TIMEOUT 240
> OK 'AT+CGDCONT=1,"IP","web.omnitel.it"'
> OK ATDT*99#
> TIMEOUT 22
> CONNECT ""
>
> . Then I put "noauth" in place of "auth" in the file /etc/ppp/options.
> Then I tried to connect with '# pon', but it couldn't be established:
> this is the file /var/log/pppd.log:
>
> AT
> OK
> AT+CGDCONT=1,"IP","web.omnitel.it"
> OK
> ATDT*99#
> CONNECT
> Serial connection established.
> Using interface ppp0
> Connect: ppp0 <--> /dev/usb/ttyACM0
> PAP authentication succeeded
> Cannot determine ethernet address for proxy ARP
> local IP address 83.225.200.24
> remote IP address 192.168.100.101
> Terminating on signal 15
> Connect time 0.5 minutes.
> Sent 0 bytes, received 0 bytes.
> Connection terminated.
> disconnect script failed
>
> . The line 'Terminating on signal 15' shows that something is wrong.
>
> Could anybody suggest a remedy?




Petr wrote:

> Try to put debug to ppp peers config..that should show the cause.
>
> If not, post log with debug turned on.
>
> See man pppd for details.



Sébastien wrote:

> could you enable "debug" in the provider file and provide us a more
> comprehensive log?



At the end of the file /etc/ppp/peers/provider I put the line:

debug

, and this is /var/log/pppd.log:



AT
OK
AT+CGDCONT=1,"IP","web.omnitel.it"
OK
ATDT*99#
CONNECT
Serial connection established.
using channel 1
Using interface ppp0
Connect: ppp0 <--> /dev/usb/ttyACM0
sent [LCP ConfReq id=0x1 ]
rcvd [LCP ConfAck id=0x1 ]
rcvd [LCP ConfReq id=0x1 ]
sent [LCP ConfAck id=0x1 ]
sent [LCP EchoReq id=0x0 magic=0x9dc63d95]
sent [PAP AuthReq id=0x1 user="anything" password=]
rcvd [LCP EchoRep id=0x0 magic=0x11a80f0]
rcvd [PAP AuthAck id=0x1]
PAP authentication succeeded
sent [IPCP ConfReq id=0x1 ]
sent [IPCP ConfReq id=0x1 ]
rcvd [IPCP ConfNak id=0x1 ]
sent [IPCP ConfReq id=0x2 ]
rcvd [IPCP ConfAck id=0x2 ]
rcvd [IPCP ConfReq id=0x2 ]
sent [IPCP ConfAck id=0x2 ]
Cannot determine ethernet address for proxy ARP
local IP address 83.225.139.145
remote IP address 192.168.100.101
Script /etc/ppp/ip-up started (pid 1873)
Script /etc/ppp/ip-up finished (pid 1873), status = 0x0
Terminating on signal 15
Connect time 0.3 minutes.
Sent 0 bytes, received 0 bytes.
Script /etc/ppp/ip-down started (pid 1904)
sent [LCP TermReq id=0x2 "User request"]
rcvd [LCP TermAck id=0x2 "User request"]
Connection terminated.
disconnect script failed
Waiting for 1 child processes...
script /etc/ppp/ip-down, pid 1904
Script /etc/ppp/ip-down finished (pid 1904), status = 0x0


.. Any idea?
Thanks indeed,
Rodolfo