I'm trying to connect to internet with a gprs cellular phone, a Motorola c350,
connected to my laptop Hyundai 255KI 15 with a mini usb cable.
Debian Sarge 3.1 is installed.
I've been following the howto at:

http://www.debianitalia.org/modules/...1&articleid=96

.. First I made sure the acm driver was there, with:

# dmesg |fgrep acm

.. Then I did:

# mknod /dev/usb/ttyACM0 c 166 0

.. Then I created a file /etc/pppd/peers/provider and filled it with:


# Speed
115200
# Use hardware flow control (i.e. RTS/CTS) to control the flow
# of data on the serial port.
crtscts
# Use the modem control lines.
modem
# Specifies that pppd should create a UUCP-style lock file for
# the serial device to ensure exclusive access to the device.
lock
# Disable Van Jacobson style TCP/IP header compression in both
# the transmit and the receive direction.
novj
# Disables the default behaviour when no local IP address is
# specified, which is to determine (if possible) the local IP
# address from the hostname.
noipdefault
# This option causes pppd to create such a default route when
# IPCP comes up, and delete it when the link is terminated.
defaultroute
disconnect '/usr/sbin/chat -e -f /etc/chatscripts/disconnect -v'
connect '/usr/sbin/chat -e -f /etc/chatscripts/provider -v'
/dev/usb/ttyACM0
user anything
password anything
#With this option, pppd will accept all control characters from the peer,including those marked in the receive asyncmap
receive-all
logfile "/var/log/pppd.log"
nobsdcomp
nodeflate



.. Then I created a file /etc/chatscripts/provider and filled it with:


'' AT
TIMEOUT 240
OK 'AT+CGDCONT=1,"IP","web.omnitel.it"'
OK ATDT*99#
TIMEOUT 22
CONNECT ""

.. Then I put "noauth" in place of "auth" in the file /etc/ppp/options.
Then I tried to connect with '# pon', but it couldn't be established:
this is the file /var/log/pppd.log:

AT
OK
AT+CGDCONT=1,"IP","web.omnitel.it"
OK
ATDT*99#
CONNECT
Serial connection established.
Using interface ppp0
Connect: ppp0 <--> /dev/usb/ttyACM0
PAP authentication succeeded
Cannot determine ethernet address for proxy ARP
local IP address 83.225.200.24
remote IP address 192.168.100.101
Terminating on signal 15
Connect time 0.5 minutes.
Sent 0 bytes, received 0 bytes.
Connection terminated.
disconnect script failed

.. The line 'Terminating on signal 15' shows that something is wrong.

Could anybody suggest a remedy?
Any help will be highly appreciated!
Rodolfo